HI, problems installing software to run Arduino

Ive just got my Sparkfun Arduino and I really keen to start using it..however..when installing the software from this site (version 18) the software does not extract (well the pc tells me it will take 5 hours to extract!) Ive also tried downloading ver 0017 but get the same result. I am working on Vista. Can someone please help???

Otherwise my board is going to be useless!!

the software does not extract (well the pc tells me it will take 5 hours to extract!)

5 hours to extract? or to download?

The version 18 zip file is a 85.5 M zip file. It took about 3.5 seconds to download, for me. Of course, that's using a T1 line, but, still it shouldn't take that long to download.

Do you have virus scanning software running? Microsoft software is notorious for not estimating how long anything will take. 5 hours jobs complete in 2 minutes. 30 second jobs take an hour and a half.

What kind of internet connection are you using?

Well I have high speed broadband connection, working fine otherwise.

I was using mozilla, changed to IE and downloaded the file ok. When I run the app I now get the following error..

Could not find the main class processing.app.base program will exit

Cant wait to get back to my Mac, he he. Any help appreciated. :'(

Well Ive decided to delete the last download and try it again. Now the DL stops at the last percent and the pc hangs.

Is there anybody who would be willing to email me a copy of 0018 file?

This would really help me out and let me get started.

damionleitch(AT)yahoo.co.uk Cheers!!

Microsoft time calculations: http://www.xkcd.com/612/

Now, about mailing the file - my email will not let me email 85meg files.

I don't think many peoples email will allow 85 meg files especially since the email encoding will make well over 100mb. Theres obviously something wrong at your end, I just downloaded the Windows version (95 seconds - not quite T1 class) No problem. Have you tried downloading it first, unzipping it to its own folder and then installing it locally ?

Scrubbing the computer and reinstalling windows will almost certainly fix it........

Heres an alternative download at my expense, its just a vanilla html download like the pukka version. Just give it another 20 minutes to finish uploaading before you try it :)

www.pluggy.me.uk/arduino-0018.zip

Install winrar or winzip, after that, dont know, using linux here.

XP doesn't need external software to handle zip files. They appear as folders with a zip across them. You can just right click and unnzip them to a 'real' folder with real files in it.

Trying your link now.....thanks for helpin me. Stand by!!!

XP doesn't need external software to handle zip files. They appear as folders with a zip across them. You can just right click and unnzip them to a 'real' folder with real files in it.

Oh how naive you are! XP's built in unzipper is pretty crippled from what I remember, they no doubt did a deal with WinZip. I've certainly encountered insanely slow zip extraction native to Windows XP - ugh!

Yes, you can use XP:s builtin unzipper, without any problems. To me it sounds like a full harddisk?

I'm naive because I say you don't need software to unzip zip files on XP ?

For people who don't unzip files for a living it works well, Its not fast, but it works. Installing some mega app with all its associated baggage isn't going to do the performance of the PC any favours especially if unzipping is something you rarely do. (Or on second thoughts, you'd better install some mega app to do it, so that people like me can make a living cleaning up your computer so it doesn't run like a slug on Valium )

I suspect the guys problems are related to an overloaded PC, installing software is like playing Russian roulette, the more you do it, the higher the risk of blowing the PC's brains out. Something I've learnt in my 25 professional years in this industry.......

XP doesn't need external software to handle zip files. They appear as folders with a zip across them. You can just right click and unnzip them to a 'real' folder with real files in it.

I think he may looking at the zipped file whose contents indeed look like normal folders and is then trying to run 'arduino.exe' from that zipped folder. He may not be doing what your last sentence says - unzipping the files to a real folder with real files in it and then running the real copy of 'arduino.exe'.

Don

disable your antivirus software...i had the same issue..damn norton.

ps i also used winzip instead of windoz zip

He's had six months to figure it out - I suspect everything is OK.

Don