Highspeed Flashtrigger

Hallo, Ich habe eine Frage, die hauptsächlich mit dem Aufbau einer Schaltung und weniger mit dem Arduino selbst zu tun hat. Aufgebaut habe ich das Schmitt Trigger Photogate. Wenn ich Pin3 des IC555 mit A0 verbinde und den Wert auslese bringt der Serial Monitor solange die Lichtschranke nicht durchbrochen wird den Wert 0. Wenn ich die Lichtschranke durchbreche (mit meinem Finger) wird ein Wert um 900 angezeigt. M.E. sollte dies aber umgekehrt sein ??? Auf Wassertropfen reagiert die LS absolut gar nicht (wofür sie eigentlich gedacht war). Kann mir jemand sagen, ob ich einen denkfehler habe? Wenn ich die ganze sache umschreibe und an einen digitalen pin gehe und diesen auslese ist es das gleiche spiel (nicht unterbrochen 0 unterbrochen 1).

Ich hoffe mir kann jemand weiterhelfen.

Gruss

High Speed Flash Trigger : http://www.elektor.com/magazines/2010/june/high-speed-flash-trigger.1352136.lynkx

Sound Activated Flash Trigger for High Speed Photography: http://coldsolder.wordpress.com/2010/04/20/sound-activated-flash-trigger-for-high-speed-photography/

Triggering a Camera's Flash with Sound and Light: http://www.glacialwanderer.com/hobbyrobotics/?p=11

Ok, Soweit war ich schon. Die seiten kenne ich, trifft allerdings mein problem nicht ganz, da mein Sensor (LS) eigentlich genau so aufgebaut ist. Mich wundern die Werte, die genau genommen "falsch herum" sind...

Kannst Du einen Link auf das Schaltbild posten?
Grüße Uwe

Orientiert hab ich mich daran.

Ich gehe aber direkt (ohne Thyristor) aus IC pin 3 auf: entweder Pin7 um dig. auszulesen oder auf a0 um analog auszulesen. Statt Thyristor benutze ich am Blitzausgang (der seperat angesteuert wird, also nicht über diese Schaltung) einen Optokoppler (Blitz funktioniert)

Ich bin gerade noch einmal den Plan durchgegangen, eigentlich gibt es nix, was ich (laie) falsch herum gelötet haben könnte (nur bei dem Poti bin ich mir im mom. nicht sicher, kann es aber nicht prüfen, da ich im Büro bin).

Danke fürs drüberschauen

ps. Wenn es eine andere möglichkeit gibt zu einem Ergebnis zu kommen bin ich auch bereit, diese Schaltung zu verwerfen bzw "umzulöten"

Mich wundern die Werte, die genau genommen "falsch herum" sind...

Wie währe es mit einer Invertierung des Ausgangssignals ?

Den wenn das Ergebnis exakt umgekehrt ist dann kann man es ja invertieren.

Sorry,
bin Laie und steh aufm Schlauch.
Wie soll ich das Ausgangssignal invertieren?

C-MOS IC 4069 DIP: http://www.conrad.de/ce/de/product/172952/C-MOS-IC-4069-DIP

http://www.produktinfo.conrad.com/datenblaetter/150000-174999/172952-da-01-en-4069.pdf

Was baut ihr denn da für absurdes Zeug? Ein Flashtrigger mit Arduino braucht eine Fotodiode, einen Optokoppler und das wars.

Wo wir schonmal beim Thema Arduino sind. Heist es nicht viele Wege führen nach Rom ?

Hallo aupex

Den NE555 hab ich noch nie gemocht. :(

Die Schaltung arbeitet richtig.

Hier wird der 555 als Schmitttrigger verwendet.

Der 555 hat intern eine Spannungsteiler aus 3 gleichen Widerständen, 2 Comparatoren und eine RS-Flipflop (RSFF).

Der eine Eingang des einen Comparators vergleicht ob bei pin 2 eine Spannung anliegt, die kleiner als 1/3 der Versorgungspannung ist und setzt das RSFF und den Ausgang 3 auf HIGH Der Eingang des 2.Comparators vergleicht die Spannung an pin 6 ob sie größer als 2/3 der Versorgungspannung ist und resetiert das FF und damit den Ausgang pin 3 auf LOW.

Wenn das Licht der LED auf den Fototransistor trifft leitet dieser und zieht die Pins 2 und 6 auf HIGH. Damit geht der Ausgang auf LOW.

Fällt kein Licht auf den Fototransitor so ist dieser hochohmig und das Potentiometer 10KOhm zieht die pins 2und 6 auf LOW. Der Ausgang 3 geht auf HIGH.

Also genau das was Dir passiert.

In der Schaltung wird dann der Tyristor mit eine positven Spannung (HIGH) gezündet und somit der externe Blitz.

Wenn Du möchtest, daß der Ausgang LOW wird wenn der Fototransistor abgedunkelt wird, dann tausche einfach den 10KOhm Potentiometer und den Fototransistor um. ( Emittor (Füßchen mit Pfeil) auf Masse, Kollektor auf eingänge und Poti zwischen 9V und Eingänge).

Du kannst auch die Schaltung so lassen und die Programmlogik ändern. (Lichtschranke unterbrochen -> Analogwert groß).

Alternativ kannst Du auch den NE555 weglassen und den Fototransistor - Potentiometer an den Arduino Analog - Eingang schalten.

Grüße Uwe

@aupex Wo ist eigentlich das Problem? Wenn Du das Eingangssignal eh im Arduino weiterverarbeitest, ist der Wert doch wurscht.

@apogee Das ist absolut kein absurdes Zeug. Über den Schmitt-Trigger hast Du die Möglichkeit, das Signal digital auszuwerten. Die Analogeingänge am Arduino sind bekanntlich nicht gerade die schnellsten.

Ich schliesse mich apogee an und denke auch das Projekt läuft nach dem Motto "Warum einfach wenn auch schwerer geht". apogee hat nur noch ein paar Widerstände unterschlagen... aber sonst würde ich mir den ganzen Zinober mit der NE555 Schaltung (und ich finde es ist ein geiler Stein mit dem man eine ganze Menge anstellen kann) sparen.

;-) Nene, das Projekt lief unter dem Motto : "Ich bau mir nen Hiviz-Trigger, der ist idiotensicher" und während dem Bau kam noch dazu :"Da gibbet ja was, dass die ganze Sache reproduzierbarere / komfortabler macht". Und da ich nicht unbedingt ein Electro-Freak bin (5+6 Klasse war da mal was ist aber schon ein weilchen her) und ich hier im Forum gesehen habe, dass es mit der o.g. Schaltung funktionieren sollte dachte ich so bei mir: "Warum net?" Ok, die Werte ankommen ist also schonmal gut und scheinbar auch soweit richtig. Dann wäre nur noch dass Problem, dass der Sensor nicht auf die Wassertropfen reagiert. Ich denke diesen fehler sollte ich hauptsächlich am Poti suchen. Richtig?

Gruss

Ja, für die Reaktion auf Wassertropfen muß die Schaltung genau abgeglichen sein. Am einfachsten ist es wenn Du ein Oszilloskop hast und die Werte des Fototransistors mißt.
Als einfachere Lösung rate ich Dir den Fototransistor - Poti direkt ohne 555 an den Arduino zu hängen und die Triggerschwelle über SW zu setzen.

Grüße Uwe

Danke, Also einfach gesagt vor icpin 6 das Signal abgreifen und an einen analogen Pin schicken. Richtig?

Nochmal sorry für die dummen Fragen.

ja, den poti für den Anfang voll aufdrehen und den 555 weglassen.
Grüße Uwe

Nochmal sorry für die dummen Fragen.

Beim Lernen gibt es keine dummen Fragen. Es gibt nur umständliche und schwerverständliche Erklärungen, die zudem auch noch lückenhaft sein könnnen ! Lieber einmal zuviel gefragt als einmal zuwenig, sonst könnte einem wichtiges Wissen fehlen !

Funktioniert.
Hatte ausversehen den 10k Poti am falschen Pin gelötet… Anfängerfehler… ::slight_smile:

Fotos folgen.

Gruss und danke an alle

tja, dann kann man natürlich keinen Fehler in der SW finden. Gratuliere zu Deiner ersten Korrektur. ;) Viele Grüße Uwe