How do voltage regulators fail?

I was setting up an LED array for a little project and once everything was in place on the BB I tested the LED's with 8 AA battery's running through a 7805A. I had resistors on my LED's and have used them on several different things without any problems.

I cooked 3 of them before realizing something was awry :fearful: I did something weird a few days ago and got this particular regulator/heatsink REALLY HOT but after cooling down it seemed OK.

Do these regulators sometimes fail and allow too much voltage to pass? I know anything's possible but I was wondering if there is a common failure mode. I changed to another regulator and all seems well.

I checked it and it's putting out 5v but something was screwy...

How much current were you drawing? Or put it another way, how many LEDs and what value resistors?

440 ohm. I have several LEDs with resistors attached that I use messing with stuff. I’ve used them over and over without issue. One of them actually pfft’d a little black streak in the diode, almost as if the regulator wasn’t even there.

Something sure happened and I want to avoid it in the future! I’ve been using these little VR’s to power my ATtiny 85 tinkering and I’d hate to cook one.

Any advice on powering devices with them? I always check voltage coming from them when hooking stuff up and assumed they’re pretty bulletproof.

A beefy regulator like you have should have no trouble staying in spec with 12 volts, and if all of your LED's had 440 ohms in series, seems to me, they should not have blown even with the full 12 volts.

How many LED's are you driving at once?

Just one LED at a time. I had them arrayed on the board and I was checking each one individually with a jumper from the regulator. Each one just blinked once and was dead.

Spooky! 12 V Dc through a 5 volt regulator to an LED with 440 ohms in series....

Did you check the resistance to make sure you did have 440 ohms? If that's good then the only seeming possibility is that you some how brought the current in past the resistance.

You don't have anything in the circuit that throw and inductance spike?

Did you have any capacitors on the input and output of the regulator? You need them to keep it stable.

440? is not a terribly common value. Are you sure? What is the color code?

Here is the first sentence from the National Semiconductor LM340/LM78MXX datasheet. Likely your regulator got too hot and shut itself down to avoid damage. You need to discover why that happened. Personally, I don't think I've ever seen a 78xx fail.

The LM140/LM340A/LM340/LM7800C monolithic 3-terminal positive voltage regulators employ internal current-limiting, thermal shutdown and safe-area compensation, making them essentially indestructible.

EDIT: 8xAA cells is overkill into a 7805. 6xAA is more than enough. The additional voltage will just be dissipated as heat. The regulator will run hotter than it needs to.

The resistors are yellow-yellow-brown-gold. I did have a 10 uf cap on the other part of the board which may have still been connected across the + and -... I took everything off the board when things got wonky and all seems well now.

If I accidentally had my jumpers hooked to the 12v from the batteries with the cap across them would that have blown the LED's? It's the only thing I can think of...

When it got hot I believe I had it plugged into the board backwards :astonished: I noticed it was getting REALLY WARM when I touched it. After it cooled off I checked it out and all was well again and I've used it a few times since without incident.

About the 8XAA, I'm just using it because it's convienent. I thought that the circuit wouldn't pull any more current through the VR than the circuit requires? I guess I'm misunderstanding some things.

Thanks for the help! I'd like to figure this out so it won't happen again in the future!

If I accidentally had my jumpers hooked to the 12v from the batteries with the cap across them would that have blown the LED's? It's the only thing I can think of...

Instantly.

Also, heat is the enemy of electronics parts... and while no damage may seem apparent after some abuse... the life of a part can be drastically shortend by allowing it to get overheated. Your regulator has some internal protection circuitry that makes it shut off when it gets to hot however, that circuit is not likely to perform well when the part is hooked up wrong...

hoff70:
The resistors are yellow-yellow-brown-gold.

Sounds like 440? ±5% all right, but 44 is not an E24 number (or even E192 for that matter). I suppose that anything is possible, but I'd check them with an ohmmeter to make sure.

I did have a 10 uf cap on the other part of the board which may have still been connected across the + and -... I took everything off the board when things got wonky and all seems well now.

Not understanding where this cap was. Either on the 12V before the regulator or on the 5V after the regulator should be fine.

About the 8XAA, I'm just using it because it's convienent. I thought that the circuit wouldn't pull any more current through the VR than the circuit requires? I guess I'm misunderstanding some things.

You are understanding correctly. But it's just that much more voltage that the regulator has to drop. The power that the regulator has to dissipate is the voltage it has to drop (12 - 5 = 7V in this case) times the current through it. The current will be the same regardless of the input voltage, all other things being equal. So if the circuit draws 100mA at 5V, the regulator will dissipate 7V x 0.1A = 0.7W with 12V input and 4V x 100mA = 0.4W with 9V input. So a 3V increase in the input voltage results in a 75% increase in the power the regulator dissipates.

Thanks for the help! I'd like to figure this out so it won't happen again in the future!

Sure thing, hope you do!

I had a LM317 adjustable voltage regulator fail recently. The output was set at 7.5 volts, but after a few hours it failed gracefully by going to zero. The problem must have been heat (4 Watts?). The supply was 24 volts dc, and the draw was 250 mA.

Yikes 4 watts? How big was the heatsink, Lol I guess not enough unless you had a fan going
I have one set up as a current source (1amp) so im dissapating like 1w I think and I got a small heatsink with a mini fan blowing to prevent it from getting uncomfortably hot next to its resistor also dissapating heat
and just doing a little math and some guesswork id guess your lm317 was immediately over 300°F explaining failure possibly

How big was the heatsink

Heatsink? what heatsink!? :blush:

It’s great fun when almost everything you do is a learning experience! I’m just glad the regulator failed the way it did, and there was no damage to my equipment.

I remember doing that with a 7805, back then I didn't even think about power dissapation, was wondering why it would get red hot at 12 input and 1a draw lol

Most voltage regulators ICs have built-in thermal protection. This means that if you don't have a big enough heatsink on them, they reduce the output voltage (and hence current draw) until the power dissipation is low enough to keep them within temperature limits. They recover if you turn the power off and let them cool down.

I had this happen to me when I was using a 7912 regulator bolted to a large piece of aluminium sheet as a heatsink. After a while, the output voltage would drop slightly and ripple started appearing on the output.Although the heatsink was quite large, the aluminium was too thin to carry the heat away fro the IC. Using a thicker gauge of aluminium cured the problem.