How I fixed: "avrdude: stk500_getsync(): not in sync: resp=0x00" / Attiny85

Greetings, Earlier today while messing around with some Attiny85's, out of the blue I started getting "avrdude: stk500_getsync(): not in sync: resp=0x00." :'{

I spent 3 long hours. . . digging through online remedies, reasoning, and theories but nothing I found worked. I knew my setup was correct or it was something beyond my control. Luckily, I eventually found a remedy. I can't tell you why it worked, but it did, and that is enough for me :D Adding you don't constantly have to switch Boards and programmers constantly just increasing the confusion with this. It should also help eliminate USB issues.

Just thought I'd share and maybe I can spare someone else the annoyance.

How to:

  1. Save your projects somewhere safe, and delete everything you got Arduino software wise. Fresh slate.

  2. Download the Arduino IDE 1.0.4 (

  3. Extract the contents and rename it to something like "IDE_Attiny". Then extract it again and rename it to "IDE_Arduino". The names don't matter but you want 2 complete IDE's in separate folders.

  4. Download ( and place the contents only in your "IDE_Attiny"'s hardware folder overwriting when prompted.

  5. Now start the 2, seperate Attiny and Arduino IDE's/.exe's. Windows you should have 2 separate IDE icons in the task bar.

  6. Setup your ArduinoISP example sketch in the .exe from the "IDE_Arduino" folders and upload. (Don't connect the Reset Cap, yet.)

Tools>Board=Arduino(*) COM=Whatever COM you use Programmer=AVR ISP (first option)

  1. Then setup your Attiny85 on the other "IDE_Attiny". Connect the Reset Cap. then upload.

Tools>Board>Attiny85(*) COM = COM Programmer=Arduino as ISP Burn Bootloader if you changed mhz

Visit this link if you need wiring assistance. (

Hope it helps somebody,

This solved the problem I was having. THANKS!

Woo-hoo! I found this post after I spent probably as much time as you did trying to fix this. But you saved me countless more hours - thanks!

dritchie, Whay OS are you using. Wondering if this would help under Squeezy Linux. TomJ

hey thanks for the post!!

i tried but i am getting avrdude: yikes invalid device signature error

some one please help me out....

Using Coding Badly's cores properly installed and the programming shield project from Adafruit I program tiny's with no issue I use the Arduino as ISP sketch and I can program Tiny's and Mega's (all) on the modified shield as well as 328's and anything else that has a 6 pin ISP connector. I have 3 boards 2 from Evil Mad Scientists and one from another source that has all the Arduino controller sockets on it and all works fine.


Hi, i tried this method, it did not work. The attiny85 worked for a few sketches then it just started giving this error. I tried to burn a bootloader using a 16mhz crystal and two caps of same value. I get the exact same error you mentioned. Please help.

? Anyone else fixed their software installation by "burying a root" ? :grin:

Seriously, such things as dual-installs really should not be considered a "fix". Rather they are workarounds the somehow produce one desirable effect while at the expense of reason and good installation practices.

I have used both Coding Badly's library and MIT and used them on 1.0, 1.0.1, 1.0.4, and 1.0.5 and have not had problems. I have multiple boards.txt files that I rename when I need to do something unusual with a new core processor. I only have the current installation on the hard drive, but I do keep the ZIP archieve of the previous installation on the network server.

While I appreciate "fix" it is really not that. More time needs to be spent with trying to understand what happened and how to properly address the issue without uninstalls, installs, and dual-installations.


I created an account just to thank you