Can i have step by Step instruction to burn bootloader in atmega8.

i Have Arduino328, and i want to load bootloader in atmega8, after loading bootlader in atmega8 i want to run program on standalone board, m using

atmega8 to reduce my project cost, i have completed all steps as per below lin

and i got successful loading message, but i don't know why my atmega8 is not working, i removed my atmega328 chip from my board and i

connect my atmega8 chip on board, m able to load blink program on my arduino but after loading program my LED blinking not work.

let me know solution


Loading a bootloader on the ATmega8 is tha same as loading a bootloader on the Atmega328P except you select the board "Arduino NG or older w/ ATmega8" instead of "Arduino Uno" or "Arduino Duemilanove w/ ATmega328".


Thanks johnwasser for reply,

Right i have selected "Arduino NG or older w/ ATmega8" after loading bootloader in atmega8,

m got Bootloader burning successful message = ok
Program loading/uploading successful message = ok
Led showing correct status while loading program.(Blinking Tx, Rx Leds are correctly )

but why my led program is not working after loading program??????? i am testing blink led program on my board, is there any special setting or any setup while we are using Atmega8 on arduino328 board...

(i am testing my mega8 chip on mega328 board)

I can't think of any reason for the LED not to work. The digital pin 13 is Port B bit 5, just like on the ATmega328 and that is connected to chip pin 19 just like on the ATmega328. If you put a meter on pin 19 of the chip does it go on and off?

Hi johnwasser,

Please check video n tell me anything following wrongly?????

everything showing ok than what is problem???

have u seen bootloader instruction which i have mentioned on my previous reply????

or anything is missing in instruction which i followed(Bootload an ATmega328 : 7 Steps - Instructables)

See this video for more clarity...

See this video for more clarity...
- YouTube

Your board is labeled "Areduino" or maybe "Araduino". I don't know if that board has design differences that might cause a problem.

You have a bunch of wires connected to your "Areduino". Try disconnecting everything but the USB cable to see if that helps.

See this video for more clarity...
- YouTube

It certainly looks like burning the bootloader and uploading the sketch worked fine, making this a "why isn't BLINK working?" question. As John points out, your board is far from being a "standard" Arduino; are you sure that the on-board LED is connected to the same pin? (it does blink after the reset, which is normal (though it blinks a bit weird (probably a video artifact))

thanks for reply,

As u know Arduino is OPEN SOURCE, i have purchase board from local market n make , and the have printed their name on this board,

many examples are working on my board(with original mega328 which come with my board) without any problem,

i tried firmata, blink led , push button, etc....

are you sure that the on-board LED is connected to the same pin?

ya its perfectly working with my original mega328 n default blink led program without any change....

k today ll upload video with both mega8 and 32...

i hop this will help to understand....

Could you post the full compile/upload log (with “verbose” on) created when you upload the sketch?

Since you were apparently successful uploading the bootloader, you could try uploading optiboot instead.
I would not really expect this to change anything, but I suspect that the ATmega8 bootloader hasn’t been looked at in a long time… (For example, the pin13 LED blinks immediate AFTER your upload. Optiboot wouldn’t do that; it would just start the sketch. It COULD be the way that the ATmega8 bootloader starts sketches (restart the bootloader and let it time out), or it could be the sign of something more mysterious happening.)

Thanks westfw,

I am beginner for arduino...

please tell me two thing,

from where i can get compile/upload log (with "verbose" on)?

and what is optiboot???? can i have some steps for this ??????


Can any one tell me baby step to burn bootloader in atmega8 ???

with all smallest steps…???