How to Reset Fuse of Arduino Mega 2560 and Mega16U ?

Hello guys,

Few days back i was playing with mega 2560, but accidentally i think i have blows mega 2560 fuse bits as i was uploading some other hex file to it. I have gone through google and some people suggest to do high voltage programming of atmega 2560 chip which can recover the chip back if the issue is due to wrong fuse bits.

Can you please suggest how to connect atmega 2560 to AVR Dragon for high voltage programming ? I have blown up atmega 2560, AVR Dragon, AVR Dude, Atmel studio 7.0, etc...

So you played with something else then Arduino IDE when you uploaded a hex (because Arduino IDE can not do that). If so, you might have erased/disabled the bootloader. Did you try to simple reburn it?

And high voltage programming, just connect the ISP header to the Dragon... But you probably have to tell the uploading program to use HV mode.


Great catch. Yea, i used avr dude to upload hex file to arduino mega 2560 using usbasp programmer. I tried to reburn the boot loader which worked for first time and then again i tried to upload hex file and this failed. After that i am not able to reburn the boot loader. AVR dude and Arduino IDE has same error message. It says device signagure is 0x000000. Same thing i tried to do on Atmega16U2 usb to serial chip on same arduino mega 2560 board. That to failed.

So i have blown mega 2560 and mega16U2 on the usb side. I will give a high voltage shot to it.

Did you ever resolve this? I did the same damn thing and messed up my 2560.