How to run wpa_supplicant with -d or -dd option for better logging?

I can’t figure out where this process is launched:

 1137 root      1904 S    wpa_supplicant -B -P /var/run/ -D nl80211 -i wlan0 -c /var/run/wpa_supplicant-wlan0.conf

I’d like to run it with -d to do some debugging.

Related: OpenWrt Forum Archive

Try this:

  • edit file: /etc/config/wireless
  • find this section: config wifi-device radio0
  • at the end of the above section, add this new line: option log_level x
    where x = 0 for verbose debugging or x = 1 for debugging (the default value may be 2)

As per this web page: Wireless configuration [Old OpenWrt Wiki]

Thanks... this is great.

Although, logread -f doesn't seem to show anything more with that log_level set to 1 or 0 (restarted wifi as well). Maybe this isn't where I should see the increased logging?

Did some more digging. Edit and goto the end of this file: /lib/wifi/

As a warning though if this still doesn't work, this may explain why:

Ah, I was afraid of having to make my own image. I've come across is this but haven't tried it yet: Building a custom image for Arduino YUN