how to set "programmer" for Arduino MICRO

Hello,
I Just received a Micro (clone form aliexpress) ;
I immediatly run blink, add Serial print debug and send a character to computer via Keyboard. All was fine.
But now, I am unable to upload the sketch.
I suppose I have badly changed the programmer item in menu Tools.

Please, anybody could indicate the correct setting?

Regards.
PO.

flavigny:
I suppose I have badly changed the programmer item in menu Tools.

Please, anybody could indicate the correct setting?

The Tools > Programmer only matters if you’re doing Tools > Burn Bootloader or Sketch > Upload Using Programmer. For normal uploads over USB the setting of Tools > Programmer doesn’t make a difference.

Please do:

  • File > Preferences > Show Verbose output during upload(check).
  • Attempt to upload a sketch
  • After the upload fails there should be a button Copy error messages on the right side of the orange bar. Click this button.
  • Paste the error messages in a message here using code tags(</> button on the toolbar).
  • If there is no Copy error messages button then select everything in the black console window at the bottom of the Arduino IDE window and paste it in a message here using code tags.

Thank for your reply,
it seems that IDE is searching for an external programmer (usbTinyISP is currently checked)
I have tried to nullify programmer= in preference.txt, then IDE complains abouit it.
Regards.
PO.

here is the error window:

Sketch uses 6,918 bytes (24%) of program storage space. Maximum is 28,672 bytes.
Global variables use 252 bytes (9%) of dynamic memory, leaving 2,308 bytes for local variables. Maximum is 2,560 bytes.
C:\Users\adminpo\Desktop\ARDUINO\arduino-1.6.8\hardware\tools\avr/bin/avrdude -CC:\Users\adminpo\Desktop\ARDUINO\arduino-1.6.8\hardware\tools\avr/etc/avrdude.conf -v -patmega32u4 -cusbtiny -Uflash:w:C:\Users\adminpo\AppData\Local\Temp\builda91d45d9bb79fd254c1169ec8eadcc87.tmp/po.ino.hex:i

avrdude: Version 6.0.1, compiled on Apr 15 2015 at 19:59:58
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "C:\Users\adminpo\Desktop\ARDUINO\arduino-1.6.8\hardware\tools\avr/etc/avrdude.conf"

Using Port : usb
Using Programmer : usbtiny
avrdude: Error: Could not find USBtiny device (0x1781/0xc9f)

avrdude done. Thank you.

Which board do you have selected in Tools > Board?

Arduiono micro of course,
see prtscrn attached
regards
PO.

arduinomicro.jpg

Ok, I just had to check because some boards do automatically use that programmer but not the Arduino/Genuino Micro. Try doing Sketch > Upload instead of clicking the arrow button and let me know if that helps.

I notice you're using an outdated hourly build. Unless you have good reason to be using that version of the IDE I recommend you upgrade to 1.6.9. If you want to use the hourly build for beta testing, etc then you should probably install the latest one.

hello,
it is better, no more error about searching a device matching Vid/Pid ,
for my, COM17 is the “normal” tty for the duino, but at reset a see temporary Com23 “loader”
I suppose that remote reset does’nt run and I have to play with reset to present Com23 at time when upload starts.
here is the error window:

Sketch uses 6,918 bytes (24%) of program storage space. Maximum is 28,672 bytes.
Global variables use 252 bytes (9%) of dynamic memory, leaving 2,308 bytes for local variables. Maximum is 2,560 bytes.
Forcing reset using 1200bps open/close on port COM17
PORTS {COM1, COM17, } / {COM1, COM17, } => {}
PORTS {COM1, COM17, } / {COM1, COM17, } => {}
PORTS {COM1, COM17, } / {COM1, COM17, } => {}
PORTS {COM1, COM17, } / {COM1, COM17, } => {}
PORTS {COM1, COM17, } / {COM1, COM17, } => {}
PORTS {COM1, COM17, } / {COM1, COM17, } => {}
PORTS {COM1, COM17, } / {COM1, COM17, } => {}
PORTS {COM1, COM17, } / {COM1, COM17, } => {}
PORTS {COM1, COM17, } / {COM1, COM17, } => {}
PORTS {COM1, COM17, } / {COM1, COM17, } => {}
PORTS {COM1, COM17, } / {COM1, COM17, } => {}
PORTS {COM1, COM17, } / {COM1, COM17, } => {}
PORTS {COM1, COM17, } / {COM1, COM17, } => {}
PORTS {COM1, COM17, } / {COM1, COM17, } => {}
PORTS {COM1, COM17, } / {COM1, COM17, } => {}
PORTS {COM1, COM17, } / {COM1, COM17, } => {}
PORTS {COM1, COM17, } / {COM1, COM17, } => {}
PORTS {COM1, COM17, } / {COM1, COM17, } => {}
PORTS {COM1, COM17, } / {COM1, COM17, } => {}
PORTS {COM1, COM17, } / {COM1, COM17, } => {}
Uploading using selected port: COM17
C:\Users\adminpo\Desktop\ARDUINO\arduino-1.6.8\hardware\tools\avr/bin/avrdude -CC:\Users\adminpo\Desktop\ARDUINO\arduino-1.6.8\hardware\tools\avr/etc/avrdude.conf -v -patmega32u4 -cavr109 -PCOM17 -b57600 -D -Uflash:w:C:\Users\adminpo\AppData\Local\Temp\builda91d45d9bb79fd254c1169ec8eadcc87.tmp/po.ino.hex:i

avrdude: Version 6.0.1, compiled on Apr 15 2015 at 19:59:58
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is “C:\Users\adminpo\Desktop\ARDUINO\arduino-1.6.8\hardware\tools\avr/etc/avrdude.conf”

Using Port : COM17
Using Programmer : avr109
Overriding Baud Rate : 57600
AVR Part : ATmega32U4
Chip Erase delay : 9000 us
PAGEL : PD7
BS2 : PA0
RESET disposition : dedicated
RETRY pulse : SCK
serial program mode : yes
parallel program mode : yes
Timeout : 200
StabDelay : 100
CmdexeDelay : 25
SyncLoops : 32
ByteDelay : 0
PollIndex : 3
PollValue : 0x53
Memory Detail :

Block Poll Page Polled
Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack


eeprom 65 20 4 0 no 1024 4 0 9000 9000 0x00 0x00
flash 65 6 128 0 yes 32768 128 256 4500 4500 0x00 0x00
lfuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
hfuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
efuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
lock 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
calibration 0 0 0 0 no 1 0 0 0 0 0x00 0x00
signature 0 0 0 0 no 3 0 0 0 0 0x00 0x00

Programmer Type : butterfly
Description : Atmel AppNote AVR109 Boot Loader

Connecting to programmer: .
avrdude: butterfly_recv(): programmer is not responding
Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

Here's what I think the problem is: if you press shift while you click the Upload button(the right pointing arrow) it changes from Upload to Upload Using Programmer. You can see the text to the right of the button when you hover over the upload button, if it says "Upload Using Programmer" that's what's happening. I suspect that the program you ran on your Micro emulated the pressing of the shift key on your keyboard and either it kept pressing it over and over again or it just got stuck pressed down. So hopefully once you upload another sketch this will no longer be a problem or I have occasionally had keys get "stuck" from emulated keystrokes and had to restart the computer to fix the problem.

flavigny:
COM17 is the "normal" tty for the duino, but at reset a see temporary Com23 "loader"

That's the normal, expected behavior of a Micro, Pro Micro, or Leonardo.

hello,
thanks, you are right about the origin of "abusively using programmer". I have rebooted and it disapears.
I suppose some interference with other program, I have a lot of aids for visualy impaired that use hooks to the keyboard.
I have added "RESOLVED" on title, is it a flag to set to do this?.

Now I will dig about reset by on/off at1200 bps not running.
I do some tries and start a new topic if needed;

PO.

Glad to hear it's working now!

flavigny:
I have added "RESOLVED" on title, is it a flag to set to do this?.

That's a very helpful thing to do but you need to edit the first comment of the thread by clicking the "Quick Edit" button on the bottom right of that comment, edit the title, and then click "Save". That will change the title shown in the topic listing. Most people don't take the time to do that but it is one of the forum rules and it's really a good idea because then other forum members won't waste time reading through the thread to see if they can help because they can see from the title that it's been solved. That will give them more time to help with your other issue :slight_smile: . Thanks!