How to use seeeduino XIAO in jetson nano

Hi,
I want to use seeeduino in jetson nano.

So,I tried to install Additional Boards Manager of XIAO.

I looked at this site and tried.
https://wiki.seeedstudio.com/Seeeduino-XIAO/#software

But, I got a warning when I was installing Seeed SAMD Boards and I can’t install it.

tool bossac is not available for your operating

So, I want to know if there is a solution.

Run the IDE on something other than a Jetson Nano?
Manually install bossac from source?
Remove the OS check from the bossac install and see it it works anyway?

Remove the OS check from the bossac install and see it it works anyway?

As for this one, I have done it before by making a custom Boards Manager package index that is just a slightly modified version of the standard one (the Seeed one in this case). You have to add an additional element to the systems field that is a copy of the x86-64 Linux system element, except with the host value modified (to aarch64-linux-gnu in this case).

I believe you can use the file:// schema in the additional Boards Manager URL field to host the package index file on your local system. Otherwise, just put it somewhere public on the Internet (e.g., a GitHub Gist).

Info here:
https://arduino.github.io/arduino-cli/latest/package_index_json-specification/#tools-definitions

Kind of interesting to play around with if you are into that sort of thing, but definitely a long shot for it to actually work. You will come out of it at least with the useless tools as placeholders, which makes it easy to understand which folders you need to put the working replacements in.