I bought a UNO R3 ATmega328P CH340G USB Driver Development Board

I bought a UNO R3 ATmega328P CH340G USB Driver Development Board from here:

http://www.ebay.com/itm/381042306619

When connecting it only comes up as a usb 2.0 serial port, I am unable to connect. when I try to install a driver it can't find one. I wondering if a bought the right board?

An Arduino factory Uno SMD is 30 USD from Sparkfun; I'd be suspicious of a 5 USD board.

But then I don't actually know what "USB Driver Development Board" means. Is it meant to be a Uno compatible device?- it certainly looks like one.

You need the CH340 serial driver from here. (This is the CH340 manufacturer's chinese site, I can't find the download on the english site)

The best place to get the drivers from is the Chinese site, it will be the most up to date.

Thanks

i was able to download a driver and now have the board working

Thanks for helpful topic! I thought the board was broken... better to buy original?

Bye

scirr26: Thanks for helpful topic! I thought the board was broken... better to buy original?

Bye

Depends on how much you want to spend. When we sell boards like this we put a link to the drivers in the listings and most people get one with them fine.

If anyone is looking for help with this board...

http://kiguino.moos.io/2014/12/31/how-to-use-arduino-nano-mini-pro-with-CH340G-on-mac-osx-yosemite.html

It worked perfectly for me... The USB to Serial comm is little slower than Regular 328 based UNO but works. If your app uses lot of USB2Ser comm, then this is not for you.

Hope this helps!

I cussed my pair of Chinese clones of the Arduino Micro with a CH340G for about 5 hours. It turned out a 2 minute trip to my garage to find a different USB cable solved the problem. Go figure!

Brandon

I bought a similar one, it works fine using Linux (Mint)

os x 10.9.3
latest arduino 1.6.3

installed as per instructions

serial port not showing in /dev directory and all arduino is giving me is as per attached image

also at the bottom of the arduino window it says:

arduino uno connected on /dev/tty.usbserial-A700eeQZ which is NOT in the list of available ports?

any help greatly appreciated

Screen Shot 2015-04-07 at 4.31.43 pm.png

hi all, problem solved. Found a more up to date driver through this forum and instructions here:

http://kiguino.moos.io/2014/12/31/how-to-use-arduino-nano-mini-pro-with-CH340G-on-mac-osx-yosemite.html

Now appears to be working.

Greg :)

Hello All,

I am a regular buyer/user in India, of Arduino boards of all varieties, since 2011. This is first time I bought a low cost, about $7 Arduino Uno clone from eBay.in. It had a few nice things besides low price - additional holes to mount male pins, on all connectors, adjacent to female header, so that we can use female-to-female connectors to link up other Indian accessories having male header pins. There were extra holes next to ICSP connector for Tx, Rx, +5V, 3.3V and SCL, SDA.

I had an issue with USB device driver. I quickly zeroed in on this topic and downloaded driver file from link given for Chinese manufacturer. After installing the driver, I had to disconnect and reconnect the board and then everything was fine.

I mostly use the board for training my students so it is a great buy at this low price.

BTW, I purchased two Unos in Micro Center shop in Houston, USA, two months back for $6 each. They were selling Arduino Mega for $10 and Raspberry Pi for $20. So I believe nobody should now need to pay $30 for an Arduino.

Best wishes.

-P W Dandekar

Here's another driver acquisition choice. I used the WIN7 version and it seems to work well. They also offer a Linux driver. http://www.5v.ru/ch340g.htm

Hi,

I got my Arduino UNO clone working ok thanks to the CH340 USB drivers. Does anyone have any info on getting the circuit schematic?

Thanks.

You will not find an accurate CH340G UNO schematic. There are many makers of the boards and so many different boards, even if you found one you would have no way to tell if it was the right schematic for your particular board. You can start with the official Arduino Uno schematic (google for "Arduino Uno schematic") and use it as a general reference. Keep in mind your board will have a different USB-to-serial section because the IC and supporting circuitry is different. And your board may also have a different power supply section, and it may or may not have the buffering of the pin 13 LED.

If you want something accurate, trace out the board using an ohm meter and magnifying glass, and go ahead and draw up the schematic. An Arduino is nothing more than a breakout board for an ATMEL processor, with minimal support circuitry such as decoupling capacitors, power supply, and USB-to-serial chip. Most of the support circuitry is just for convenience, and not 100% necessary.

Those are clones (the ones with CH340G’s definitely are - they’re also not really Uno’s either, since one of the things that set the Uno apart was that it used a reprogrammalble 16u2 for the usb-serial adapter; though nobody really takes advantage of that) - the reason they are so cheap is that none of the money is going back to Arduino to support development of the software. I recommend donating some $ to Arduino if you don’t buy official boards.

Circuit diagrams for clones? You can try asking the vendor - they may have them.
Schematics for the official Uno can be found at https://www.arduino.cc/en/Main/ArduinoBoardUno - but there is no comprehensive resource for the third party clones; different manufacturers use slightly different designs.

Hi,

I'm new on arduino! I have buy this too on amazon and I have error message: Arduino : 1.6.7 (Windows 7), Carte : "Arduino/Genuino Uno"

Le croquis utilise 1 018 octets (3%) de l'espace de stockage de programmes. Le maximum est de 32 256 octets. Les variables globales utilisent 9 octets (0%) de mémoire dynamique, ce qui laisse 2 039 octets pour les variables locales. Le maximum est de 2 048 octets. avrdude: ser_open(): can't open device "\.\COM1": Le fichier spécifié est introuvable.

Problème de téléversement vers la carte. Voir http://www.arduino.cc/en/Guide/Troubleshooting#upload pour suggestions.

Ce rapport contiendrait plus d'informations si l'option "Montrer les informations de sortie pendant la compilation" était activée dans Fichier > Préférences.

Perhaps I have a problem with the driver too but I can't download it because my antivirus block it.

If anybody have an Idea It could Be good than you.

Easy to check, just open op Windows Device Manager. Is there a device with a ! when you plug in the Arduino?

And are you sure COM1 is the right com port?

And like people said, it's easy to spot if you have a Arduino clone with a CH341 (apart from the price). Just look for a chip with CH341 on it (probably near the USB).

If you have one you need the driver. Where do you try to download it? http://www.wch.cn/download/CH341SER_EXE.html is the link to the driver page of the manufacturer. If you can't download it from that link because of you're antivirus you're antivirus is a piece of *** ::) Just disable the antivirus to download it then (and consider a better/less paranoid antivirus, I think Windows Defender does a fine job nowadays).

Thank you for you quick answer, I have CH340 near the usb.

Yes I have ! in device manager.

My antivirus is provide by my job, I have to use my personal computer to upload the file I'll try this evening.

Thank you septillon