I cannot upload sketch in my Arduino.(Inappropriate ioctl for device.)




Hi Good Day. I am a new user of Arduino.

I bought it online, and came here March 8, 2016.

Board: Arduino Uno R3 SMD

I already tried it first on Windows 10 and it works (blinking).

But when I tried it on my MacBook Air Yosemite 10.10.2, I cannot upload any sketch :frowning:
Gosh, I tried some troubleshooting but it doesnt work. Please help me instructively to fix my problem.
Thank you. I really appreciate your time and effort to help.

You can email me if you wanted: tknfrgrntd@gmail.com :confused: :slightly_frowning_face:

Have you restarted the computer? I will tell that a lot of people are having issues with the latest Mac and drivers.

Yes I tried it several times but still doesnt work. Can you give me any suggestion regarding my problem?

And for addition, I also had a problem regarding my arduino in installing it to Windows 8 and below. I do not know if it is the Port of the laptop or something, but when I check the Device Manager, it only Show "USB Serial.... etc", instead of "Arduino" or "Unknown Device", I also cannot install or update the said device. Please help me. Thanks a lot.

Please help me.