I cant get Arduino to start

I have a Macbook air 2017 Mojave 10.14.6. It won't start up, the moment I click the icon it pops up this small window saying "utilizing packages" and it shut down right after. I tried to restart my Mac and it did not work, then I tried to reinstall Arduino but that did not work either.

Can anybody help and solve my problem?

When you uninstalled the Arduino IDE did you delete the following files.

The Arduino IDE uses files in three locations on your computer:

  • IDE installation folder
  • Sketchbook folder, located in the Arduino IDE at File > Preferences > Sketchbook location
  • Data folder
    • On Windows
      • Standard IDE: C:\Users\{username}\AppData\Local\Arduino15
      • Windows app: C:\Users\{username}\Documents\ArduinoData\packages
    • macOS: /Users/{username}/Library/Arduino15
    • Linux: ~/.arduino15

When you use the uninstaller, only the IDE installation folder will be removed, so after reinstalling, the files left over in the other locations will still affect the new installation.

Deleting the data folder can often solve problems with the Arduino IDE not starting or failing compilation in unexpected ways.

  1. Look for the data folder Arduino15 (depending on OS) which is usually hidden and delete it. In order to show the hidden folders, you can check the box in: Start > File explorer > View > Show/hide advanced settings > check Hidden items
  2. Now, you can uninstall the Arduino IDE and no files will be left.

I'm not familiar with a Mac.

One usual option for debugging is to navigate (on a command prompt) to the directory where the IDE is installed and run the IDE from the command prompt. I will probably give you some additional information that might be helpfull.

Not sure if this can be done on a Mac.

Thank you.
It started to work now.

1 Like

I already got the help that I needed.
Thank you anyways for offering help.