I cant upload any code to my Arduino

Hello guys I'm totally new to arduino.I just bought new arduino and was trying some sample codes to understand how this works.However, something went wrong and I cant upload any code to my arduino.

the error report :avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x52 avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x20 avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x49 avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x53 avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x50 avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x10 avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x52 avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x20 avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x49 avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x53

and when ı try to upload a code holding shift key: avrdude: usbdev_open(): did not find any USB device "usb"

Note:I think there is something more to talk about.I was trying codes with my ultrasonic sensor and when I connected it to my arduino turns off. I want to know if this has damaged my arduino-hopefuly didnt :(-.

And the Important thing ı want to know is what this is related to.I just want to understand whether this physical or systematical problem.If you help me I'd be so thankful .

First, try to focus to the message "avrdude: usbdev_open(): did not find any USB device "usb"". Is the device present in OS? Disconnect all other devices form Arduino before next try. Provide more details: OS, exact type of Arduino.