I can't upload to io board(in Linux)...

Hi,

I have instaled arduino-003 in a Debian stable(kernel 2.6.15), but the option tools->serialPort is not activated, so when i try to upload a program apears a messaje of error:

Error: No such file or directory -> com1

I have loaded the module ftdi_sio, and i did a symlink: ln -s /dev/ttyUSB0 /dev/ttyS99 (or 5,9...) but...it doesnt works :(

greetis. miguel.

Sounds like your RXTX serial library isn't installed properly. Did you follow the instructions here? http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1129025529/20#20

Particulary, "5. install rxtx for Java".

Alternatively, you could try searching your preferences.txt file (to find it, open the Preferences dialog box from the menu within the Arduino IDE) for "com1" and replacing it with the full path to your Arduino serial device, e.g. "/dev/tty.S99". You may still get some errors when uploading, but it might work anyway.

I reinstalled Arduino ide folowing the instructions that you comment, but now the problem is other, when i type ./run.sh the error message is:

./arduino: line 22: java: command not found

when i did the ./make.sh the output was:

... Copying dist files... /bin/avr-gcc -g -Wall -Os -mmcu=atmega8 -Datmega8 -DF_CPU=16000000 -DBAUD_RATE=19200 -I/include -c -o ATmegaBOOT.o ATmegaBOOT.c make: /bin/avr-gcc: No se encontrĂ³ el programa make: *** [ATmegaBOOT.o] Error 127 Building antlr grammar code... ./make.sh: line 84: java: command not found ./make.sh: line 86: java: command not found ./make.sh: line 87: java: command not found ./make.sh: line 88: java: command not found Building the PDE...

Issued 1 semantic warning compiling "preproc/WParser.java":

  1. int traceDepth = 0; ^--------^ *** Semantic Warning: Field "traceDepth" shadows a field of the same name in "antlr.Parser".

Issued 5 semantic warnings compiling "preproc/TNode.java":

  1. TNode down = (TNode)getFirstChild(); ^--^ *** Semantic Warning: Local "down" shadows a field of the same name in "antlr.BaseAST". ...

Im lost :(

Thanks. miguel.

miguel

all those java not found messages means that either java is not installed or your script can't find it! make sure java is installed and JAVA_HOME is defined

massimo

I have solved the problem this morning changing the script, but i didnt have conecction to internet(sorry).

Now the ide recognices the device. :)

thanks very much. miguel.