I Can't Upload To Nano Every

So when i try to upload code to my arduino nano every it just sits on upload for ever. If i retry it i get this error: Arduino: 1.8.15 (Windows 10), Board: "Arduino Nano Every, None (ATMEGA4809)"

Sketch uses 1118 bytes (2%) of program storage space. Maximum is 49152 bytes.

Global variables use 22 bytes (0%) of dynamic memory, leaving 6122 bytes for local variables. Maximum is 6144 bytes.

processing.app.debug.RunnerException

at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:152)

at cc.arduino.UploaderUtils.upload(UploaderUtils.java:77)

at processing.app.SketchController.upload(SketchController.java:732)

at processing.app.SketchController.exportApplet(SketchController.java:703)

at processing.app.Editor$UploadHandler.run(Editor.java:2055)

at java.lang.Thread.run(Thread.java:748)

Caused by: processing.app.SerialException: Error touching serial port 'COM18'.

at processing.app.Serial.touchForCDCReset(Serial.java:107)

at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:136)

... 5 more

Caused by: jssc.SerialPortException: Port name - COM18; Method name - openPort(); Exception type - Port busy.

at jssc.SerialPort.openPort(SerialPort.java:164)

at processing.app.Serial.touchForCDCReset(Serial.java:101)

... 6 more

An error occurred while uploading the sketch

Exception in thread "Thread-269" java.util.ConcurrentModificationException

at java.util.LinkedList$LLSpliterator.forEachRemaining(LinkedList.java:1239)

at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:481)

at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:471)

at java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:151)

at java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:174)

at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)

at java.util.stream.ReferencePipeline.forEach(ReferencePipeline.java:418)

at cc.arduino.contributions.libraries.LibrariesIndexer.rescanLibraries(LibrariesIndexer.java:169)

at processing.app.BaseNoGui.onBoardOrPortChange(BaseNoGui.java:681)

at processing.app.Base.onBoardOrPortChange(Base.java:1345)

at processing.app.Editor$UploadHandler.run(Editor.java:2091)

at java.lang.Thread.run(Thread.java:748)

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

i tried everything, restarted my pc, reseting the board, unpluging and repluging the board, trying different com ports. Etc. Also the orange light doesn't turn on and i can't upload code for it to blink. Any help would be appreciated.

Is Nano Every recognized correctly from windows?
Open Device Manager and connect Nano Every to USB while looking at the COM port list.
Will appear new COM ports?

If newer appeared, select the that COM port number in the Arduino IDE and do upload.

I just tried that, is dissapered when i disconnected it and when i reconnected it it reappeared and i reselected the com port in ide and the same failure happened

This means that the COM port that connects to Nano Every has already been opened by someone other than the Arduino IDE and the Arduino IDE could not be attached that ports.

It's hard to think of an any application that connects to a newly connected port at all right away, so I'm not sure anymore... :thinking:

Alright i'll keep trying things. Thanks for the help so far.

megaAVR core (for Nano Every , UNO WiFi Rev 2) is strangely designed and to upload, be sure

  1. Open the correct Port in Arduino IDE after connect Nano Every to USB with power
  2. Close the Arduino IDE Serial Monitor <=== This is important
  3. Upload
  4. Open the Arduino IDE Serial Monitor for terminal debugging

The code can't be uploaded if Serial Monitor is open. This is very different from any other core.

i tried that. Same exact results

It's possible there is problem with your damaged board / bootloader, Arduino IDE or even Windows (virus, corrupted files, etc.). Only you can isolate the issue.

Good Luck,

just had this exact problem and wanted to comment here. Cura caused my port to be busy after closing it my issue was fixed

yeah i just bought a micro instead