I have the 328-PU, got the boot loader on, but now I get "not in sync"

Hello,

I have an Arduino Uno board. I programmed with the included chip, but I fried it on a breadboard application. So I bought some ATmega328-PU chips from digi-key. These did not have the bootloader on them.

I used this guide: http://forum.arduino.cc/index.php?topic=58670.0

And I was able to get the bootloader on this chip (I used ATmegaBOOT_168_atmega328.hex)

Now, I'm trying to upload code to the chip normally using the Uno, but I get the following errors:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xad

Any idea what the issue may be?

As a clarification:

  • I have tried to put a 110 resistor between RESET and 5V, and it still does not work.

  • I have tried to put a 10uF resistor between 5V and ground, and it still does not work.

  • I made sure to change 14 back to 0F in the configuration file after I got the bootloader working.

  • I have NOT verified that the Bootloader is actually working though... How would I do this?

The UNO doesn't use ATmegaBOOT_168_atmega328.hex. See boards.txt:

uno328.bootloader.path=optiboot
uno328.bootloader.file=optiboot_atmega328.hex