I have This Relay and i Cannot Figure out why it won't get power

I tried hooking it up to 5V, GND and pin 3, There is an LED that should be on to indicate it does have power going to it, but i will NOT turn on, any suggestions

Have you tried the digital pin high and low? Maybe the led only comes on when the relay is energised (as opposed to getting power to the module) and that will depend on the state of the digital pin.

You could test the relay itself, if you can access the soldered pins coming straight out of the relay on the back of the pcb, by applying 5V direct. (You can see the relay pins in the pic bottom right here.)

edit: can you provide a link to that module? (Not the relay itself, the whole unit.)

There is no Link to the Actual Module, I bought a Startup kit on Ebay and this was in it.

this is what came in the kit:


There is no Link to the Actual Module

It must have its own native identification though? Looks like top-right in your photo maybe?

Did you try the digital pin high and low?

Presumably when you say 5V applied, you mean from Uno? The Uno should be ok with it, since that relay is 270mW which at 5V is just over 50mA so that's ok. But if you used an external supply to 5V and Gnd you'll need to put that Gnd to the Arduino, else the digital high/low will have no meaning.

Suggestion... check it with the Arduino out of the loop by applying 5V from some batteries (I'm sure 6V be ok too), and then also touch the battery + and - to the signal pin alternately, that should toggle the relay.

Welcome to the forum.
Can you post the code you are using to operate the relay?

Please read the first post in any forum entitled how to use this forum.
http://forum.arduino.cc/index.php/topic,148850.0.html then look down to item #7 about how to post your code.
It will be formatted in a scrolling window that makes it easier to read.

Thanks.. Tom.. :slight_smile: