I keep bricking nanos

In the last couple of months I've bricked three Nanos. Plus a Leonardo. Just happens out of the blue for no obvious reason. No com port showing on some, hanging on Uploading on others. I suspect my laptop and intend putting some protection between it and the nano. First thoughts are to drop the voltage (a bit high at 5.1v but within spec) with a diode and insert resistors in the two data lines to reduce any power surges. I was going to find how high I can go with the resistance value before the USB stops working then lower it 10% or so. To this end I Just ordered some USB breakout boards. I was wondering if this is a route others have trodden and if so what advice could be offered.

btw I've tried using a UNO as a programmer to re-install the bootloader and can't get it to work - complains about wrong board codes. Anyway even if I reinstalled the bootloader, if indeed that is the problem, that won't stop me bricking them again so I'm trying to get to the source of the problem.

Dunno if this helpful, if you upload broken code it can make board fail to connect via USB. On MKR boards you can double tap reset to stop code from executing when you power the board and upload new sketch fixing the broken one. I did this many times with MKR ZERO, but am not familiar with your boards

You can't brick Nanos with wrong code; exception is use of WDT with short timeouts. The Leonardo can be bricked with incorrect code; that can be solved by pressing/releasing the reset button.

This has never happened to me, nor have I read any posts of this issue (that I can recall). My point being your setup must have some unique connections OR perhaps it is ESD.

Can you identify when it happens? i.e. when loading a new program or with a program working then not.

You have posted this topic in the Nano 33 IOT section of the forum. Is it this board that you have bricked ?

Apologies UKHeliBob I hadn't intended selecting Nano 33 IOT. I'm annoyed with myself for doing a mis-post and if I could find a way to delete this post I would, but it tells me I don't have permission to delete - amazingly I can't delete my own post! Maybe some moderator, reading this, will delete it.
Anyway I've been bricking standard Nanos.

There is either a time limit to delete a topic or if it has replies you can't delete; not sure what applies and if there is something else.

There is no reason to delete; I've moved it to Classic Nano - Arduino Forum. You should be able to do it yourself in the future if you need to; open your topic, click the big black pencil next to the title and select a new category in the dropdown box. Next click the green checkbox to apply.

Electrostatic discharge is an interesting point. I'll look into ways of reducing the risk. As for a pattern, it seems to happen on connecting to the USB. Which would support the ESD idea.

Many thanks sterreje!

The more I think about ESD the more it fits. My preferred working environment is a settee - covered in some modern synthetic material! I find it's really comfortable so I can be so much more productive but maybe this comes at a price. I've just ordered some conductive foam and will be setting up an antistatic workspace when it arrives. As an interim I have a metal cased USB memory stick which is a useful way of bringing out the laptop's 'ground' so by touching it I can discharge any static on the nano kit through my body before inserting. Just flagging this in case anyone else is having their Arduinos mysteriously zapped.
And it may be no coincidence that I bricked them during the summer months, can't say if there was a dry spell (which would help static build up) when I did the damage but this could be another factor.