I received Arduino TRE!!


Today I received Arduino TRE!! :slight_smile:

Following is youtube about first connection of my Arduino TRE to Mac.

It's so slow. And I will find a reason of that.


Nice, the products page still says 'coming soon' I had no idea it was available. Can't watch the vids on my expensive phone internet. What is slow, the board or vid?

Nice, the products page still says 'coming soon' I had no idea it was available. Can't watch the vids on my expensive phone internet. What is slow, the board or vid?

My Arduino TRE is development version.

The vid isn't slow. The board is slow.
When I tried to upload a sketch about blink example to Aruduino TRE, It took time.
Even I failed uploading a sketch 4 times before success.
I don't know why;;

Does anyone know when it's supposed to be released?
It's already summer and nothing has come out yet. =(

I have also received my Arduino TRE Developer Edition; I was surprised that I was able to get one of the 50 beta units since I placed my order more than 10 hours after their availability was announced on the Website.

I have never run across a supposedly open source product or project for which so little information was made available. You'd think the CIA was a silent partner with Arduino and BeagleBoard in its development.

I may be the oldest (72) of the beta testers; I ran programs on vacuum tube mainframes over 50 years ago. Since then I have built medical instruments for cell analysis, interfaced to progressively smaller computers - first modified DEC and Data General minis, then 8-bit Ataris and Apples, finally PC's (starting by hacking into the buses of a PCjr because it was the cheapest!). It is now clear that the ARM processors now ubiquitous in smartphones have more than enough power to control instruments, making them smaller, simpler, and cheaper, and thereby increasing their availability to more people in more places, benefiting science and public health. Since instrument manufacturers are in business to make money, it is always advisable to have open source alternatives.

A quick look at the Raspberry Pi made it clear that it didn't have quite enough computing power to handle the jobs I needed done, nor did the Arduino Due. The BeagleBone Black was immediately interesting because of its low price and high-speed PRUs, but the PRUs are not extensively supported and documentation on the BeagleBone Black has remained limited.

The October announcement of the TRE seemed to promise the consummation of a marriage made in Heaven. Galileo himself found out too much about the Heavens for his own good looking through his telescopes; I share his interest in microscopes, which he also pioneered and which didn't get him into any trouble. The Intel Galileo, however, is not well configured for work either with telescopes or with microscopes.

The TRE, on the other hand, could logically focus the attention of the large, diverse, and highly creative Arduino community on a microprocessor very much worthy of its interest, allowing the library of adaptable software to increase much more rapidly than it has to date. It was clear from the first pictures that, although the TRE would be able to use Arduino Shields, some workaround would be needed to incorporate the functionality of BeagleBone Capes. The issue was not, as far as I can tell, discussed at any length anywhere on the Web, nor did any advance details appear concerning the Linux software for the BeagleBone side of the TRE.

When BeagleBone announced their intention to shift from their relatively lame Angstrom Linux to Debian when the Rev C boards went into production in May, I guessed - wrongly as it turns out - that the TRE would run Debian. I don't think it does.

It's hard to find out for sure. We beta testers uncomplainingly paid something of a premium price to get our hands on the hardware and, it was logical to presume, software and the documentation for it, or at least an indication of where the documentation could be found.
From what came in the box, I was able to start and run the TRE successfully from a Mac, a Windows system, and a Linux (Ubuntu) system, and run it by itself, connected via wired Ethernet. Although a D-Link WiFi adapter was shipped with the TRE, neither the TRE firmware nor the paper documentation provided any clue as to how to install it. No reference manual exists in the shipped version of the firmware.

So I waded into the system and got it to blink its green light on for a second and off for a second. And couldn't and can't stop it from doing so. I can now run it freestanding and surf the Web with it, but it won't load the TRE App. Mac, Windows, or Linux systems connected to it let me start TreSetup and log on, but report that they can't connect to the TRE even after cables have been checked and replaced and the Linux Reset button has been pushed.

I have looked at all the files now on the SD and can't find anything that appears to contain a program dated after I received the TRE. That makes it likely that something necessary to make the system work has been deleted from the SD. It was stupid of me not to have made a copy of it before I started, but it is not unlikely that I wouldn't have been able to do so. Generally speaking, one downloads images of open source operating systems from websites. GitHub is where most Arduino software can be found, but I can't see even a clue that they have any software for the TRE.

With any luck, Arduino will soon inform the Developer Edition purchasers that an image of a new and improved version of the OS is available. I'm not holding my breath.

-Howard Shapiro