I think I should have just bought a real Uno.

I have one of those WAVGAT Uno r3 clones, and when I first got it I read all of the issues people have with them trying to upload sketches, and thought to myself.. Ahh for 4 bucks, I can deal with an extra driver install.. man, was I wrong..

After like an hour of trial and error when I first got this thing I was finally able to upload a sketch to it.

Now, today.. several weeks later.. I just wanted to update the code.. should be simple right? NOPE.

Back to square one. I've tried, reinstalling these CH340 drivers a dozen times, the IDE itself, different USB ports, different cables, different computers, different programmers, double and triple checked the COM ports.. still can't.. times out after 10 tries.

Please do this:

  • (In the Arduino IDE) File > Preferences
  • Uncheck the checkbox next to “Show verbose output during: compilation”
  • Check the checkbox next to "Show verbose output during: upload
  • Click “OK”
  • Sketch > Upload
  • After the upload fails, you’ll see a button on the right side of the orange bar “Copy error messages” (or the icon that looks like two pieces of paper at the top right corner of the black console window in the Arduino Web Editor). Click that button.
  • In a forum reply here, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum’s code tags markup to your reply.
  • Press “Ctrl + V”. This will paste the upload output between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.
Arduino: 1.8.13 (Windows 10), Board: "WAVGAT UNO R3"

Warning: platform.txt from core 'Arduino AVR Boards' contains deprecated recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{build.path}/{archive_file}" "{object_file}", automatically converted to recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{archive_file_path}" "{object_file}". Consider upgrading this core.

Sketch uses 1298 bytes (4%) of program storage space. Maximum is 29696 bytes.

Global variables use 9 bytes of dynamic memory.

C:\Users\Joseph\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/bin/avrdude -CC:\Users\Joseph\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/etc/avrdude.conf -v -patmega328p -carduino -PCOM5 -b57600 -D -Uflash:w:C:\Users\Joseph\AppData\Local\Temp\arduino_build_490010/Blink.ino.hex:i 



avrdude: Version 6.3-20190619

         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         Copyright (c) 2007-2014 Joerg Wunsch



         System wide configuration file is "C:\Users\Joseph\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/etc/avrdude.conf"



         Using Port                    : COM5

         Using Programmer              : arduino

         Overriding Baud Rate          : 57600

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xdd

avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x07

avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xdd

avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x77

avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xf7

avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x07

avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xdd

avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x77

avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xf7

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x77



avrdude done.  Thank you.



An error occurred while uploading the sketch



This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

1: Does the currently loaded sketch still work?
2: If yes, does that show on the serial monitor?
3: Does it by any chance use pins 0 and/or 1 for I/O?

Is the board still correctly recognised in Windows device manager?

If so, does the port in the IDE match the port in Windows device manager?

I bought a different Arduino, and it worked fine on the first try. I don't know that I care too much about getting this other one working, it was already a headache to begin with.