I think my arduino mega 2560 is dead

I was playing with Vin and a transistor when the arduino got disconnected from my pc and after a few seconds it started to smoke. It wasn't much smoke but enough to panic and disconnect everything. I waited a few minutes and then i plugged it into my pc. The power led and the 13 pin led were on but my pc couldn't recognize my device. In arduino ide i couldn't find the port and the tx and rx leds didn't blink at all. I tried to restart my px, reset arduino, i powered it with a 12v source and i got 12v out on Vin but 0 on 5V and 3V. The 13 pin doesn't want to turn off and my pc doesn't recognize it. It is not a ch arduino and it worked perfectly until i did this. I've benn searching on internet for 2 hours now about this but i still couldn't find something relevant. In device manager it sais "unknown usb device (device descriptor request failed)" and inside proprieties at device status this is written:
"Windows has stopped this device because it has reported problems. (Code 43)

A request for the USB device descriptor failed."

I also tried to update drivers automatically and manual but didn't work. I have no idea where that smoke came from.

Is it dead? can i do anything to make it work?

(deleted)

"12v out on Vin but 0 on 5V and 3V"
Says to me the reverse polarity protection diode is ok, but likely the 5V regulator got zapped, or something is shorting 5V to Gnd. If nothing else is hot, then likely the 5V regulator.
And also likely the Atmega16U2, those seem pretty sensitive to voltage events. The '2560 itself may have survived.
Both are difficult to repair without a hot air rework station or similar tool.