I2C RTC and Arduino Nano.. Strange behavior

Guys, new in here... Thus it may be looks funny my questions...

I'm using a Nano V3.0, DS1307 RTC and I2C protocol for time readout in Serial. Now, I have followed exactly info from here

http://www.electroschematics.com/8921/digital-clock-with-arduino-and-ds1307/

And after that, i hooked up firstly with D4 and D5 (Physical 7, 8) for SDA, SCL. But it did not worked. Then I connected the A4, A5 for the same according to Internet sources. There I was able to connect the RTC. It also went back to current date. But time is not updating at all. In either way... Any ideas??

Mishu~

A4 and A5 are the proper pins for I2C devices on a nano board. Sounds like the RTC hasn't been given the run command. That software appears to print messages to the serial monitor in the IDE, what is it saying?

Okey, I did the exactly according to this…

And got this:

2014/5/20 13:8:20
since 1970 = 1400591300s = 16210d
now + 7d + 30s: 2014/5/27 13:8:50

2014/5/20 13:8:20
since 1970 = 1400591300s = 16210d
now + 7d + 30s: 2014/5/27 13:8:50

2014/5/20 13:8:20
since 1970 = 1400591300s = 16210d
now + 7d + 30s: 2014/5/27 13:8:50

2014/5/20 13:8:20
since 1970 = 1400591300s = 16210d
now + 7d + 30s: 2014/5/27 13:8:50

Means time is not updating…

EDIT::

Just now found that it’s updating, but too too too damn slow. I mean after several minutes, it gets one second update… Ideas???

OKEY!! The problem found!!.

The XTAL for RTC was not working… I ordered a new shipment and after attaching the newly shipped one, it’s working fine…

The old shipment was probably BAD!!