I2C Scanner not working on Due

This is partly a question and partly a warning, It is also a continuation of this thread http://arduino.cc/forum/index.php?PHPSESSID=755e294d98e009ead8a865a10adb8bd9&topic=143868.0

However, this seems to be Due specific.

As described in the thread I linked to above, I could not get the I2C communication to work with a Microchip digital potentiometer. I also played around with a TC74 temperature sensor (the 5.0V version, but as far as I can tell from the datasheet it should work with 3.3V) without success.

Today I had the opportunity to try a Arduino Uno, and everything worked...

It turns out that I2Cscanner does not work on (my) Due for some reason, it never finds any device. It works fine on my uno (using the same wires and components). This is a problem since it is what I was using for troubleshooting last week.

However, once the sketch for controlling the pot worked on the Uno I was able to run it on the Due without problems.

The TC74 sketch is still not working on the Due, but works fine on the Uno even if the sensor is connected to 3.3V :~

Does anyone know what could be going on?

I should say that I had a look with an oscilloscope on the SCL and SDA lines (I saved the data somewhere) when trying to read from the TC74, and as far as I can tell the voltage levels etc. looked ok but the communication failed after the Due sent the start and the address (I believe there is no ACK bit, could be wrong).