IDE 1.5.1

io53: ... but now I feel stupid. Got any ant argument for that?

Don't feel stupid, i got the same error when I released the windows zip for 1.5.1...

Maybe a wrong timestamp in some .java file? I really don't know...

Hello dude,
I’ve installed “arduino-1.5.1r2” on WInXP SP3 but I’ve got the problem as

“Launch4j”
An error occurred while starting the application

please see the picture. And “javaw.exe” is still in Windows Task Manager as well.

But, “arduino-1.5” works perfectly.

Regards,
pak

11-9-2012 12-49-39 AM.jpg

"Launch4j" An error occurred while starting the application

Had same problem on a Win7/32bit and winXP, spent some time to figure out why. I have an Hardware folder in my documents/arduino path that cause crash, remove it fix it. It's obviously a bug of the release 1.5.1r2 since 1.5 not have this problem and hope will be fixed soon since many users use the hardware folder to access unsupported cpu's. I didn't find the infos easily so I'm write here (even if was mentioned in this discussion just before).

I have an Hardware folder in my documents/arduino path that cause crash, remove it fix it.

Actually, I've deleted preferences.txt under %appdata%\Arduino directory. That will solve the problem.

Thanks anyway and still waiting for Arduino Due in Singapore.

Regards, pak

Hi!.

I'm running 1.5.1r2 and I'm having one annoying problem.

I often loose the debug information during compiling. I get a message saying that I've errors, but it doesn't point me to where the error is.

I fix this buy deleting the preferences.txt and then running the IDE1.01 to build the preferences.txt again.

After this, It works again in IDE 1.5.1r2.

But, after a while, i get again with same problem.

Anyone having this issue?

Hi!

No one else with this problem?

alvesjc,

I can't reproduce it, can you post a working and a non-working preference.txt? Maybe this can give us some hints to reproduce your issue

Hi cmaglie.

This is the currently not working preferences.txt.

I’m having the issue now and can’t fix it anymore in the same way I did before.

Thank you for your attention.

File attached.

preferences.txt (2.65 KB)

Hi again.

Please find attached a working preferences.txt

This time, the only way to make it work again, was by compiling IDE all over again.

By the way, Some files were missing after compiling in this folder:

hardware\tools\g++_arm_none_eabi\bin

Shouldn’t all be there after compiling?

preferences.txt (2.3 KB)

io53:

cmaglie: Try "ant clean" first.

Thank you, it worked. :)

... but now I feel stupid. Got any ant argument for that?

You are not alone! I was stuck there for two days, before finding this post. Thanks a lot cmaglie for the trick! My config is: Arduino 1.5.1r2 (co-resident with Arduino 1.0.3) Windows XP SP3, running on a Compaq NC6000

I downloaded Arduino 1.5.1r2 and installed it on Windows 8 just like any other version of Arduino. When I started the application, I saw the Arduino start screen, then an error message that said, "An error occurred while starting the application," appeared.

I had the same error when updating to 1.5.1 from 1.1 on win 7 SP3 32bit I can confirm removing the folder 'my documents\Arduino\Hardware' fixes the problem (I had additional boards installed in this folder, the Sparkfun Micro)

best regards, Lieven Standaert

Guys,

can you please send me a PM with your 3rd hardware folder, so I can check it?

thanks!