IDE 1.6.10 error can't upload sketch but 1.0.6 did upload.

I download IDE 1.6.10 in zip format and unzip to some folder.
It can complied sketch but can’t upload to UNO R3.

Sketch uses 5,252 bytes (16%) of program storage space. Maximum is 32,256 bytes.
Global variables use 231 bytes (11%) of dynamic memory, leaving 1,817 bytes for local variables. Maximum is 2,048 bytes.
An error occurred while uploading the sketch

Then I moved back to v1.0.6 and it did upload very well.

Windows 7 Ultimate X64
Java 8 Update 91 X64


board=uno
boardsmanager.additional.urls=
build.verbose=false
build.warn_data_percentage=75
compiler.warning_level=none
console=true
console.auto_clear=true
console.error.file=stderr.txt
console.length=500
console.lines=4
console.output.file=stdout.txt
editor.antialias=true
editor.caret.blink=true
editor.code_folding=false
editor.divider.size=2
editor.external=false
editor.font=Monospaced,plain,16
editor.indent=true
editor.invalid=false
editor.keys.alternative_cut_copy_paste=true
editor.keys.home_and_end_beginning_end_of_doc=false
editor.keys.shift_backspace_is_delete=true
editor.languages.current=en
editor.linenumbers=false
editor.save_on_verify=false
editor.tabs.expand=true
editor.tabs.size=2
editor.update_extension=true
editor.window.height.default=600
editor.window.height.min=290
editor.window.width.default=500
editor.window.width.min=400
export.applet.separate_jar_files=false
export.application.fullscreen=false
export.application.platform=true
export.application.stop=true
export.delete_target_folder=true
gui.scale=120
last.folder=D:\data\MQ-2\MQ-2.ino
last.ide.1.6.10.daterun=1469801754
last.ide.1.6.10.hardwarepath=D:\data\arduino-1.6.10\hardware
last.screen.height=1080
last.screen.width=1920
last.serial.location=878,332,776,533
last.sketch.count=1
last.sketch.default.location=208,75,1357,905,508,0
last.sketch.default.path=D:\data\MQ-2\MQ-2.ino
last.sketch0.location=208,75,1357,905,508,0
last.sketch0.path=D:\data\MQ-2\MQ-2.ino
last.sketch1.location=508,75,1255,948,657,0
last.sketch1.path=D:\data\MQ-2.ino\MQ-2.ino.ino
platform.auto_file_type_associations=true
preproc.color_datatype=true
preproc.enhanced_casting=true
preproc.imports.list=java.applet.*,java.awt.Dimension,java.awt.Frame,java.awt.event.MouseEvent,java.awt.event.KeyEvent,java.awt.event.FocusEvent,java.awt.Image,java.io.*,java.net.*,java.text.*,java.util.*,java.util.zip.*,java.util.regex.*
preproc.output_parse_tree=false
preproc.save_build_files=false
preproc.substitute_floats=true
preproc.substitute_unicode=true
preproc.web_colors=true
programmer=arduino:avrispmkii
proxy.manual.hostname=
proxy.manual.password=
proxy.manual.port=
proxy.manual.type=HTTP
proxy.manual.username=
proxy.pac.url=
proxy.type=none
recent.sketches=D:\data\MQ-2\MQ-2.ino,D:\data\MQ-2.ino\MQ-2.ino.ino,D:\data\arduino-1.6.10\examples\01.Basics\Blink\Blink.ino
run.display=1
run.options=
run.options.memory=false
run.options.memory.initial=64
run.options.memory.maximum=256
run.present.bgcolor=#666666
run.present.exclusive=false
run.present.stop.color=#cccccc
serial.databits=8
serial.debug_rate=9600
serial.parity=N
serial.port=COM8
serial.port.file=COM8
serial.port.iserial=55330343731351208131
serial.stopbits=1
sketchbook.path=C:\Users\Tong\Documents\Arduino
software=ARDUINO
target_package=arduino
target_platform=avr
update.check=true
update.id=612470926498945682
upload.using=bootloader
upload.verbose=false
upload.verify=true

snap0937.png

preferences.txt (2.93 KB)

There is a bug in Arduino IDE 1.6.10 that can cause that issue when you start the IDE by opening a sketch(.ino) file(by double clicking on it, etc.). Please try this:

  • Close all Arduino IDE windows
  • Start the Arduino IDE, not by opening a sketch file.
  • Open the sketch file via File > Open, File > Sketchbook, or File > Examples

I couldn’t open IDE with a blank sketch, it automatic load the last sketch.

Btw, I downloaded 1.6.9 and it work perfect. Thanks.

Wait for the next version…