IDE 1.6.5 is now available for download

Hi everyone

We've just released IDE 1.6.5. This release includes support to the new Arduino Zero and fixes to 470 issues (with many old ones)

Arduino Zero support is available through Boards Manager.

We also have a new editor, a serial monitor that stays open (disabled) while uploading, and a File > Open Recent menu showing the last 5 opened sketches.

The complete list of changes is available here.

The list of available unofficial boards support urls has grown to 18 and library manager lists 229 different libraries.

We hope you'll enjoy all the effort we put into the IDE

Any feedback is very much appreciated.

Federico

Version 1.6.5 does not start. After the splash screen, it will simply be closed again. Clean install does not work to. Back to version 1.6.4

System: Windows 8.1, Sp1 64Bit

Can you start it using arduino_debug.exe from the command prompt? It should print an error message: please paste it here

C:\Program Files (x86)\arduino-1.6.5>arduino_debug
Loading configuration…
Initializing packages…
Preparing boards…
java.io.FileNotFoundException: C:\Users\Ren?\AppDat
es.txt (Zugriff verweigert)
at java.io.FileOutputStream.open0(Native Me
at java.io.FileOutputStream.open(FileOutput
at java.io.FileOutputStream.(FileOutp
at java.io.FileOutputStream.(FileOutp
at processing.app.legacy.PApplet.createWrit
at processing.app.PreferencesData.save(Pref
at processing.app.Base.(Base.java:343
at processing.app.Base.guardedMain(Base.jav
at processing.app.Base.main(Base.java:137)
java.lang.RuntimeException: Couldn’t create a write
oaming\Arduino15\preferences.txt
at processing.app.legacy.PApplet.createWrit
at processing.app.PreferencesData.save(Pref
at processing.app.Base.(Base.java:343
at processing.app.Base.guardedMain(Base.jav
at processing.app.Base.main(Base.java:137)

When I start the exe directly as an administrator then the ide starts. Must be a problem with permissions.

Indeed. You may have run the IDE as administrator the first time you started it. Please ensure your user has access to folder %APPDATA%\Arduino15. Or, if you don't care about losing your preferences, just trash it and restart the IDE

The problem is not resolved by deleting the folder "% APPDATA% \ Arduino15" A new folder is not created. Arduino 1.6.5 will start only when it is called as an administrator.

Looks like a screwed %APPDATA% folder then

I have several old versions of Arduino installed which all work and i can not imagine why the% APPDATA% folder should be the problem therefore. I will now have to try on my notebook (Windows 7 64Bit)

OK: working under Windows 7 and without adminrights for the first start! Any ideas?

Hi all,

I'm experiencing the same issue on W7 64 SP1 and stand-alone installation (ie .zip file). Same problem if started as admin On the same machine IDE 1.6.4 works fine.

The splash screen suddenly close without any error message or code. Trying debug exe but cmd windows close also immediatly and so, no debug message available.

Hello, I have a problem opening directly from ".ino" file, it doesn't open. Windows 8.1 x64 and Arduino IDE previous versions OK. Tried to delete the old preferences, upgrading the IDE, deleting the /user/appdata/roaming/arduino15/ and fresh install after reboot. IDE Launch when calling Arduino or Arduino_debug but nothing when called from ino or pde file. Returned error from Arduino_debug is : "Erreur : impossible de trouver ou charger la classe principale processing.app.Base" (error: can't find or load the main class processing.app.Base). Admin or not give the same.

My2cents..good Day to You.

Alomamabobo .ino file association (what makes double clicking on .ino file possible) is done by the installer: have installed the IDE or just unzipped it?

Installer only and tried with arduino & arduino_debug ( tried file association: .ino -> arduino and .ino -> arduino_debug) Thanks for the answer.

Edit: tried to put (overwrite) everything from the zip file to the installed directory (C:\Program Files (x86)\Arduino) same result. File open from IDE work as expected. Still can't open file directly.

We found a bug with the windows .exe files that prevents double clicking a .ino from opening the IDE. We are going to deliver a 1.6.5-r2 for windows later tomorrow

Thank You :)

It works great on Win7 32bit. But when I double-click a .ino file, it opens with 1.6.1. I installed 1.6.5 as a zip and 1.6.1 with the installer. But I want the default IDE to be 1.6.5. How can I change this? Should I uninstall 1.6.1?

Isaac96, yes, you need to install 1.6.5 with the installer. However, please wait for the release of 1.6.5-r2 (later tomorrow) as we have found a bug that prevents double clicking from opening the IDE

Ok, thanks!

I now have another problem. "Burn Bootloader" seems to be broken. When I click it, it seemingly only gives avrdude this command:

C:\Users\Isaac\AppData\Roaming\Arduino15\packages\arduino\tools\avrdude\6.0.1-arduino5/bin/avrdude -CC:\Users\Isaac\AppData\Roaming\Arduino15\packages\arduino\tools\avrdude\6.0.1-arduino5/etc/avrdude.conf -v -patmega328p -cstk500v1 -PCOM6 -b19200 -e -Ulock:w:0x3F:m -Uefuse:w:0x05:m -Uhfuse:w:0xDE:m -Ulfuse:w:0xFF:m

There is no .hex file specified. How can I fix this? EDIT I burned my bootloader, so now I am happy.

If you have unconventional characters in your username, the installer will create a new %appdata% folder with the wrong username. It's a common mistake from years back that non-english users seems to have to relive again and again.

My name and username is "Håkan" and the appdata folder should be created in "users\Håkan\appdata\roaming\Arduino15" but is created in "users\H†kan\appdata\roaming\Arduino15"

This is obviously something that needs to be fixed in the new installation!

/Håkan