IDE 1.6.6 is now available for download

Hi everyone

After 4 months and a half, we are proud to release IDE 1.6.6. It features hundreds of fixes (870 closed issues), a shiny new preprocessor, pluggable usb core, serial plotter, a better ArduinoISP example and many more.

More info available in the blog post.

We hope you'll enjoy all the effort we put into the IDE

Any feedback is very much appreciated.

Federico

Thank you, your efforts toward these enhancements and fixes is much appreciated!

All my sketches have compilation failed error on v1.6.6!

Yuri_D sorry to read that. Mind to post the actual errors? Without them, we can't do much really!

Hi, I’d like to report 2 issues.

My installation is IDE 1.6.6, Windows 7, installed from zip package. I have IDE 1.5.7 and IDE 1.6.5 co-exist.

  1. regarding program launch, it refuses to launch the IDE unless I manually create the AppData\Local\Arduino15 folder - I am sure I have access permission to the path.
java.nio.file.AccessDeniedException: C:\Users\xxxxxx\AppData\Roaming\Arduino15 -> C:\Users\XXXXXX\AppData\Local\Arduino15
        at sun.nio.fs.WindowsException.translateToIOException(WindowsException.java:83)
        at sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:97)
        at sun.nio.fs.WindowsFileCopy.move(WindowsFileCopy.java:387)
        at sun.nio.fs.WindowsFileSystemProvider.move(WindowsFileSystemProvider.java:287)
        at java.nio.file.Files.move(Files.java:1395)
        at processing.app.windows.Platform.fixSettingsLocation(Platform.java:250)
        at processing.app.PreferencesData.init(PreferencesData.java:36)
        at processing.app.BaseNoGui.initParameters(BaseNoGui.java:987)
        at processing.app.Base.guardedMain(Base.java:155)
        at processing.app.Base.main(Base.java:135)
  1. regarding 3rd party board installation. It always throws exception when opening board managers and refuse to load json repository files. The 3rd party json file I used is: “https://raw.githubusercontent.com/sparkfun/Arduino_Boards/master/IDE_Board_Manager/package_sparkfun_index.json

Exception:

java.lang.RuntimeException: java.lang.IllegalArgumentException: Unmatched braces in the pattern.
	at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onUpdatePressed$23(ContributionManagerUI.java:149)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.IllegalArgumentException: Unmatched braces in the pattern.
	at java.text.MessageFormat.applyPattern(MessageFormat.java:508)
	at java.text.MessageFormat.<init>(MessageFormat.java:362)
	at java.text.MessageFormat.format(MessageFormat.java:840)
	at processing.app.I18n.format(I18n.java:85)
	at cc.arduino.contributions.DownloadableContributionsDownloader.lambda$download$13(DownloadableContributionsDownloader.java:105)
	at java.util.Observable.notifyObservers(Observable.java:159)
	at java.util.Observable.notifyObservers(Observable.java:115)
	at cc.arduino.utils.network.FileDownloader.setStatus(FileDownloader.java:111)
	at cc.arduino.utils.network.FileDownloader.download(FileDownloader.java:206)
	at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:111)
	at cc.arduino.contributions.packages.ContributionInstaller.download(ContributionInstaller.java:322)
	at cc.arduino.contributions.packages.ContributionInstaller.downloadIndexAndSignature(ContributionInstaller.java:298)
	at cc.arduino.contributions.packages.ContributionInstaller.updateIndex(ContributionInstaller.java:276)
	at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onUpdatePressed$23(ContributionManagerUI.java:145)
	... 1 more
 Unmatched braces in the pattern.

Hope this helps.

Hi,

I discovered that it related not to IDE but to boards definition pack v1.6.9... With v1.6.5 I've no problems. F.e. I got an error:

GetFileAttributesEx I:\Arduino\libraries\SdFat/SdInfo.h I:\Arduino\libraries\SdFat/SdSpi.h: The specified path is invalid.

And warning for ARM (v1.6.5 installed) even when Mega 2560 board selected:

Warning: platform.txt from core 'Arduino ARM (32-bits) Boards' contains deprecated recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{build.path}/{archive_file}" "{object_file}", automatically converted to recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{archive_file_path}" "{object_file}". Consider upgrading this core.

AGRRRRR!!! After boards file switching I have "exec: "/bin/avr-g++": file does not exist" error permanently

Hi,

When I install board manager for Galileo and Edison, I got the following Warnings. Is there any issue of board support for Galileo (i586) and Edison (i686).

Warning: platform.txt from core 'Arduino i586 Boards' contains deprecated recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} "{build.path}/{archive_file}" "{object_file}", automatically converted to recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} "{archive_file_path}" "{object_file}". Consider upgrading this core.

Warning: platform.txt from core 'Arduino i686 Boards' contains deprecated recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} "{build.path}/{archive_file}" "{object_file}", automatically converted to recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} "{archive_file_path}" "{object_file}". Consider upgrading this core.

Board Intel:i586:izmir_fd doesn't define a 'build.board' preference. Auto-set to: I586_IZMIR_FD Board Intel:i586:izmir_fg doesn't define a 'build.board' preference. Auto-set to: I586_IZMIR_FG Board Intel:i686:izmir_ec doesn't define a 'build.board' preference. Auto-set to: I686_IZMIR_EC WARNING: Category '' in library DallasTemperature is not valid. Setting to 'Uncategorized' WARNING: Category '' in library EEPROM is not valid. Setting to 'Uncategorized' WARNING: Category '' in library Ethernet is not valid. Setting to 'Uncategorized' WARNING: Category '' in library EthernetShield is not valid. Setting to 'Uncategorized' WARNING: Category '' in library OneWire is not valid. Setting to 'Uncategorized' WARNING: Category '' in library SD is not valid. Setting to 'Uncategorized' WARNING: Category '' in library SPI is not valid. Setting to 'Uncategorized' WARNING: Category '' in library Servo is not valid. Setting to 'Uncategorized' WARNING: Category '' in library SoftwareServo is not valid. Setting to 'Uncategorized' WARNING: Category '' in library TimerOne is not valid. Setting to 'Uncategorized' WARNING: Category '' in library USBHost is not valid. Setting to 'Uncategorized' WARNING: Category '' in library WiFi is not valid. Setting to 'Uncategorized'

todotani those warnings are expected. Intel has to update its core

parcalto sparfun file is broken. contact them to get it fixed

Hi
I have some problems with IDE 1.6.6 and Arduino DUE.
The compilation fail using Ethernet library, this is the results trying to compile UDPSendReceiveString (in Ethernet examples):

Arduino:1.6.6 (Windows 7), Scheda:"Arduino Due (Programming Port)"

Attenzione: platform.txt del core 'Arduino ARM (32-bits) Boards' contiene la stringa deprecata recipe.c.combine.pattern="{compiler.path}{compiler.c.elf.cmd}" {compiler.c.elf.flags} -mcpu={build.mcu} "-T{build.variant.path}/{build.ldscript}" "-Wl,-Map,{build.path}/{build.project_name}.map" {compiler.c.elf.extra_flags} -o "{build.path}/{build.project_name}.elf" "-L{build.path}" -mthumb -Wl,--cref -Wl,--check-sections -Wl,--gc-sections -Wl,--entry=Reset_Handler -Wl,--unresolved-symbols=report-all -Wl,--warn-common -Wl,--warn-section-align -Wl,--warn-unresolved-symbols -Wl,--start-group "{build.path}/syscalls_sam3.c.o" {object_files} "{build.variant.path}/{build.variant_system_lib}" "{build.path}/{archive_file}" -Wl,--end-group -lm -gcc convertita automaticamente in recipe.c.combine.pattern="{compiler.path}{compiler.c.elf.cmd}" {compiler.c.elf.flags} -mcpu={build.mcu} "-T{build.variant.path}/{build.ldscript}" "-Wl,-Map,{build.path}/{build.project_name}.map" {compiler.c.elf.extra_flags} -o "{build.path}/{build.project_name}.elf" "-L{build.path}" -mthumb -Wl,--cref -Wl,--check-sections -Wl,--gc-sections -Wl,--entry=Reset_Handler -Wl,--unresolved-symbols=report-all -Wl,--warn-common -Wl,--warn-section-align -Wl,--warn-unresolved-symbols -Wl,--start-group "{build.path}/core/syscalls_sam3.c.o" {object_files} "{build.variant.path}/{build.variant_system_lib}" "{build.path}/{archive_file}" -Wl,--end-group -lm -gcc. Verifica la disponibilità di un aggiornamento di questo core.
Attenzione: platform.txt del core 'Arduino ARM (32-bits) Boards' contiene la stringa deprecata recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{build.path}/{archive_file}" "{object_file}" convertita automaticamente in recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{archive_file_path}" "{object_file}". Verifica la disponibilità di un aggiornamento di questo core.
ATTENZIONE: La categoria '' della libreria SPI non è valida. La imposto a 'Uncategorized'
ATTENZIONE: La categoria '' della libreria Wire non è valida. La imposto a 'Uncategorized'
C:\Program Files (x86)\Arduino\libraries\Ethernet\src\utility\w5100.cpp: In member function 'void W5100Class::init()':

C:\Program Files (x86)\Arduino\libraries\Ethernet\src\utility\w5100.cpp:33:13: error: 'SPI_CS' was not declared in this scope

   SPI.begin(SPI_CS);

             ^

C:\Program Files (x86)\Arduino\libraries\Ethernet\src\utility\w5100.cpp: In static member function 'static uint8_t W5100Class::write(uint16_t, uint8_t)':

C:\Program Files (x86)\Arduino\libraries\Ethernet\src\utility\w5100.cpp:147:16: error: 'SPI_CS' was not declared in this scope

   SPI.transfer(SPI_CS, 0xF0, SPI_CONTINUE);

                ^

C:\Program Files (x86)\Arduino\libraries\Ethernet\src\utility\w5100.cpp: In static member function 'static uint16_t W5100Class::write(uint16_t, const uint8_t*, uint16_t)':

C:\Program Files (x86)\Arduino\libraries\Ethernet\src\utility\w5100.cpp:168:18: error: 'SPI_CS' was not declared in this scope

     SPI.transfer(SPI_CS, 0xF0, SPI_CONTINUE);

                  ^

C:\Program Files (x86)\Arduino\libraries\Ethernet\src\utility\w5100.cpp: In static member function 'static uint8_t W5100Class::read(uint16_t)':

C:\Program Files (x86)\Arduino\libraries\Ethernet\src\utility\w5100.cpp:188:16: error: 'SPI_CS' was not declared in this scope

   SPI.transfer(SPI_CS, 0x0F, SPI_CONTINUE);

                ^

C:\Program Files (x86)\Arduino\libraries\Ethernet\src\utility\w5100.cpp: In static member function 'static uint16_t W5100Class::read(uint16_t, uint8_t*, uint16_t)':

C:\Program Files (x86)\Arduino\libraries\Ethernet\src\utility\w5100.cpp:209:18: error: 'SPI_CS' was not declared in this scope

     SPI.transfer(SPI_CS, 0x0F, SPI_CONTINUE);

                  ^

exit status 1
Errore durante la compilazione

Moreover there is a problem with board definition 1.6.5 and the max function, regardless of version of the ide. Compiling this simple sketch:

void setup() {
 int a,b,c;
 b=1;
 c=2;
 a=max(b,c);
}

void loop() {
}

the result is:

Arduino:1.6.6 (Windows 7), Scheda:"Arduino Due (Programming Port)"

Attenzione: platform.txt del core 'Arduino ARM (32-bits) Boards' contiene la stringa deprecata recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{build.path}/{archive_file}" "{object_file}" convertita automaticamente in recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{archive_file_path}" "{object_file}". Verifica la disponibilità di un aggiornamento di questo core.
C:\Users\Alessandro\Google Drive\FO3X\Arduino\SKETCH\FreeAirOzoneExposure_v5_9_2_A\sketch_nov04b\sketch_nov04b.ino: In function 'void setup()':

sketch_nov04b:3: error: 'max' was not declared in this scope

  a=max(2,3);// put your setup code here, to run once:

           ^

exit status 1
'max' was not declared in this scope

No problems with IDE 1.6.5 r5 and board definition 1.6.4.

Bugs or my errors?
Thanks for any response

Something is very wrong with 1.6.6

this is my LCD display with my sketch compiled with 1.6.5

|500x320

and this is what it looks like when compiled with 1.6.6 and 1.6.7 hourly build

|500x314

i have not changed anything in my sketch

a.mate please share your whole sketch or file a bug on Ethernet library repo https://github.com/arduino-libraries/Ethernet

huginen please share your whole sketch

I also encounter compile errors. A sketch that compiled under 1.6.5 an hour ago now issues under 1.6.6 the below errors (all libraries were updated and the IDE restarted). Since it is in German language it basically says that the g++ compiler is not found (?).

In addition, on my Mac w/El Capitan the port connected to my Uno is still not recognized.

Detailed error text:

Arduino: 1.6.6 (Mac OS X), Board: "Arduino/Genuino Uno"

/Users/kurtbierbaum/Downloads/Arduino.app/Contents/Java/arduino-builder -dump-prefs -logger=machine -hardware "/Users/kurtbierbaum/Downloads/Arduino.app/Contents/Java/hardware" -hardware "/Users/kurtbierbaum/Library/Arduino15/packages" -hardware "/Users/kurtbierbaum/Documents/Arduino/hardware" -tools "/Users/kurtbierbaum/Downloads/Arduino.app/Contents/Java/tools-builder" -tools "/Users/kurtbierbaum/Downloads/Arduino.app/Contents/Java/hardware/tools/avr" -tools "/Users/kurtbierbaum/Library/Arduino15/packages" -built-in-libraries "/Users/kurtbierbaum/Downloads/Arduino.app/Contents/Java/libraries" -libraries "/Users/kurtbierbaum/Documents/Arduino/libraries" -fqbn=arduino:avr:uno -ide-version=10606 -build-path "/var/folders/4r/c24llmzd48nf8h8lp8w6rvbh0000gn/T/build539119600000aa111ab32252c8f08077.tmp" -warnings=none -prefs=build.warn_data_percentage=75 -verbose "/Users/kurtbierbaum/soilsensorserver/soilSensorServer/soilSensorServer.ino" /Users/kurtbierbaum/Downloads/Arduino.app/Contents/Java/arduino-builder -compile -logger=machine -hardware "/Users/kurtbierbaum/Downloads/Arduino.app/Contents/Java/hardware" -hardware "/Users/kurtbierbaum/Library/Arduino15/packages" -hardware "/Users/kurtbierbaum/Documents/Arduino/hardware" -tools "/Users/kurtbierbaum/Downloads/Arduino.app/Contents/Java/tools-builder" -tools "/Users/kurtbierbaum/Downloads/Arduino.app/Contents/Java/hardware/tools/avr" -tools "/Users/kurtbierbaum/Library/Arduino15/packages" -built-in-libraries "/Users/kurtbierbaum/Downloads/Arduino.app/Contents/Java/libraries" -libraries "/Users/kurtbierbaum/Documents/Arduino/libraries" -fqbn=arduino:avr:uno -ide-version=10606 -build-path "/var/folders/4r/c24llmzd48nf8h8lp8w6rvbh0000gn/T/build539119600000aa111ab32252c8f08077.tmp" -warnings=none -prefs=build.warn_data_percentage=75 -verbose "/Users/kurtbierbaum/soilsensorserver/soilSensorServer/soilSensorServer.ino" "/Users/kurtbierbaum/Library/Arduino15/packages/arduino/tools/avr-gcc/4.8.1-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -w -x c++ -M -MG -MP -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10606 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR "-I/Users/kurtbierbaum/Downloads/Arduino.app/Contents/Java/hardware/arduino/avr/cores/arduino" "-I/Users/kurtbierbaum/Downloads/Arduino.app/Contents/Java/hardware/arduino/avr/variants/standard" "/var/folders/4r/c24llmzd48nf8h8lp8w6rvbh0000gn/T/build539119600000aa111ab32252c8f08077.tmp/sketch/soilSensorServer.ino.cpp" fork/exec /Users/kurtbierbaum/Library/Arduino15/packages/arduino/tools/avr-gcc/4.8.1-arduino2/bin/avr-g++: no such file or directory Fehler beim Kompilieren.

topdancer you installed a core through boards manager: this means the IDE will use it despite bundling an newer version. Go to Boards Manager and update AVR core to 1.6.9 For good measure, be sure your have no files under /Users/kurtbierbaum/Library/Arduino15/packages/arduino/ (this may lead to reinstalling sam and samd core)

Federico, the Boards manager shows "Arduino AVR Boards Built-In by Arduino 1.6.9 Installed". An update button does not show up.

Under /Users/.../arduino/ I see two directories:

.../arduino/hardware/avr/ with no further files in it and .../arduino/tools/avr-gcc/4.8.1-arduino2 .../arduino/tools/avrdude/6.0.1-arduino2

Shall I remove all of them?

Luckily, I can also use Yosemite on a separate boot volume. On this volume 1.6.6 compiles with no error and I can also upload to Uno.

Checking the above directory I do not see a directory .../packages/. Instead /Arduino15/ contains some jason related files...

Here is my sketch

#include <Wire.h>
#include <LiquidCrystal_I2C.h>
#include <VirtualWire.h>
#include <Adafruit_BMP085.h>
int count;
Adafruit_BMP085 bmp;
LiquidCrystal_I2C lcd(0x27,20,4);
void setup() {
  Serial.begin(9600);
   Serial.println("setup");
  if (!bmp.begin()) {
	Serial.println("Could not find a valid BMP085 sensor, check wiring!");
	while (1) {}
  }
  vw_set_rx_pin(12);
  vw_set_ptt_inverted(true);
  vw_setup(4000);
  vw_rx_start();
  lcd.init();
  lcd.backlight();
  lcd.home();
  lcd.setCursor(0,0);
  lcd.print("Inne Temp:");
  lcd.setCursor(0,1);
  lcd.print("Lufttryck:");
  lcd.setCursor(0,2);
  lcd.print("Ute Temp :");
}
void loop() {
  long pres = 0;
  lcd.setCursor(11,0);
  lcd.print(bmp.readTemperature());
  lcd.setCursor(11,1);
  pres = bmp.readPressure();
  lcd.print(pres/100);
  uint8_t buf[VW_MAX_MESSAGE_LEN];
  uint8_t buflen = VW_MAX_MESSAGE_LEN;
  if (vw_get_message(buf, &buflen))
  {
    lcd.setCursor(11,2);  
    int i;
    digitalWrite(13, true);
    char temp=0;
    Serial.print("");
    for (int i = 0; i < buflen; i++)
    {
      //char c = (buf[i]);
      temp=(char)buf[i];
      lcd.print(temp);
      Serial.print(temp);
      Serial.print("");
          }
    count++;
    
    Serial.println("");
    digitalWrite(13, false);
 } 
}

I think there may be an issue in the SD library regarding 1.6.6. I tried several times, and the same program under both 1.6.6 and 1.6.5r5 will compile and upload fine, but reading a text file on the SD card fails every time when compiled and uploaded from 1.6.6. And it opens fine every time when compiled and uploaded from 1.6.5r5. I am using the SD library that installs with the respective version of the IDE. (haven’t looked that deep to see if there is any difference between the two)

FWIW I have a Windows 7 Pro 64bit machine, installed the IDEs with the Windows installers, i7 16GB. The target board is an Arduino Ethernet (unfortunately the .com version, but .cc retired them).

topdancer, yes remove those folders too: they are fooling the IDE

Do you mind opening an issue on github at the SD library repository? It's https://github.com/arduino-libraries/SD

thank you huginen, I'll try it tomorrow

I too am getting errors with 1.6.6. I am running Arduino DUE, windows 8. It was working fine with version 1.6.5 I get the following error during compile time...

Warning: platform.txt from core 'Arduino ARM (32-bits) Boards' contains deprecated recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{build.path}/{archive_file}" "{object_file}", automatically converted to recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{archive_file_path}" "{object_file}". Consider upgrading this core. Warning: platform.txt from core 'Arduino SAMD (32-bits ARM Cortex-M0+) Boards' contains deprecated recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{build.path}/{archive_file}" "{object_file}", automatically converted to recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{archive_file_path}" "{object_file}". Consider upgrading this core.

WARNING: Category '' in library Ethernet2 is not valid. Setting to 'Uncategorized' Library can't use both 'src' and 'utility' folders.

Error compiling. Invalid library found in C:\Program Files\Arduino\libraries\Firmata: Library can't use both 'src' and 'utility' folders.

I've tried to revert back to version 1.6.5 and now that doesn't work. So I think the 1.6.6 installer is removing important file(s) who knows, I've ran out of options and now my project is on hold until I sort this out.

Ive tried the default code:

void setup() {
  // put your setup code here, to run once:

}

void loop() {
  // put your main code here, to run repeatedly:

}

Any ideas?

Many thanks,

@Itgeek the warnings are normal and can be safely ignored. As for the error with Firmata, try this:

  • Sketch > Include Library > Manage Libraries...
  • In the box that says Filter your search... type firmata
  • Click on the Firmata entry in the list of results
  • Click on the Update button
  • Click on the Close button
  • Try compiling your sketch again