IDE 1.6.9 not launching on Win10 64b

IDE doesn’t open and gets Invalid library found
See attached Debug file

debug.txt (3.74 KB)

Try using the Arduino IDE in portable mode by creating a folder named portable in the Arduino IDE installation folder(C:\Program Files (x86)\Arduino).

I made the Portable directory but I still not be able to install - The message is that the IDE 1.6.12 has to be uninstalled but I erased everything from the Arduino dir...

Try this:

  • Start Windows "Programs and Features"(I think it's in Control Panel)
  • Double click Arduino
  • Click "Uninstall"
  • Try installing Arduino again

If that doesn't work then use the "Windows ZIP file for non admin install" instead of the "Windows Installer" download from the Download page on the arduino.cc website.

Thanks,The Arduino app was still on the list of apps and I was able to delete it. Now I installed the IDE but when I launch Arduino it says that it could not run because it cannot create a folder to store the sketchbook. Should I create it?

Damnit! I still have the same problem:
After downloading the IDE 1.6.12 I get the same behavior: Clicking on the Arduino program,it opens the arduino image for a few second then, with the Portable directory, the message says it can’t create the sketchbook even that I have it already on the Documents\Arduin, and without the Portable Dir nothing happens…
Looking at the debug output,strangely it seems to refer to IDE 1.6.9 with libraries errors,then Java doesn’t seem to be able to open the preference file.
Note that I also installed with the zip file with the same result
Here are the debug output and the preference file listing.

preferences.txt (4.72 KB)

debug.txt (3.79 KB)

alains:
it seems to refer to IDE 1.6.9

No, that’s Arduino SAM Boards 1.6.9.

From debug.txt:

java.io.FileNotFoundException: C:\Users<username>\AppData\Local\Arduino15\preferences.txt (Access is denied)

if you are actually running in portable mode it shouldn’t be looking there because portable mode means that all the files normally stored in the Arduino15 folder are stored in the portable folder instead. Is that debug.txt from when you ran the IDE in portable mode?

One thing you could try is to right click the Arduino shortcut and select “Run as Administrator”.

I finally was able to fix it: Recreating folders that had been deleted by the virus PC Accelerator, a nasty one.. Thanks for your help!