IDE 1.8.0, Arduino Zero, Raspberry Pi, CMSIS-Atmel not available

I downloaded and installed IDE 1.8.0 on my Raspberry Pi 2 Model B running the latest Raspbian Jessie.

Works great with my UNO board.

I am unable to use it with my Zero board.

Under Board Manager I selected "Arduino SAMD Boards (32-bit ARM Cortex-M0+) by Arduino" when I clicked "Install" next to "1.6.11". I got the following error:

"Tool CMSIS-Atmel is not available for your operating system."

What can I do to fix or work around this?

I have submitted a bug report: CMSIS-Atmel not available on ARM Linux - cannot install latest SAMD boards · Issue #2 · arduino/ArduinoModule-CMSIS-Atmel · GitHub

Until an official fix is released you have two options:

  1. Use SAMD boards 1.6.8 or older. They do not use CMSIS-Atmel.

  2. Save the attached file to disk (but not in ~/.arduino15) and add

file:///wherever/you/put/it/package_xx_index.json

to Preferences > Additional Boards Manager URLs.

After that you should see
“Arduino SAMD Boards (32-bits ARM Cortex-M0+) by Arduino *** Workaround for ARM Linux/CMSIS-Atmel ***”
in the Boards Manager. (Just the versions that use CMSIS-Atmel.)

package_xx_index.json.txt (7.04 KB)

It has been fixed now, no workarounds necessary.

Great! Thank you. It all works now.