IDE 1.8.0 Released -- update: 1.8.10

thank you, it works fine now! (edit: just the location of the Sketch folder had to be added manually to the preferences)

You're welcome. I'm glad if I was able to be of assistance. Enjoy! Per

ARDUINO 1.8.9 2019.03.15

[ide]
* New target! ARM64 boards are now fully supported (Nvidia Jetson and RaspberryPi3 with 64bit operating system)
* Fix UTF8 related bugs on Windows
* Fixed: can now compile again using OpenJDK (removed dependency on JavaFx)
* Fixed: only use touchBar on OSX 10.12 or higher
* PluggableDiscovery: easily add your own discoverer and make it available in Boards/Port menu (thanks @PaulStoffregen for the idea and the initial implementation)
* LibManager: reduce slowdown when searching
* Fixed: ensure a sketch line is visible when it contains an error and must be highlighted
* Linux: the installer now tries to install a symlink is /usr/local/bin (this doesn't affect usual non-systemwide installation) Thanks @2E0PGS

[wifi-updater]
* Fix firmware upgrade not being available for 3rd party WINC boards

[arduino-builder]
* Use lexicographic distance as last chance to spot the right library (if every other tecnique failed)
* Fix some prototypes being inserted in the middle of a function

having installed IDE 1.8.8., the IDE always starts with a new (empty) file, not with the latest working file as before (1.8.5). How can I make 1.8.8 to automatically load the latest opened file again?

dsyleixa: having installed IDE 1.8.8., the IDE always starts with a new (empty) file, not with the latest working file as before (1.8.5). How can I make 1.8.8 to automatically load the latest opened file again?

What works for me in 1.8.8 is with the latest working file loaded, click on File -> Quit. Then it comes back to there when the IDE runs next time.

dsyleixa: having installed IDE 1.8.8., the IDE always starts with a new (empty) file, not with the latest working file as before (1.8.5). How can I make 1.8.8 to automatically load the latest opened file again?

This is a known issue with Arduino IDE 1.8.8. Luckily, the bug has already been fixed and there is a new IDE version now 1.8.9. Please update to Arduino IDE 1.8.9.

thanks @all, to have to reinstall a new version anew is too cumbersome to me, but ctrl+Q for Quit (instead of ALT+F4) is fine! OTOH, if there was a new Search and a Replace function in the 1.8.9 Editor with find-whole-words-only-option available, then it might be worth-while to upgrade ;)

Is there an issue with IDE 1.8.9? I downloaded and installed it a few days ago. Today I tried to use it but everything returns a "Error compiling for Arduino/Genuino Uno" and Board Info says it is a Arduino/Genuino Uno and it is on port Com6. This is using a Windows 7 desktop. Even the ArduinoISP example sketch returns that same error. I am unable to do anything with it. Did I miss something? I will re download it and reinstall it but this threw me since the previous version I had installed did not have a problem with these boards.

Thank you.

Southerner: Is there an issue with IDE 1.8.9? I downloaded and installed it a few days ago. Today I tried to use it but everything returns a "Error compiling for Arduino/Genuino Uno" and Board Info says it is a Arduino/Genuino Uno and it is on port Com6. This is using a Windows 7 desktop. Even the ArduinoISP example sketch returns that same error. I am unable to do anything with it. Did I miss something? I will re download it and reinstall it but this threw me since the previous version I had installed did not have a problem with these boards.

Thank you.

Please do this:

  • When you encounter an error, you'll see a button on the right side of the orange bar "Copy error messages" in the Arduino IDE (or the icon that looks like two pieces of paper at the top right corner of the black console window in the Arduino Web Editor). Click that button..
  • In a forum reply here, click on the reply field.
  • Click the button on the forum toolbar. This will add the forum's code tags markup to your reply.
  • Press "Ctrl + V". This will paste the error between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.

If the text exceeds the forum's 9000 character limit, save it to a .txt file and post it as an attachment. If you click the "Reply" button here, you will see an "Attachments and other settings" link.

AVG reports that the windows installer contains win32/heim !!!!!!

:(

Please clean it!

It does not contain any problem, according to AVAST's report.

Are you sure you got it from this link: https://www.arduino.cc/download_handler.php?f=/arduino-1.8.9-windows.exe ?

Virus Total comes up clean too. I suspect modry_salamander has other issues and his AV might be compromised if he got it from here.

Forgive me, I've been out of the robot game for a few years. I just opened up Arduino IDE (1.6.5) on my Mac and was prompted that it was out of date. I installed the current version (1.8.9) and get the below errors when I upload a sketch.

Arduino: 1.8.9 (Mac OS X), Board: "Arduino Leonardo"

Sketch uses 10280 bytes (35%) of program storage space. Maximum is 28672 bytes.
Global variables use 336 bytes (13%) of dynamic memory, leaving 2224 bytes for local variables. Maximum is 2560 bytes.

avrdude: butterfly_recv(): programmer is not responding
avrdude: butterfly_recv(): programmer is not responding
avrdude: butterfly_recv(): programmer is not responding
avrdude: butterfly_recv(): programmer is not responding
avrdude: butterfly_recv(): programmer is not responding
Found programmer: Id = ""; type = 
    Software Version = a.; Hardware Version = �.�
avrdude: butterfly_recv(): programmer is not responding
avrdude: butterfly_recv(): programmer is not responding
avrdude: error: buffered memory access not supported. Maybe it isn't
a butterfly/AVR109 but a AVR910 device?
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

avrdude: butterfly_recv(): programmer is not responding
avrdude: error: programmer did not respond to command: leave prog mode
avrdude: butterfly_recv(): programmer is not responding
avrdude: error: programmer did not respond to command: exit bootloader
avrdude: error: programmer did not respond to command: exit bootloader

Invalid library found in /Users/scottcallahan/Documents/Arduino/libraries/ZumoExamples: no headers files (.h) found in /Users/scottcallahan/Documents/Arduino/libraries/ZumoExamples
Invalid library found in /Users/scottcallahan/Documents/Arduino/libraries/ZumoExamples: no headers files (.h) found in /Users/scottcallahan/Documents/Arduino/libraries/ZumoExamples

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

I have no idea what butterfly_recv(): is. I don't know what a AVR 109 device is. I checked the preferences for the sketchbook location and it's the same for both versions.

Arduino 1.6.5 still uploads perfectly, just the text is pixilated.

Thanks for any help.

Scott

ok, I fixed the butterfly_recv(): errors by pressing the reset button while uploading the sketch. Now the only problem I have is

Invalid library found in /Users/scottcallahan/Documents/Arduino/libraries/ZumoExamples: no headers files (.h) found in /Users/scottcallahan/Documents/Arduino/libraries/ZumoExamples
Invalid library found in /Users/scottcallahan/Documents/Arduino/libraries/ZumoExamples: no headers files (.h) found in /Users/scottcallahan/Documents/Arduino/libraries/ZumoExamples

Which, once again doesn't show up in the previous version.

Fixed it, so far so good. :)

(deleted)

Hi Tim.

Did you check the contents of the tabs were not simply added to the sketch itself ?

Bob.

(deleted)

TimEllis: I just installed a fresh verison 1.8.9 of the IDE. I have some code that includes two .h files. I add the files using the sketch->add file. The .h files show up in the bar at the top and the code compiles fine. I made sure to save all of the files. When I close the IDE and reopen it the .h files do not show up. How can I be sure the .h files will reappear each time I open the IDE?

I just gave it a try, but was unable to reproduce the issue. After you add the .h file, select Sketch > Show Sketch Folder. Do you see the .h file in that folder?

(deleted)