IDE 1.8.1 not launching on win7/64

Just downloaded IDE 1.8.1 and installed on M6700 (i7-3720QM/8GB/Win7 Pro x64). Read the before posing page and the previous not launching posts. Drive C: is SSD, D: is HDD. MyDocuments have been relocated to D:. The arduino-debug output is


Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\Joel>cd c:\program files (x86)\arduino

c:\Program Files (x86)\Arduino>arduino_debug.exe
DPI detection failed, fallback to 96 dpi
com.sun.jna.platform.win32.Win32Exception: The device is not ready.
at com.sun.jna.platform.win32.Shell32Util.getFolderPath(Shell32Util.java:48)
at com.sun.jna.platform.win32.Shell32Util.getFolderPath(Shell32Util.java:61)
at cc.arduino.os.windows.Win32KnownFolders.getDocumentsFolder(Win32KnownFolders.java:71)
at processing.app.windows.Platform.recoverDefaultSketchbookFolder(Platform.java:75)
at processing.app.windows.Platform.init(Platform.java:54)
at processing.app.Base.(Base.java:197)
at processing.app.Base.main(Base.java:140)

The arduino.l4j.ini contents are


-Xms128M
-Xmx512M

I get the splash screen, then nothing. The IDE has never run.

Thanks

(deleted)

Thanks for the quick reply.

Shutdown followed by restart produced the same response from arduino_debug.exe shown in initial post.

As a test I resurrected a win10 Core Duo machine. Both IDE 1.8.0 and 1.8.1 load and run. Teensyduino 1.3.4 loads and runs on 1.8.0.

So the problem must be in my system on the Win7 i7 machine.

Any ideas?

(deleted)

Arduino 1.8.1. is not launching for me too on windows 7 Professional (64 bit). I tried to run it in compatibility mode, but nothing works. Where can I find a log that tells me why it's not launching?

In the Arduino folder I found the 2 following files that can be opened with Notepad:

  1. arduino.l4j file opened in notepad shows:
    -Xms128M
    -Xmx512M

  2. arduino_debug.l4j opened in notepad shows:
    -Xms128M
    -Xmx512M

I disabled Microsoft Security Essentials and it made no difference. How can I get Arduino software to work on Windows 7 pro x64 operating system?

Hello,

the same problem as i on my WIN7 Laptop. The 1.8.1 start page is shown 5-10sec and then disappears...
I deinstalled an old Java version and install the new 8version.

The debug output is closed so fast that i cannot read the information.

Can anybody help?

kind regards
Bernd

Bewild - I had to open a command line window and start the debug from there. Look at the first included code in my original post – that is the commands and output from the window.

Chasing down the source code it appears that the x86 java code throws an exception trying to find my documents folder. I moved the folder from the SSD to the HDD, so that may be the wrench in the works. I will write a VS test program to verify the system call that Shell32 has taken exception to.

[SOLVED] It was my bad, I messed up moving My Documents to the HDD such that the registry entries for My Documents, ... were pointing to the DVD (which was empty). Hence the "not ready" error message. Pointed everybody back to the HDD and all was well.

Thanks ... I got to learn about KnownFolders and CLSIDs.

I solved my issue, too: There was a strange library folder "Documents/Arduino/libraries/libraries/libraries/lib....." which were >20 libraries folders. At start the debug mode showed "wrong library in Documents/Arduino/libraries". After rename the old library folder, Arduino installed a new one.

By the way, i was able to see the error screen after starting the arduino_debug.exe out of a DOS-box.

Thanks.
Bernd

Someone ? Windows 8.1 pro , IDE 1.8.1 splash screen, then nothing.

I forget how to get a Command line window in win8.1, but when you get one, navigate to where you installed 1.8.1 (in my case it was c:\program files (x86)\arduino) and run arduino_debug.exe. You can see where to start.

Good luck

@mjansen9011: in my case the libraries folder was corrupted. Delete your libraries folder and install the Arduino sw new.

Hello all,

Thanks for the tips here re the debug.exe.

I was having the same symptoms for 1.8.x versions: install OK, run splash screen, then nothing.

I ran the debug in cmd (open cmd first, then drag .exe in to run without the cmd closing after) which showed Java permission issues with "C:\Users\Colin\AppData\Local\Arduino15\preferences.txt" file.

I found this folder to be hidden, and some read only, so unticked 'Hidden' and 'Read only' in Properties and applied to subfolders and subfiles as well.
This seems to have fixed my problem!

So thanks again, and good luck to the next person coming here for help!

Cheers,
Colin