IDE (1.8.10 and .12) won't start on Win10 **SOLVED**

*** SOLUTION POSTED AT POST #2 ***

Hey Team.
Tried all the basic debug steps I could find for the past 2 days, gave up and hope you can help.

  • 1.8.10 WAS previously working
  • Came back to use it, failed
  • Installed 1.8.12… failed
  • Re-installed a half dozen times, cleaned the registry, tried Java on its own, preferences.txt, libraries, browsed debug output… can’t make sense of it
  • Splash makes it to “Preparing Boards…” then the “javaw” download pops up, and hangs there forever. (see pic)
  • Debug is 1.8.10, as attached, still failing

Open to suggestions.

20200331 - IDE Fail - DEBUG Log.txt (51.6 KB)

20200331 - IDE Fail - launch4j.log.txt (9.86 KB)

Oh, and when I click CANCEL DOWNLOAD on “javaw” (left it overnight as a test…no change) I get this popup.
:frowning:

20200331 - IDE Fail2.jpg

SOLUTION

For the benefit of anyone else having this problem, I used Microsoft Process Monitor (Tool Previously Known As: SysInternals FileMon/ProcMon) and watched the IDE try to load. I searched on “keywords.txt” in the PATH as a filter.

Somehow - the source of which I have not yet identified - despite MULTIPLE uninstalls and a “Registry Clean” for anything with the word Arduino in it, there must have been a user/config file repeatedly being left behind during the re-install process which pointed to an old “Arduino/libraries/” user class module and it was trying to load a “keywords.txt” for that class. Somehow ArduinoIDE translated that into needing to download javaw.exe/keywords.txt from “Arduino…” ?! Makes no sense.

In any event, I renamed the user-defined libraries folder so it couldn’t see it, and it loaded immediately, no problem. Took me 3 days to figure that out. Gah. Hopefully that technique helps someone else.

:[

Hi All.

I have a similar problem. I have upgraded to 1.8.12 2 days a go and all was working until I closed the IDE today and rebooted my Win10.

when I start the IDE it shows the splash screen for 2 sec and then the screen closes with no IDE open. I have reinstalled as Admin but still no luck.

Here is the output from debug:

C:\Program Files (x86)\Arduino>arduino_debug.exe
Set log4j store directory C:\Users\Alper\AppData\Local\Arduino15
Loading configuration...
Initialising packages...
java.lang.NullPointerException
        at cc.arduino.contributions.packages.ContributionsIndexer.parseIndex(ContributionsIndexer.java:134)
        at processing.app.BaseNoGui.initPackages(BaseNoGui.java:483)
        at processing.app.Base.<init>(Base.java:273)
        at processing.app.Base.main(Base.java:150)

C:\Program Files (x86)\Arduino>

Please see this post
Then ensure you are or were not affected.

Greetings,

Thank you @ ardyMoto,

@alperkayar :

the source of problem has in the below location:

*C:\Users\Alper\AppData\Local*

delete all folder started with "Arduino15"

then Arduino IDE will run smoothly. :slight_smile: