IDE 1.8.5 crashes on start up win 7

this my very first install of arduino and it crashes at startup , I have updated java to the latest

here is my debug output

</ C:\Program Files (x86)\Arduino>arduino_debug
Looking for library ‘user32’
Adding paths from jna.library.path: null
Trying user32.dll
Found library ‘user32’ at user32.dll
DPI detection failed, fallback to 96 dpi
Looking for library ‘shell32’
Adding paths from jna.library.path: null
Trying shell32.dll
Found library ‘shell32’ at shell32.dll
Looking for library ‘Ole32’
Adding paths from jna.library.path: null
Trying Ole32.dll
Found library ‘Ole32’ at Ole32.dll
Looking for library ‘kernel32’
Adding paths from jna.library.path: null
Trying kernel32.dll
Found library ‘kernel32’ at kernel32.dll
com.sun.jna.platform.win32.Win32Exception: The device is not ready.
at com.sun.jna.platform.win32.Shell32Util.getFolderPath(Shell32Util.java
:48)
at com.sun.jna.platform.win32.Shell32Util.getFolderPath(Shell32Util.java
:61)
at cc.arduino.os.windows.Win32KnownFolders.getDocumentsFolder(Win32Known
Folders.java:71)
at processing.app.windows.Platform.recoverDefaultSketchbookFolder(Platfo
rm.java:76)
at processing.app.windows.Platform.init(Platform.java:55)
at processing.app.Base.(Base.java:201)
at processing.app.Base.main(Base.java:144)

C:\Program Files (x86)\Arduino>>

When you start the Arduino IDE it needs to access the sketchbook folder and the Arduino15 folder. The default location of the sketchbook folder is Users{user name}\Documents\Arduino. The Arduino folder is at Users{user name}\Appdata\Local\Arduino15. It looks to me like it's not able to access one of those folders. The "The device is not ready." thing makes me think you have some non-standard location of the folder like on an external or network drive.

One thing you could try as a workaround is to run the Arduino IDE in portable mode: https://www.arduino.cc/en/Guide/PortableIDE That will cause the portable subfolder of the Arduino IDE installation folder to be used instead of the Arduino15 folder and the sketchbook will also initially be under that folder (though you can later change it via File > Preferences > Sketchbook location if you like). If you use the "Windows ZIP file for non admin install" version of the Arduino IDE you also have the option of installing the IDE to any location you like in case the current installation location (C:\Program Files (x86)\Arduino) imposes some difficulties for you.

thanks, will try as I use a c: drive for boot and a D: drive for date

portable instructions say to create a folder called portable, does not work for me , i uninstall and reinstall , ng. I reset my documents folder to default and tried a reinstall, ng

What do you mean by "does not work for me"? Are you getting the exact same output from arduino_debug.exe?

I never knew about the "portable" installation until I read this topic. I installed 1.8.5 on a flash drive and a USB attached hard drive and both instances worked perfectly. I also have WIN7.

I did create a folder on the c drive as explained and put a folder in it called portable

debug results

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>cd\

C:>cd arduino
The system cannot find the path specified.

C:>cd arduino-1.8.5

C:\arduino-1.8.5>arduino_debug
Looking for library ‘user32’
Adding paths from jna.library.path: null
Trying user32.dll
Found library ‘user32’ at user32.dll
DPI detection failed, fallback to 96 dpi
Looking for library ‘shell32’
Adding paths from jna.library.path: null
Trying shell32.dll
Found library ‘shell32’ at shell32.dll
Looking for library ‘Ole32’
Adding paths from jna.library.path: null
Trying Ole32.dll
Found library ‘Ole32’ at Ole32.dll
Looking for library ‘kernel32’
Adding paths from jna.library.path: null
Trying kernel32.dll
Found library ‘kernel32’ at kernel32.dll
com.sun.jna.platform.win32.Win32Exception: The device is not ready.
at com.sun.jna.platform.win32.Shell32Util.getFolderPath(Shell32Util.java:48)
at com.sun.jna.platform.win32.Shell32Util.getFolderPath(Shell32Util.java:61)
at cc.arduino.os.windows.Win32KnownFolders.getDocumentsFolder(Win32KnownFolders.java:71)
at processing.app.windows.Platform.recoverDefaultSketchbookFolder(Platform.java:76)
at processing.app.windows.Platform.init(Platform.java:55)
at processing.app.Base.(Base.java:201)
at processing.app.Base.main(Base.java:144)

C:\arduino-1.8.5>

I forgot that there is a bug that causes the IDE to still try to access the Documents/Arduino folder even when in portable mode: https://github.com/arduino/Arduino/issues/7097 Which makes portable mode not the workaround I thought it might be.

Try running the Arduino IDE beta build in portable mode to see if it works: http://www.arduino.cc/en/Main/Software#beta

This person's solution to the same error concurs with my theory of the cause:

j-luc: [SOLVED] It was my bad, I messed up moving My Documents to the HDD such that the registry entries for My Documents, ... were pointing to the DVD (which was empty). Hence the "not ready" error message. Pointed everybody back to the HDD and all was well.