IDE 2.0.0-rc2 Autoformat

Still doesn't work (doesn't do anything).

Hi @nosmoke.

Which board do you have selected in the Arduino IDE's Board menu?

Please provide a sample of unformatted code that you would expect to exhibit a change after doing an Auto Format.

Arduino Uno.

After downloading 2.2.0-rc2, loaded a sketch and tried auto-format as it hadn't been functional in previous Beta releases. Simply backspaced an indent of a statement following a "while()", typed ctrl-T and nothing happened (repeatedly). After receiving your reply, tried it with another sketch and it worked albeit slowly (took several seconds to do it). Reloaded the original sketch and and it too worked (slowly) so I don't know what was going on.

Thanks, will let you know if it happens again...

The reason for the slowness is because the auto formatting is handled by Arduino Language Server. The language server reprocesses the sketch, including the Arduino core and any other libraries it uses after every change. The IDE shows an indicator of this on the status bar at the bottom left corner:

image

So the auto format is delayed when that processing is ongoing.

Happening again. This time error messages show up:

"Unable to watch for changes in this large workspace. Please follow the instructions link to resolve this issue".

The "Instructions" box links to a Visual Studio web page explaining the cause of the error.

The spurious "Unable to watch for changes in this large workspace" notifications are tracked here:

This is apparently a bug in the Eclipse Theia IDE framework used by the Arduino IDE 2.x

I don't know what the conditions are that cause this spurious "Unable to watch for changes in this large workspace" notification, so my ability to investigate the impacts is limited.

However, I did just happen to get one of these notifications. Auto Format continued to work as expected. So there is not a universal correlation between that notification and the auto format not working bug (arduino/arduino-ide#396, arduino/arduino-ide#337)