IDE 2.0 Beta 9 not working Wemos D1 Mini (ESP8266)

Hi
I've got a Wemos D1 Mini (clone) and try to use it with the ESP8266 library with version 2.7.4 (the 3.x versions break the code) and Arduino IDE 2.0 Beta 9.
The error is always "The FQBN is not available for the selected board LOLIN(WEMOS) D1 mini (clone). Do you have the corresponding core installed?"
Funny part though, if I uninstall ESP8266 and then right install it again through board manager, compilation works, until I restart Arduino IDE. The it starts up again with this error.
Also weird, if I remove ESP8266 library, restart Arduino IDE, then the Wemos board is still selectable in the board manager.
Board URL is https://arduino.esp8266.com/stable/package_esp8266com_index.json

@pert one for you I think

I forgot to mention, this is with Windows 10.

Hi,
I have the same problem as patoberli, different board but esp8266 based.
The 2.7.4 core doesn't allow to select any esp 8266 board until upgrading the core to 3.0.2.
After that I can choose the board and still work even downgrading core to 2.7.4 .
Closing the Ide and reopening=same issue again...

Hope it helps

I forgot: Ide is 2.0B9 , did not try B10 yet

Davide

1 Like

Thanks for posting this. Now I know why the compiling sometimes worked and sometimes stopped working!

I think it must be because of this bug in the ESP8266 boards platform, which was fixed in their 3.0.1 release:

1 Like

Thanks pert,
if I well understand, when using esp8266 core < 3.0.1 we must use the trick I wrote above.
It has been fixed only for core 3.0.1 (where, in my case, i found a buggy webserver, the good one working is in 2.7.4).

You can easily apply the fix retroactively to your 2.7.4 version of the ESP8266 boards platform. It's only a single line.

Instructions:

  1. Select File > Preferences from the Arduino IDE's menus.
  2. Check the box next to "Show verbose output during: compilation".
  3. Click the OK button.
  4. Open any sketch.
  5. Select Sketch > Verify/Compile from the Arduino IDE's menus.
  6. Wait for the compilation to end (doesn't matter if it passes or fails).
  7. Scroll up the black "Output" pane at the bottom of the Arduino IDE 2.x window. At the very top, you'll see something like this:
    Using core 'esp8266' from platform in folder: C:\Users\per\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.7.4
    
  8. Open the folder shown in the output.
    NOTE: the AppData or .arduino15 folder (depending on which operating system you are using) are hidden by default. You'll need to configure your file browser to show hidden folders.
  9. Open the file boards.txt in a text editor.
  10. Add the following line to the top of the file:
    menu.UploadTool=Upload Tool
    
  11. Save the file.
  12. Restart the Arduino IDE if it's running.
2 Likes

Thanks, will test this later when home.
I've posted a comment in GIT in the hope that they see it and might consider it for a backport.

1 Like

In my case the message about the not found FQDN was not solved by this. @AppsByDavideV did it work for you?

Hello,
just tried but it doesn't work. Esp boards are still greyed out.
Attached screenshots with ide 2.0B10 (I know it doesn't matter) , maybe I made a mistake.


Have a nice Weekend

@pert any other idea what we might try?

I see. It happens for any boards platform when you have a version previous to the latest installed.

Arduino IDE 2.x is intended only to be used for beta testing. It simply isn't at a development state when it can be used as a production tool. Please use the classic Arduino IDE.