IDE dies on splashscreen

PROBLEM
I tried opening my Arduino IDE (1.8.2) and only get the splashscreen (with "Initializing Packages...") and then nothing. I'm using Windows 8.1.

I've read through the posts - trying to see what is "unusual" about my setup?

That about covers it -- lots of different libraries - but that hasn't really been an issue.

SYMPTOMS
When I go to the Board Manager -- that's when the problems start to crop up. I'll get errors on the downloads when the Board Manager is open (partial downloads, incomplete downloads, the old UTF-32 bad character...etc).

I will then get a puke of Java Errors.

SOLUTION ATTEMPTS

  • Tried uninstalling 1.8.2 and rolling back to many different versions. Found 1.6.4 to be the gold "starting point". It seems to be pretty solid and got many of my BSPs loaded without issue.
  • Uninstalling means more than just going to "Uninstall Programs", but also deleting the entire directory under C:\Users\yourname\AppData\Local\Arduino15. That gives you a completely clean system (except for libraries that you may have in other locations -- like local libraries).
  • Messed a ton with the proxy settings. No effect.
  • Messed more with the way the Additional Boards URL is formated. Doesn't like spaces - so beware of that little gotcha.

PROPOSED SOLUTION
If you think your BSP downloads have become corrupt -- don't blow the whole installation away, just go to C:\Users\yourname\AppData\Local\Arduino15 and blow away the JSON files and temp files. I pretty much cleaned out the directory except for the preferences.txt file.
SUCCESS!
Then tried reloading the BSP screen and it re-reads and downloads all the latest JSON files as specificed in your additional Boards option.

Hope this helps a few other poor souls struggling with corrupt BSP downloads -- it can really mess with your head...

birchtree123:
I also work with the Intel Arduino 101 and TinyTile. Another BSP: https://github.com/01org/corelibs-arduino101/releases/download/2.0.0/package_2.0.0-rc4_index.json

Is there a reason you're using that BSP instead of the standard Intel Curie Boards included in the Arduino JSON file?

It sounds like you have solved your problem but here's a tip for troubleshooting when Arduino crashes/doesn't start. If you run arduino_debug.exe from the command line you will get some output. It's sometimes a bit cryptic to my understanding but it can give some clues at least. I believe the arduino_debug file is only present on the Windows version and that other OSs can just run arduino from the command line and get the same output.

I guess I can remove that 'additional' URL for the 101 - I was playing with it a few months ago and need to clean up my setup. Thanks for the tip (reminder) to clean things up.

Also - thanks for the super helpful tip on the arduino_debug.exe. I didn't know about that and can see how helpful it would have been in my investigation.

Thanks again.