IDE do Arduino não está compilando para a placa NodeMcu

Há um tempo atras eu tinha um código que funcionava e tal. Entretanto, há uns dias retomei esse mesmo código para fazer algumas alterações, chegando me deparo com um erro dizendo:

Arduino: 1.8.8 (Windows 10), Placa:“NodeMCU 1.0 (ESP-12E Module), 80 MHz, Flash, Enabled, 4M (no
SPIFFS), v2 Lower Memory, Disabled, None, Only Sketch, 115200”

Placa nodemcuv2 (plataforma esp8266, pacote esp8266) é desconhecida

Erro compilando para a placa NodeMCU 1.0 (ESP-12E Module)

Desde já agradeço qualquer informação.

The "Board ... is unknown" error occurs when a Boards Manager installation of a different version of a hardware package fails to completely uninstall the previous version. Here's how you solve it:

  • Click the link on the line following File > Preferences > More preferences can be edited directly in the file. This will open the Arduino15 (or similar name depending on OS) folder.
  • Navigate to the packages/esp8266/hardware/esp8266 folder.
  • You will see two folders. One is named by the version of the package you currently have installed, the other is named by the version of the package you previously had installed. Delete the folder with the previous version name. Please be very careful when deleting things on your computer. When in doubt back up!

Obrigado :) . Deu certo!

De nada.

Tive o mesmo problema e consegui solucionar com essas dicas. Muito obrigado!!!

Bom dia!
Estou com um problema semelhante; a mensagem de erro é a seguinte:

Connecting……____Traceback (most recent call last):
File “/Users/MACFON/Library/Arduino15/packages/esp8266/hardware/esp8266/2.5.2/tools/upload.py”, line 25, in
esptool.main(fakeargs)
File “/Users/MACFON/Library/Arduino15/packages/esp8266/hardware/esp8266/2.5.2/tools/esptool/esptool.py”, line 2653, in main
esp.connect(args.before)
File “/Users/MACFON/Library/Arduino15/packages/esp8266/hardware/esp8266/2.5.2/tools/esptool/esptool.py”, line 468, in connect
raise FatalError(‘Failed to connect to %s: %s’ % (self.CHIP_NAME, last_error))
esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header
esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header

Obrigado.

JBJR:
Bom dia!
Estou com um problema semelhante; a mensagem de erro é a seguinte:

Connecting……____Traceback (most recent call last):
File “/Users/MACFON/Library/Arduino15/packages/esp8266/hardware/esp8266/2.5.2/tools/upload.py”, line 25, in
esptool.main(fakeargs)
File “/Users/MACFON/Library/Arduino15/packages/esp8266/hardware/esp8266/2.5.2/tools/esptool/esptool.py”, line 2653, in main
esp.connect(args.before)
File “/Users/MACFON/Library/Arduino15/packages/esp8266/hardware/esp8266/2.5.2/tools/esptool/esptool.py”, line 468, in connect
raise FatalError(‘Failed to connect to %s: %s’ % (self.CHIP_NAME, last_error))
esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header
esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header

Obrigado.

Sim, estou tendo o mesmo problema…

.…____Traceback (most recent call last):
File “C:\Users\User1\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.5.2/tools/upload.py”, line 25, in
esptool.main(fakeargs)
File “C:/Users/User1/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.5.2/tools/esptool\esptool.py”, line 2653, in main
esp.connect(args.before)
File “C:/Users/User1/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.5.2/tools/esptool\esptool.py”, line 468, in connect
raise FatalError(‘Failed to connect to %s: %s’ % (self.CHIP_NAME, last_error))
esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header
esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header

Ele meio que conectava há poucos minutos, mas travava nos 7% por um tempo até dizer que a porta parou de responder. Mudei ele de USB e parou de reconhecer, ficava sempre apontando pra porta COM9, então voltei pra USB original. Quando eu clico pra reconhecer a placa, diz :

BN: Placa não identificada
VID: 10C4
PID: EA60

Mas no gerenciador de placas, a placa está selecionada corretamente pelo que eu vejo… É uma NodeMCU 1.0 (ESP-12E Module), que é bem a placa que estou trabalhando. A única coisa, na parte de ferramentas, que acho que pode mudar é o programador, que está selecionado como AVRSIP mkll

boa noite estou com esse erro
Arduino: 1.8.13 (Windows Store 1.8.42.0) (Windows 10), Placa:“NodeMCU 0.9 (ESP-12 Module), 80 MHz, 115200, 4M (3M SPIFFS)”

The sketch name had to be modified.
Sketch names must start with a letter or number, followed by letters,
numbers, dashes, dots and underscores. Maximum length is 63 characters.

Biblioteca inválida encontrada em C:\Users\ander\Documents\Arduino\libraries\default: no headers files (.h) found in C:\Users\ander\Documents\Arduino\libraries\default

Biblioteca inválida encontrada em C:\Users\ander\Documents\Arduino\libraries\libesp32: no headers files (.h) found in C:\Users\ander\Documents\Arduino\libraries\libesp32

Biblioteca inválida encontrada em C:\Users\ander\Documents\Arduino\libraries\libesp32_div: no headers files (.h) found in C:\Users\ander\Documents\Arduino\libraries\libesp32_div

Biblioteca inválida encontrada em C:\Users\ander\Documents\Arduino\libraries\lib_audio: no headers files (.h) found in C:\Users\ander\Documents\Arduino\libraries\lib_audio

Biblioteca inválida encontrada em C:\Users\ander\Documents\Arduino\libraries\lib_basic: no headers files (.h) found in C:\Users\ander\Documents\Arduino\libraries\lib_basic

Biblioteca inválida encontrada em C:\Users\ander\Documents\Arduino\libraries\lib_display: no headers files (.h) found in C:\Users\ander\Documents\Arduino\libraries\lib_display

Biblioteca inválida encontrada em C:\Users\ander\Documents\Arduino\libraries\lib_div: no headers files (.h) found in C:\Users\ander\Documents\Arduino\libraries\lib_div

Biblioteca inválida encontrada em C:\Users\ander\Documents\Arduino\libraries\lib_i2c: no headers files (.h) found in C:\Users\ander\Documents\Arduino\libraries\lib_i2c

Biblioteca inválida encontrada em C:\Users\ander\Documents\Arduino\libraries\lib_rf: no headers files (.h) found in C:\Users\ander\Documents\Arduino\libraries\lib_rf

Biblioteca inválida encontrada em C:\Users\ander\Documents\Arduino\libraries\lib_ssl: no headers files (.h) found in C:\Users\ander\Documents\Arduino\libraries\lib_ssl

In file included from C:\Users\ander\Documents\Arduino\gsm_test_1\gsm_test_1.ino:4:0:

C:\Users\ander\Documents\Arduino\libraries\Blynk\src/BlynkSimpleEsp8266.h:18:21: fatal error: version.h: No such file or directory

#include <version.h>

                 ^

compilation terminated.

exit status 1

Erro compilando para a placa NodeMCU 0.9 (ESP-12 Module)

Este relatório teria mais informações com
“Mostrar a saida detalhada durante a compilação”
opção pode ser ativada em “Arquivo → Preferências”