IDE does not read its preference file

I have down-loaded and uninstalled various IDE's about 50 times in the last two days. I have removed and reinstalled the Java Runtime so that Java informs me I have the correct installation. I have cleaned out all my old files by way of C-Clean but still I cannot get the IDE., to recognise its Preference file location of "sketchbook" or my old file called "sketches" consistently telling me that the "sketchbook" does not exist so it will replace it with its own location .............. but this doesn't happen either, all after producing the splash screen and then the aforementioned message box; I am left with my normal desktop even though I have deposited both blank and filled files called "sketchbook" & "sketches" in every location at the time of installation and checked and re-checked my preferences file in C:\user > HCSpreckley > roaming > Arduino > Preferences time after time..

Is there anybody that can help in this matter please as I am almost exhausted by the mysterious goings on of the Arduino IDE?

Help!

In Windows ?

Download the zip file of the Arduino 1.5.7 BETA.

Keep your Arduino folder with projects, try to remove everything else.
Remove the complete Java, everything. Do not install any Java.
Remove the Arduino.

Unzip the Arduino somewhere, for example in your home folder in a folder called “my Programs”.
Run the Arduino from that location, open the settings box and set you projects folder.

Dear Peter. I will. Tomorrow morning; as of now I'm so exhausted from trying that I haven't the heart.

I tried removing the java files that were left behind from the programs that I un-installed, but I found it impossible without uninstalling the complete Windows Java Run-Time package. Is there something that I should know or can you explain please, just what you mean by "Java, Everything"?

I am extremely grateful for your help. Thanks,
Chris

The Windows version of the Arduino IDE has is own subset of Java. It doesn't need Java, it is even better off without, since there might be a conflict with versions.
Do you need Java for something else ?
In the past I have used JavaRa to remove Java.

Peter,

I have removed Java before by way of windows 7., "Programs and Features". If you know this program, can you please confirm my belief that it removes all of the two Java packages within my computer.

In answer to your question : "No I do not knowingly know of any other program that requires java; that I run".

Thanks for all your help if you can confirm or deny the first statement that I made I would be very grateful.

Cheers & thanks,
Chris

I hope that is enough, but Java has the bad habit to keep a lot of files on the computer.

Did you try the Arduino 1.5.7 zip-file and unzip it somewhere in your home folder ?
If that is running okay, perhaps some device drivers has to be (re)installed for the Arduino boards.

Peter,

I did all that I think you stated although I am unconfident about my java removal although I have used Win 8.1 for the removal and it now is shown to be clear of any Java program.

I removed all installed Arduino IDE's and re-started the computer. I then installed an existing download of arduino-1.5.7-windows all as you suggested. After doing this I visited the existing c:\user\HC Spreckley\roaming\Arduino\Preferences.txt file; opened it; and found that it still contained my old detail and referenced the Sketchbook to C;\Program File (x86)\Arduino\Sketchbook location. I then corrected the preferences file to suit the location of the newly installed IDE.,

Following all this I committed the program by clicking the Arduino.exe logo. Unfortunately the same thing as before happened, namely: The Green splash page started; hung for some time; then up came the message box that the sketchbook location had been changed and that the default Sketchbook would be used. Unfortunately that was the end of the hopped for IDE., start.

So: Is the location of the Preferences file the same or different when you install the IDE to a none standard program location or do you have any suggestions about my install method or any other suggestion including how I might find those java programs or bits and pieces lurking in the shadows.

Many thanks,
Chris

Using: Windows 7, 64-bit, Arduino IDE 1.5.7 zip-file.
My "preferences.txt" is at C:\Users\Peter_n\AppData\Roaming\Arduino15\preferences.txt
There is nothing else in that folder, only the preferences.txt file.
Tested once more with new downloaded Arduino, unpacked in Downloads folder: it uses the same preferences.txt.
Removing the "Arduino15" folder does not make it slow, it starts normally.

Arduino IDE 1.0.6 zip-file uses this file : C:\Users\Peter_n\AppData\Roaming\Arduino\preferences.txt

When I open a PowerShell or cmd.exe, typing "java" does not start something, it is not recognized.
Searching the harddisk for "java" is not that easy, since files are found in the Arduino system files, and the Windows\winsxs folder. But nothing in other locations.

Downloaded JavaRa from http://singularlabs.com/software/javara/
Version 2.6 runs without installing additional .NET packages in Windows 7. Selected "Remove Java Runtime", there was no uninstaller, selected "Next", and "Perform Removal Routine": 0 item deleted, because nothing was found.
There is also "Additional Tasks", you can select all 4.

I hope this will help. You need the "Arduino15" folder for the "preferences.txt", you can delete it to start with a new one. After that you might have to set your projects folder in the settings box in Arduino IDE. My computer has no Java files and the Arduino IDE starts without delay.

Peter,

Many thanks. I will empty my machine of all Arduino and Java using the suggested program and all that I can find and following your procedures as closely as possible I will reinstall and get back to you as soon as I can.

Thanks for now,
Chris

Peter,

In short I have met with absolutely no success, in fact if anything I have gone backwards as I now do not get the warning box stating that Arduino cannot find the Sketchbook location and will make its own, (which it never did in any case).

If you wish to 'Bale Out' then please do so as it must be getting very aggravating for you,

I emptied every location I could find with an Arduino 'Preferences.txt' file and did I find them in the most unlikely places in fact their were about 5 or 6. I found that the latest version that you suggested when installed didn't produce a preferences file in the usual location but in the Arduino>lib file and within its first few lines it suggested that the file should not be altered by the user and I didn't; it suggested another location; (that location was empty on all three occasions of attempting to run 1.5.7). After this I re-downloaded 1.5.7 once more followed by 1.0.6 followed by 1.0.5 cleaning out the machine and checking for java each time with your suggested Java-Ra program however no Java was found following its being first run when it presumably deleted all JavaRunTime files and curiously not one of the installation attempts manufactured a 'preferences file' leaving nothing in which to attempt an edit.

Now no Arduino startup will provide anything more that the green splash screen at which it halts, hangs and then disappears leaving the message after about 1 minute of "An error occurred while starting the application"

I am absolutely lost. I have never in my life of computing which is around about 35 years come across a program designed for a machine that would not load and run. What on earth can be going on. My tracking of all the locations of researched file locations was done within File Explorer>search using as the principal file, 'preferences.txt'

If you have anything to add I then I am a willing listener but if you haven't then I thank you for all the advice offered.

Cheers, Chris

The preferences in the ‘lib’ directory is the system file. I changed a setting in the Arduino IDE and searched the harddisk for preferences.txt, that is how I was sure the find the right file.

I can’t believe that the Arduino files are that bad.
Can you try another computer ? You could install the Arduino or unpack the zip-file, both is okay. And after removing it, no Windows system files have been changed. Only the device drivers for the Arduino boards perhaps.

If every other computer will run Arduino just fine, perhaps you need to re-install Windows …
Or maybe the Arduino IDE generates log or debug information, but I don’t know how to do that.

Peter
,
Your not going to believe this.:

1] I have a desk top running Vista and the IDE worls fine in t hat. The trouble with that machine is it only has a max of 1.5 Gig of memory and 750 Gb are used currently. The IDE runs well but the machine is O' so slow its more than a yawn and because of its architecture I don't feel like adding the little bit of memory that it could benefit by. Therefore I have run the IDE., on my lap top for some years now.
2] I have previously ditched the windows platform and reloaded it + ALL MY WORKING PROGRAMS BACK ON T O IT. Can you remember the last time you did that? Well thats why I don't want to even try it once more. Following my last finish of that chore the IDE still wouldn't run and I found an Adafruit down-load that did. I've tried the Adafruit download once more this time and even that didn't work.
So what's next, well I am just going to have to learn either Programmers Notebook, or Atmel Studio 6, or MS Visual Studio but they all seem to be such a learning yawn that although I have them on computer, now, whenever I open one of them I don't find anything remotely intuitive and so find myself closing them and going to bead. And yes I have downloaded Arduino for Visual Studio and have it on Atmel Studio 6.

But you know there has to be a very simple reason as to why the Arduino doesn't like me or my Windows 8.1 operating system for it is from that update time that all this nonsense began. Its either that or quite simply me, I don't mind if you think I am to be the villain of the peace as for all I know that could well be the case.

Cheers Chris

I’m sorry, I have no idea what to do.
You need to use another computer, or you can try Ubuntu linux.

I’m using Windows 7, not Windows 8.
In Windows 8 there are more restrictions for device drivers. On the forum I see only problems with Windows 8 with installing the device drivers.

The only think I can think of is to search for *.txt files that changed today. There are many of them in /AppData/Local/Temp, but I don’t know if they mean anything.
There are command line options for arduino.exe, but those are only for the sketch (verify, upload and so on), not for the Arduino IDE itself.

Someone with more knowledge about the Arduino IDE could perhaps help ?

Thanks Peter,

I have altered the request for help on the same forum by hopefully putting the words in the request more simply (although you got the gist of this one right from the outset). I'm working now on my desk top where it works well enough apart from the derisory speed at which it insists upon doing certain chores. Currently working on the provision of heat control in a gound heat pump and balancing it with its compatriot Greenhouses temperature and humidity. Simple enough if you are not in a hurry but all this messing about has put me days in arrears and trying to catch up on a megalithic Dell desk top monster doesn't make for congenial working. Look mate; thanks very much for all your attempts | just wish we could h ave pulled it together.
Cheers,
Chris

Okay. Stay cool 8)

I'm trying. Very.....................

A test: Windows 10 Preview 64-bit installed. Arduino 1.5.8 BETA zip-file unzipped in Downloads folder. Drivers installed. Arduino started. There was a SmartScreen warning, but I choose “Run Anyway”. Arduino was started in 4 seconds (slow harddisk, 5 years old computer). Also a firewall question popped up. The preferences.txt is in C:\Users<name>\AppData\Roaming\Arduino15 and I chould change settings. The harddisk was tested a few weeks ago (it took 4 hours with GSmartControl in linux) and is in perfect condition.

As you can see, everything is working as it is supposed to.