IDE doesnt open in 1.8.4 1.8.2 1.6.13 (solved)

Hi

I had the arduino IDE (1.8.4) installed on my laptop and it worked fine but than it just wouldn't open again I have re-instaled `1.8.4 and than it was still doing the same than i tried 1.8.2 and 1.6.13 but the problome was stil the same. I couldn't upload the video so here is a link to it https://youtu.be/VnVxsZU3r7o . but the problem is that IDE starts and the loading screen opens and than that that disappears and than there is nothing.

There are a number of things that could cause this. If you run arduino_debug.exe (which is located in the root of the Arduino IDE installation folder) from the command line you will be able to see some output you can post here and that may give a clue to the cause.

There is one issue that has been causing this for people lately: https://github.com/arduino/Arduino/issues/6689 an easy way to test if that's the problem, and solve the problem at the same time is to install and run the hourly build: http://www.arduino.cc/en/Main/Software#hourly that build is primarily meant to be used for beta testing but you can go back to using 1.8.4 again once the hourly build has reset the font size to a valid value, you just need to be careful not to shrink the font down too far again (and even if it happens you will know how to fix it).

I'm pretty sure that that is what happend by me because my font was realy small the last time i stopt IDE but after running the hourly build (that works fine) 1.8.4 still doesn't works

edit: oke never mind after saving something in the hourly build 1.8.4 worked again thanks for the help

Glad it's working again! Sorry I didn't explain it clearly. For anyone else who might have this problem, you need to run the hourly build, change the font size via ctrl+mouse wheel or File > Preferences > Editor font size, then exit the hourly build and after that 1.8.4 or earlier will start working again. The other option is to just manually edit the editor.font value in your preferences.txt file.