IDE Help files quit launching

Help files quit launching. These are the ones under the IDE Help pull-down menu. Getting Started, Troubleshooting, Reference, etc etc… none of them work anymore. Np errors… nothing happens after pushing Enter. These appear to be some kind of shortcut to the web site. My internet browsers are working fine.

I’ve uninstalled and reinstalled the IDE many times. I also manually deleted Arduino files in the user | AppData folders. My PC is running Win 10.

They actually open local copies of those pages in your browser, which should allow this to work even when your computer doesn't have an Internet connection. You can find the files under {Arduino IDE installation folder}/reference.

Which version of the Arduino IDE are you using?

I’m using version 1.8.5

I find nothing there that resembles a name, like… Getting Started, Troubleshooting, Reference, etc etc. Like you suggested… I drilled down from C:\Program Files (x866)\reference\ in three difference directions… only found some .jpg pictures of boards.

Previous times when working on sketches I could go to Help | Reference and the programming reference page would pop up… very handy now nothing happens and I have to go out the the web site. Like I said I reinstalled several times and Help | Reference will not pop up.

As a test, I went to my wife’s PC (also Win 10 and identical hardware) and downloaded the IDE and VIOLA the Help | Reference page pops up. This a very handy feature while working on a sketch. I’d like to get it back. Any ideas?

I could not find the files like you suggested on my wife’s PC either yet Help | Reference pops up the programming reference page, which seems to be coming through the browser… long url looking like a shortcut beginning with local C: and embedded within the middle of the url. On my wife’s PC when I unplug my ethernet cable the reference page will not pop up and the browser times out… so I feel certain that this help stuff comes from the internet. My wife’s computer now behaves like mine did last year.

It looks like something got goobered up in the registry, because I uninstall and deleted AppData before reinstalling. It is like something is remembering a bad configuration that is not being removed with uninstall.

long url looking like a shortcut beginning with local C:

And when you look at the folder on her computer indicated by that URL what do you find? Note that Windows likes to hide folders.

On my wife's PC when I unplug my ethernet cable the reference page will not pop up and the browser times out.

I just checked and you're correct about that. In older versions of the Arduino IDE that did not happen.

so I feel certain that this help stuff comes from the internet.

No, the actual content is from the html files in the reference folder. It's just some external JavaScript dependencies that require access to the Internet.

Ok....... but do you have any suggestions as to how to fix. It is very handy to have the Help menu items pop up in a browser window. It worked at one time, but quit. As I said, I have uninstalled and reinstalled many times. I also deleted the Arduino15/AppData before reinstall. It is like there is something stuck in the registry that does not clear with an uninstall.

The test install on my wife's PC works perfectly, the Help pops up immediately.

On your computer, what happens if you double click an .html file?

I get an Error

"Class not registered"

I think that's a valuable clue. It does sound like a registry issue but I don't think it's specifically related to the Arduino IDE. The Arduino IDE likely just opens the .html file and lets the OS figure out which browser you want to use to view it. Most browsers will have a thing in their Options dialog that lets you set it as the "Default Browser". I wonder if maybe you have no default browser set on your computer.

When I try to open a file that has no program association Windows pops up a dialog to let me choose the default program to open that file type. Since you are not getting that dialog it seems like maybe there is already a program associated with .html files but for some reason it isn't working (maybe that program was removed from your computer?).

I've seen that error before when the registry keys relating to the file associations are messed up.

Thanks pert, For asking me the.html question and leading me to a resolution.

It seems that the OS somehow switched settings for .html type from Firefox to MS Edge browser. When I checked the settings for file type it had the Edge logo icon. Changing it back to my default Firefox fixed the problem.

Actually it was not quite as easy as indicated above. It took some tinkering. If I recall I tried to change to Firefox at least two times, but did not switch, kept going back to Edge, like the OS would not allow it. As you would expect the OS let me change back and forth between Edge and IE (all MS stuff), but not Firefox. Then when I tired the Arduino Help and it immediately brought up the Edge browser, (blank screen) which was VERY SLOW to render the Help page, even on several refresh (retries). Then going back to the file type settings, I tried to switch to Forefox again and it said something like "Do you really want to change, and highly suggested that I stay with Edge because it was designed for Win10, but I said NO and was finally able to switch .html file type back to Firefox, which worked and was fast about 1 seconds. Then I switched back to Edge and it was slow like before maybe 10 seconds. Back to Firefox now, and Help is working great. I HATE MICROSOFT WIN-10 AND THE EDGE BROWSER !!!!!!

Sorry for bringing a Microsoft problem to the Arduino forum.

Yeah, Windows 10 was the last straw for me. I've used Windows since it first came out. I've never been a huge fan but I was resigned to it until now. I did finally get Windows 10 set up the way I want it (essentially the Windows 2000 UI) after a ridiculous amount of hassles and hacks but the next time I upgrade my OS it will definitely be to Linux.