IDE installed , worked for a short period, now splash screen for a few secs

Hi!

I use Zorin OS 15.2 Linux.

I installed Arduino IDE 1.8.12 and it appeared to work for only a short period.

I downloaded some libraries from the Board Manager and installed them.

Now when I try to run the IDE, I only get the splash screen for a few seconds, then nothing.

I have tried removing and re-installing in the Software centre. This didnt work.

I downloaded from the web site and tried a command line install and this did not work either.

Can you assist?

The Web Editor works fine. I can upload to Uno with no difficulty.

There was a problem with Arduino's package_index.json file used for Boards Manager that caused the NullPointerException error and prevented the IDE from starting.

Now the package_index.json file has been fixed, but to recover the Arduino IDE to a working condition you must delete the bad package_index.json from your computer as well as the cache folder, then restart the Arduino IDE as usual.

remove file /home/YourUsername/.arduino15/package_index.json
remove folder /home/YourUsername/.arduino15/cache

NOTE: These are a hidden folder. You will need to configure your file browser software to show hidden folders in order to see them.


Please note that the problem that caused the Arduino IDE to break from the bad package index file has already been fixed and will be in the next release of the IDE. That's the reason why the Nightly/Beta Builds are not affected, and also the reason why we did not detect this problem earlier.

Sorry for any inconvenience this has caused!