IDE non risponde

Buongiorno a tutti avrei un quesito da risolvere : da ieri non riesco ad aprire Ide di arduino mi spiego meglio quando clicco sull'icona di arduino l'apertura avviene dopo mezz'ora. Avrei bisogno che qualcuno mi illumina su cosa possa essere successo. Grazie

Qualche info in più. windows ? Linux ? Mac ? Quale versione S.O. ? Quale versione IDE ? Versione installata da zip o da installatore ?

windows 7 mentre IDE Arduino 1.6.4 installata da zip :il problema si è presentato all'improvviso fino a ieri era tutto funzionante

no niente di strano

in attesa ho pensato di disinstallare il software 1.6.4 e ho installato 1.6.7 ma il problema persiste e cioè clicco su arduino exe esce srcitto sto avviando e dopo circa 20 min. si apre.Ho provato ad eseguire arduino_debog.exe mi dice che " librerie non valide" sto avviando...e si ferma li.Dov'è l'inchippo? Grazie

Secondo me c'e' qualche libreria che lo impalla. Prova a toglierle dalla cartella LIBRARIES dove hai gli sketch. Toglile tutte, magari fai un taglia/incolla in un'altra cartella,avendo alla fine la LIBRARIES vuota. E' un tentativo.

Altra "possibilità", prova la versione 1.6.8, scompatti lo zip in una cartella arduino-1-6-8, all'interno di questa cartella crei una cartella portable e rilanci l'ide.

speedyant:
Altra “possibilità”, prova la versione 1.6.8, scompatti lo zip in una cartella arduino-1-6-8, all’interno di questa cartella crei una cartella portable e rilanci l’ide.

che funzione avrebbe la cartella portable?

Le "impostazioni" e i file che altrimenti si "spalmerebbero" nei meandri di Windows, "finiscono" in modo ordinato in quella cartella.

Ho risolto in parte il problema ho scaricato 1.6.5 ho aggiornato i driver perchè non mi vedeva le porte,ma resta irrisolto l'IDE che apre in ritardo. La creazione della cartella portable non l'ho capita.

Quindi la prova che ti ho suggerito non l'hai fatta. Poi non capisco. Avevi la 1.6.4 poi provi la 1.6.7 ora metti la 1.6.5 mentre l'ultima versione è la 1.6.8 Boh, non capisco che stai facendo !?!

Non mi diverto a installare i vari software , ho installato 1.6.8 e ottenevo errore con le varie librerie cioè non

le trovava poi ho installato 1.6.7 e ottenevo lo stesso risultato del 1.6.8. Infine con 1.6.5 ho risolto il problema

aggiornando i driver ma resta irrisolto il problema del ritardo dell'apertura dell'IDE. Quello che più mi danno è

che una settimana fa tutto funzionava perfettamente con 1.6.4. La prova di togliere la cartella della

libreria non l'ho fatto perchè questo problema avveniva solo con il software 1.6.8. Altri suggerimenti te ne

sarei grato non metto assolutamente in dubbio i tuoi consigli.Grazie

Il mio consiglio è per il discorso della lentezza, gli errori in compilazione non c'entrano nulla.

Quando hai fatto prova con arduino_debug.exe sembrava dirti che qualche libreria non la "digerisce", da qui il mio consiglio, SVUOTA la cartella libraries dove hai i progetti/sketch (taglia e incollali da un'altra parte) e prova a farlo ripartire. E' un tentativo, logicamente.

Oppure potresti provare a installare ma dalla versione zip la versione 1.6.8 e crearci dentro una sottocartella di nome portable.... EDIT: Guglielmo mi ha tolto le parole di bocca ^-^

Allora,

  1. scarica la 1.6.8 (versione zip), scompattala e mettila dove ti è più comodo.

  2. vai nella cartella dell'IDE e, dentro ad essa, crea una cartella di nome "portable"

  3. da questo momento questa installazione è diventata "standalone", ovvero [u]NON usa più quanto tu hai già su disco, ma lavora SOLO al suo interno/u.

Prova quindi a lanciare l'IDE così preparato e vedi se parte in tempi "normali" ...

Facci sapere.

Guglielmo

Grazie farò come dite e non appena avrò ultimato la procedura vi farò sapere.

Grazie ora va tutto bene ho creato la cartella 'portable' e IDE si apre velocemente.

Ma non è definitiva la cosa. Questa prova ha fatto in modo di ESCLUDERE le librerie che hai per l'altro IDE. Quindi abbiamo capito che tra le librerie che hai per il vecchio IDE c'e' qualcosa di installato male.

Occhio che il nuovo IDE "portable" non vede le librerie che avevi installato in precedenza. Devi usare il menu apposito per scaricarle e aggiungerle: menu->sketch->inclusione librerie->gestione librerie...