IDE on Windows 7 - Cannot download to Nano 33 IoT

Hello,

I have just started with the Arduino today and almost nothing works. I have been unable to use Web Editor using Chromium on an RPi or Chrome on a Windows 7 machine (plug-in either will not install or does not work), I tried installing the IDE on the RPi but doing that corrupted all the software on the RPi and I have had to rebuild everything including the OS from scratch.

I have now installed the IDE on the Windows 7 machine. At least this time the machine survived. This is what happens:

Using device manager, I installed the drivers for the Nano 33 IoT but when I try to download I get an error report to the effect that a board cannot be found on the selected port.

The select port option is greyed-out.

Using the PC's control panel, I can find the Arduino but nothing about it's USB connection. It also reports that no driver is installed despite the IDE reporting a successful iństallation of the drivers.

Not off to a good start.

In summary, I have problems with:

  1. Plug-in for Chromium (RPi 4)
  2. Plug-in for Chrome (Windows 7)
  3. IDE for RPi 4
  4. IDE for Windows 7

I would welcome any suggestions for any of the above problems, in particular for 4. This is the last thing that I have tried and looks the most promising. I don't want to try 1 again because of the damage done last time.

Any suggestions?

Thanks in advance,

Paul.

Moved you to a better section and there are also basic instructions listed in here for installing the board using the IDE's BOARD MANAGER.

Please take a few moments to Learn and Use The Forum

How to get the best out of this forum Installation & Troubleshooting

Hello, Welcome to the Arduino Forum. This guide explains how to get the best out of this forum. Please read and follow the instructions below. Being new here you might think this is having rules for the sake of rules, but that is not the case. If you don’t follow the guidelines all that happens is there is a long exchange of posts while we try to get you to tell us what we need in order to help you, which is frustrating for you and frustrating for us. The people who try to help with your pro…

It will help you get the very best out of the forum in the future.

  • Your OS and version can be valuable information, please include it along with extra security you are using. Antivirus etc.
  • Always list the version of the IDE you are using and the board version if applicable.
  • Use quote or add error messages as an attachment NOT a picture.
  • How to insert an image into your post. ( Thanks sterretje )
  • Add your sketch where applicable but please use CODE TAGS
  • Add a SCHEMATIC were needed even if it is hand drawn
  • Add working links to any specific hardware as needed (NOT links to similar items)
  • Remember that the people trying to help cannot see your problem so give as much information as you can

COMMON ISSUES

  • Ensure you have FULLY inserted the USB cables.
  • Check you have a COMMON GROUND where required. ( Thanks Perry)
  • Where possible use USB 2.0 ports or a USB 2.0 POWERED HUB to rule out USB 3.0 issues.
  • Try other computers where possible.
  • Try other USB leads where possible.
  • You may not have the correct driver installed. CH340/341 or CP2102 or FT232 VCP Drivers - FTDI
  • There may be a problem with the board check or remove your wiring first.
  • Remove any items connected to pins 0 and 1.

COMPUTER RELATED

  • Close any other serial programs before opening the IDE.
  • Ensure you turn off any additional security / antivirus just to test.
  • There may be a problem with the PC try RESTARTING it.
  • You may be selecting the wrong COM port.
  • Avoid cloud/network based installations where possible OR ensure your Network/Cloud software is RUNNING.
  • Clear your browsers CACHE.
  • Close the IDE before using any other serial programs.
  • Preferably install IDE’s as ADMINISTRATOR or your OS equivalent

ARDUINO SPECIFIC BOARDS

  • CH340/341 based clones do not report useful information to the “get board info” button.
  • NANO (Old Types) some require you to use the OLD BOOTLOADER option.
  • NANO (ALL Types) See the specific sections lower in the forum.
  • NANO (NEW Types) Install your board CORE’s.
  • Unless using EXTERNAL PROGRAMMERS please leave the IDE selection at default “AVRISP mkII”.
  • Boards using a MICRO usb connector need a cable that is both DATA and CHARGE. Many are CHARGE ONLY.

CREATE editor install locations.

  • On macOs ~/Applications/ArduinoCreateAgent-1.1/ArduinoCreateAgent.app/Contents/MacOS/config.ini
  • On Linux ~/ArduinoCreateAgent-1.1/config.ini
  • On Windows C:\Users[your user]\AppData\Roaming\ArduinoCreateAgent-1.1

Performing the above actions may help resolve your problem without further help.

Language problem ?

Try a language closer to your native language:

Thanks to all those who helped and added to this list.

Hello Bob,

I can see that I shall have to divide my problems into four sections but let's concentrate on 4.

I have tried all the things in your list that are relevant. The nub of the problem seems to be the lack of a driver despite it being reported as having been installed by the IDE.

I have let Windows 7 search for a driver in the Arduino/drivers directory on the C: drive but none were found.

As far as my first experiences with the Arduino are concerned: The only ray of light in all this is that the Web Editor does work on a Macbook and I have written and downloaded sketches with that. Unfortunately the Mac is not a machine that I want to use in my lab.

There must be a way to develop for the Arduino using a PC or an RPi - I'm sure that there are many people doing just that.

Perhaps you can let me know where I can find whatever driver I am missing and then I can install it.

Thanks in advance for your help.

Regards,

Paul.

Did you install the board cores that are mentioned in a sticky post near the top of this section of the forum.

the CREATE editor has its won drivers even for some clones so they are pre-installed so to speak.

The regular editor works all the way from Win 7 upward as win7 is my base test machine.

Bob.

Hello Bob,

Thanks for your reply.

I followed the link and read about USB problems and the suggested solution of using a powered USB hub. I can see that there is a heading about "Installed cores" but no text.

Just to clarify: I used the Board Manager, located the entry for the Nano 33 IoT and clicked download. It took a while but no errors were reported. As far as I understand the Arduino terminology, this will have installed (or not) the appropriate core.

By core, I assume you mean all the register location and content definitions are needed for software development for bare processors (no OS).

I shall try a powered USB hub tomorrow and see what that does.

Is there any way I can give you more information? - It seems clear that something has not installed. As far as I can see, the USB driver is missing. Is there some way I can install this missing piece- according to the Board Manager everything got installed.

Thanks in advance for your further help.

Regards,

Paul.

With the core installation for the new NANO's I saw drivers also added at this end.
You are mostly correct in that it would normally be the definitions etc.

Just going by my own experience here with win7 x64 pro that was all.

There should be three pictures that just show the method used.
I will also add some text too so thanks for that.

Bob.

@Paul58513

Raspberry Pi running Raspbian needs 32-bit executables. Do not use 64-bit binaries. If the binary says "Linux" but not "Linux ARM" then it almost always for Intel/AMD CPUs so will not work on Raspberry Pi CPUs (all ARM).

Try the "Linux ARM 32 bits" version of the Arduino IDE on the Pi4 . Do not install the IDE using apt or apt-get. See the following for downloads and instructions.

Hello Poki,

Thanks for the suggestion. I tried the ARM 32bit version as you suggest.

I get a failure report - ./java/bin/java: cannot execute binary file: Exec format error

Any ideas?

Regards,

Paul.

Do you have it running on any OS yet ?
If so which ?

Bob.

Hello Bob, Poki

Thanks for the suggestions from the two of you.

Background:
I did get the Web Editor to run in Chrome on a MacBook Air. I also wrote a sketch, downloaded it and it worked. The problem is that I do not want to use this computer in my lab. I've got other machines there for software and hardware development.

Poki:
I have just managed to get the IDE to run on the RPi 4. There seemed to be problems with the shortcuts and I was a bit confused by the fact that the IDE software is not installed in /usr/local/bin (or similar) where I expected it to be.

I may have some problems later because the one file that was in /usr/local/bin is no longer there. I removed it (it was a shortcut anyway) while trying to sort out the shortcut problem.

Bob:
So at the moment I have Web Editor on a MacBook and IDE on an RPi 4.

I would prefer to use Web Editor via Chrome on any machine (RPi 4, PC) rather than being restricted to individual installations.

I am going to continue trying to get the IDE or Web Editor to work on a Windows 7 machine.

As far as planned projects are concerned - although not completely happy that I cannot use Web Editor on any machine with Chrome - I am good to go.

If I find out what the problem is with my Windows 7 machines, I shall let you now - it might be of general help.

Now let's see what this Nano 33 IoT can do ....

Regards,

Paul.

Of all your devices win 7 should have been the easiest.