IDE reports 'system cannot find the file specified' during Save

Recently started experimenting with Arduino IDE (1.18.13) with ESP32 Wroom32 chips
I have compiled a number of example projects OK without too much trouble

But I do run into a problem where the IDE fails to save the project at compile time, or if I press the Save in the file menu or the Down Arrow icon

This occurs after I have made a number edits which Save OK, then I compile a sketch and upload to ESP32, run Serial Monitor to view debug stuff, and that works OK
BUT
If I now go on to make further edits, I am now unable to save and get the below error when compiling

Only way to clear it is to restart the IDE

Edit :

  1. Tried Running IDE as Administrator - same issue
  2. After using Verify/Compile, after the next edit the save will fail in same way
  3. Tested with a blank sketch - just empty setup and loop - saves fail after compile

PC
Windows 10 (64 bit) - Version 10.0.19041 Build 19041
8GB Ram

Error as reported in IDE

The system cannot find the file specified
java.io.IOException: The system cannot find the file specified
at java.io.WinNTFileSystem.createFileExclusively(Native Method)
at java.io.File.createTempFile(File.java:2024)
at processing.app.BaseNoGui.saveFile(BaseNoGui.java:886)
at processing.app.SketchFile.save(SketchFile.java:287)
at processing.app.Sketch.save(Sketch.java:138)
at processing.app.SketchController.save(SketchController.java:352)
at processing.app.Editor.handleSave2(Editor.java:1908)
at processing.app.Editor.access$1000(Editor.java:117)
at processing.app.Editor$11.run(Editor.java:1888)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
at java.awt.EventQueue.access$500(EventQueue.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:709)
at java.awt.EventQueue$3.run(EventQueue.java:703)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
The system cannot find the file speci

OK - so decided to uninstall and start again

I have uninstalled Arduino, and D/loaded again and re-installed - but it does exactly the same thing

Because even though I uninstalled, once its re-installed It still has all the ESP32 board info set up etc in Board manager

So this info must be stored somewhere else - registry etc ?

Can someone point me to a procedure to do a complete un-install so it forgets all references to ESP32
So I can perform a clean install

Ok
It looks like its stored at
C:\Users<username>\AppData\Local\Arduino15

So deleted that folder

Now the re-install of Arduino, is clear of ESP32 info

I follow these instructions to add ESP 32 support

Load up a previous sketch
do a number of edit / save cycles - completes ok no error
do a compile - completes ok no error

Now try an Edit / Save cycle

And the save problem is back - the Save fails with the same error !!!

Thats about as clean a re-install as I know how to do

Odd how the file can be found fine to be able to edit and save but once the compile process is performed it seems to have lost access to the file ?

Just borrowed a laptop, done same install procedure on it at and all works correctly

So definitely something odd on my PC

But what ?