IDE serial monitor problem [SOLVED]

Hi, folks,

I’m experiencing strange problem with Arduino IDE 1.5.2 on Linux. Everything works fine, I can compile and download a sketch, sketch runs … so far, so good. But, when I try to use the “serial monitor” function from the IDE, there is an error message, saying cannot open the comm port of the Arduino and in /var/lock, there is a lock from process number of the IDE. Thus, the /dev/ttyACM0 (I am using UNO) cannot be monitored. But the download of the code is possible further, so, the port is available.

Formerly it worked both, now, without any known reason, this problem appeared.

What is strange, for some small projects I am alternatively using my clone of Ard Mini, too. There, I am using an plain Prolific serial converter … and while using this, I can normally download sketch and monitor serial, as usual. In this case, the lock file for /dev/ttyUSB0 does not appear …

I suspect the Java IDE from doing this … but why? When I manually delete the lock, it appears again. I am not a Java programmer to trace it down. Any idea? Thanks …

Karel from Prague, CZ


Problem solved. For some, unknown reason, the IDE wrote nonsense value to the configuration file, key “serial.debug_rate”. In my case a random number, not even similar to any standard baud rate. Thus, the attempt to re-configure the ACM serial channel at the start of serial monitor process failed … And did not in a case of hardware serial port. Different driver, different behaviour.

Thus, assign ANY STANDARD baudrate to this key in the IDE’s “preferences.txt” manually and everything is okay back …

About a day of debugging and searching … Anyway, thanks to all, who replied my post with some helpful information … 0 in total. Good night, sleep tight, don’t let the bed bugs bite.

Karel