IDE was working but now will not open

Hello,

I installed Arduino IDE v1.05 2 days ago and it was working fine - I was able to create, upload and run sketches to my Nano v3.0 from my WIN 7 PC.

Now I have a problem - after attempting to import a new library, the IDE just hangs when I try to start it. I tried various things to solve this but nothing has worked. I noticed that someone had posted a similar issue a few weeks ago, but can not find his post here now. I have also searched Google and the troubleshooting section, with no success.

Here are the steps I have taken so far:

  • searched GOOGLE and the troubleshooting guide
  • remove preferences.txt file
  • remove and re-install ARDUINO IDE v 1.05
  • remove ARDUINO IDE v 1.05 and install ARDUINO IDE V1.5r2
  • restore my PC to before I loaded ARDUINO IDE and re-install ARDUINO IDE V1.5r2
  • update JAVA to v55 from v51
  • verified that Microchip MPLABX which also uses JAVA still works properly
  • started arduino_debug.exe to see what it’s output is

Any ideas? I have attached screen shots of two of the messages I get.

Thanks!

ARDUINO_noStart.JPG

Does anyone have any solution to my problem? I tried installing the LINUX version of the IDE on one of my other PC’s but it keeps freezing the PC! It’s odd all other applications run on my pc’s except this Arduino IDE…

I found the post by someone else who had a very similar problem: http://forum.arduino.cc/index.php?topic=233961.msg1684759#msg1684759 but I still don’t have a solution.

Hopefully I can get the IDE running so I can see what the Arduino is all about.

UPDATE: I just found out what the problem is, but am not sure how to fix it yet.

Here is my exact problem: Infinite recursive library import · Issue #2005 · arduino/Arduino · GitHub

But now the problem is that Windows won’t let me easily remove that long set of folders it created! (SEE BELOW)

C:\Users\Mark\DOCUME~1\Arduino\LIBRAR~1\Arduino\LIBRAR~1\Arduino\LIBRAR~1\Arduino\LIBRAR~1\Arduino\LIBRAR~1\Arduino\LIBRAR~1\Arduino\LIBRAR~1\Arduino\LIBRAR~1\Arduino\LIBRAR~1\Arduino\LIBRAR~1\Arduino\LIBRAR~1\Arduino\LIBRAR~1\Arduino\LIBRAR~1\Arduino

Over 30 voyeurs looked at my post but not a single answer after a few days, that is very interesting as I doubt I am the only one with this problem.

bad_lib.JPG

I feel like i am talking to myself as there are no replies, but here is an update to my problem.

Last night I saw that a very deep directory structure had been created by the Arduino IDE. I had thought it was about 250 folders deep, so started off by renaming all the folders to a single letter ‘a’ but in fact it was over 2700 folders deep! If you have ever tried removing such a structure on a windoze PC, you will know it isn’t easy. (try using windows exploder to do so and you will see what I mean)

I looked around for utilities to do this, and found that there is a program called 'robocopy" in WIN7 and that it should work. I’ll tell you now that in my case, robocopy just failed after running for a minute or so. I had to go look for something else…

After surfing the net some more, I came across a program called “Deep Remove”. https://deepremove.codeplex.com/

I had to run this overnight and it also stopped about 8 times, but after 8 re-starts, it had removed the stairway to heaven created by the ARDUINO IDE.

I just attempted a re-install of ARDUINO IDE 1.05 and it actually appears to open now!

How can such a fatal flaw that took me over 8 hours to resolve actually be in this ARDUINO IDE, and it does not appear that any of the developers is actually working on a fix.

I have to wonder, is a program that creates a directly structure like this which is very hard to remove actually classified as MALWARE?

I ran into this same problem today with the 1.5.7 IDE and luckily found this thread. Used the deep remove tool linked to (worked in a single run that took about 10mins for me though), and I'm back up and running.

Thanks to MarkD for running this solo thread.

It was driving me crazy. Deepremove solves the problem.

Thanks MarkD

Its IDE problem Just download latest version of IDE.

Let me know latest error you are getting.

Also check when you unzip library put in to IDE (XXX date) from date whether you update the java definition on not.