IDE will not compile code for ESP8266. Exit status -1073741515

I have spent the past week trying to get the ESP8255 board working under the Arduino IDE. I could not get the latest version to list any of the ESP82xx boards in the boards menu after adding the extra board in Preferences. After a couple of total re-installations (including removing folder Arduino15) and no luck I dropped back to version 1.8.0. I now have all the ESP82xx and many others listed. I have tried the example Blink sketches etc and no matter what I do I cannot get the IDE compiler to get past

exit status -1073741515
Error compiling for board NodeMCU 1.0 (ESP-12E Module).

The board is listed on comm3. I have tried all variants of the ESP92xx with the same result. I have googled and googled and cannot find an answer to this error. As it is not a comms issue to the board (never gets as far as talking to the board) I believe it will be a library or setup problem. There are no other errors in the log so no pointers. I'm told to self isolate for at least 12 weeks so have plenty of time to work on this. Any help greatly appreciated.

Thanks in advance :slight_smile: