IDE will not run under MAC 10.5.8

Latest MAC code fails to run SYSTEM LOG reproduced below.

Jul 30 15:06:30 Unknown-00-1f-5b-bd-22-2b [0x0-0xb90b9].cc.arduino.Arduino[1843]: [JavaAppLauncher] Requested [1.5*], launching in [1.6] instead. Jul 30 15:06:30 Unknown-00-1f-5b-bd-22-2b [0x0-0xb90b9].cc.arduino.Arduino[1843]: JavaVM: Failed to load JVM: /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/bundle/Libraries/libjvm.dylib Jul 30 15:06:37: --- last message repeated 1 time --- Jul 30 15:06:30 Unknown-00-1f-5b-bd-22-2b [0x0-0xb90b9].cc.arduino.Arduino[1843]: JavaVM FATAL: Failed to load the jvm library. Jul 30 15:06:30 Unknown-00-1f-5b-bd-22-2b [0x0-0xb90b9].cc.arduino.Arduino[1843]: [JavaAppLauncher Error] JNI_CreateJavaVM() failed, error: -1 Jul 30 15:06:30 Unknown-00-1f-5b-bd-22-2b com.apple.launchd138: Exited with exit code: 1

J.knott

This looks like you could have a corrupted or old version of the Java framework, and the Arduino app is written in Java. I would try re-downloading Java from here: http://support.apple.com/kb/DL971

If that doesn't work your going to have to erase the whole Java framework and reinstall... Tell me if you need any help with that.

Thank you the problem was solved as posted elsewhere, Java was not enabled in Java Preferences.

J.Knott