IDE won't load to boards tried several can't get blink to load ok tool settings

Have several PCs so I have loaded several boards with blink and other programs but on my desk top main the verify and upload both give me exit 1 and say things like this
avr-g++: error: cannot access device-specs for ‘atmega2560’ expected at ‘device-specs/specs-atmega2560’ port reads the device fine and displays the 2560 on the port icon in devices window?
Can read the board serial number… But can not upload anything?

Try reinstalling the Arduino IDE.

On the third installation and second location in the PC system... no change?!!!!!

Please do this:

  • File > Preferences > Show verbose output during > compilation (check) > OK
  • Sketch > Compile/verify
  • When you encounter an error you’ll see a button on the right side of the orange bar “Copy error messages”. Click that button. Paste the error in a reply here USING CODE TAGS (</> button on the toolbar).

Sorry Pert I don't have that setting in file preferences??OS is Win 7 MAybe too old??

Which version of the Arduino IDE are you using?

Arduino: 1.8.2 (Windows 7), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

D:\THE BANK\arduino 1.8.2\arduino-builder -dump-prefs -logger=machine -hardware D:\THE BANK\arduino 1.8.2\hardware -hardware C:\Users\Owner\AppData\Local\Arduino15\packages -tools D:\THE BANK\arduino 1.8.2\tools-builder -tools D:\THE BANK\arduino 1.8.2\hardware\tools\avr -tools C:\Users\Owner\AppData\Local\Arduino15\packages -built-in-libraries D:\THE BANK\arduino 1.8.2\libraries -libraries C:\Users\Owner\Documents\Arduino\libraries -fqbn=arduino:avr:mega:cpu=atmega2560 -vid-pid=0X2341_0X0042 -ide-version=10802 -build-path C:\Users\Owner\AppData\Local\Temp\arduino_build_562984 -warnings=none -build-cache C:\Users\Owner\AppData\Local\Temp\arduino_cache_718849 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=C:\Users\Owner\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.4-arduino2 -prefs=runtime.tools.arduinoOTA.path=D:\THE BANK\arduino 1.8.2\hardware\tools\avr -prefs=runtime.tools.avrdude.path=D:\THE BANK\arduino 1.8.2\hardware\tools\avr -verbose D:\THE BANK\arduino 1.8.2\examples\01.Basics\Blink\Blink.ino
D:\THE BANK\arduino 1.8.2\arduino-builder -compile -logger=machine -hardware D:\THE BANK\arduino 1.8.2\hardware -hardware C:\Users\Owner\AppData\Local\Arduino15\packages -tools D:\THE BANK\arduino 1.8.2\tools-builder -tools D:\THE BANK\arduino 1.8.2\hardware\tools\avr -tools C:\Users\Owner\AppData\Local\Arduino15\packages -built-in-libraries D:\THE BANK\arduino 1.8.2\libraries -libraries C:\Users\Owner\Documents\Arduino\libraries -fqbn=arduino:avr:mega:cpu=atmega2560 -vid-pid=0X2341_0X0042 -ide-version=10802 -build-path C:\Users\Owner\AppData\Local\Temp\arduino_build_562984 -warnings=none -build-cache C:\Users\Owner\AppData\Local\Temp\arduino_cache_718849 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=C:\Users\Owner\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.4-arduino2 -prefs=runtime.tools.arduinoOTA.path=D:\THE BANK\arduino 1.8.2\hardware\tools\avr -prefs=runtime.tools.avrdude.path=D:\THE BANK\arduino 1.8.2\hardware\tools\avr -verbose D:\THE BANK\arduino 1.8.2\examples\01.Basics\Blink\Blink.ino
Using board 'mega' from platform in folder: D:\THE BANK\arduino 1.8.2\hardware\arduino\avr
Using core 'arduino' from platform in folder: D:\THE BANK\arduino 1.8.2\hardware\arduino\avr
Detecting libraries used...
"C:\Users\Owner\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.4-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10802 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR   "-ID:\THE BANK\arduino 1.8.2\hardware\arduino\avr\cores\arduino" "-ID:\THE BANK\arduino 1.8.2\hardware\arduino\avr\variants\mega" "C:\Users\Owner\AppData\Local\Temp\arduino_build_562984\sketch\Blink.ino.cpp" -o "nul"
Exception 0xc0000090 0x0 0x0 0xf2712
PC=0xf2712

syscall.Syscall12(0x771c103d, 0xa, 0x126bc0e0, 0x1230ed80, 0x0, 0x0, 0x1, 0x400, 0x12396000, 0x0, ...)
 /home/jenkins/go/src/runtime/syscall_windows.go:196 +0x4a
syscall.CreateProcess(0x126bc0e0, 0x1230ed80, 0x0, 0x0, 0x1, 0x400, 0x12396000, 0x0, 0x12557328, 0x125572d4, ...)
 /home/jenkins/go/src/syscall/zsyscall_windows.go:583 +0x112
syscall.StartProcess(0x125375e0, 0x6f, 0x122f5c00, 0x1b, 0x1c, 0x125573e0, 0x0, 0x0, 0x0, 0x0)
 /home/jenkins/go/src/syscall/exec_windows.go:326 +0x722
os.startProcess(0x125375e0, 0x6f, 0x122f5c00, 0x1b, 0x1c, 0x12557514, 0x1264a820, 0x0, 0x0)
 /home/jenkins/go/src/os/exec_posix.go:45 +0x293
os.StartProcess(0x125375e0, 0x6f, 0x122f5c00, 0x1b, 0x1c, 0x12557514, 0x0, 0x0, 0x0)
 /home/jenkins/go/src/os/doc.go:28 +0x53
os/exec.(*Cmd).Start(0x12621ad0, 0x0, 0x0)
 /home/jenkins/go/src/os/exec/exec.go:358 +0x6fa
os/exec.(*Cmd).Run(0x12621ad0, 0x0, 0x0)
 /home/jenkins/go/src/os/exec/exec.go:276 +0x2b
arduino.cc/builder/builder_utils.ExecRecipeCollectStdErr(0x124fbd80, 0x56c313, 0x15, 0x101, 0x5f4880, 0x614ef0, 0x0, 0x0, 0x0, 0x0)
 /home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/builder_utils/utils.go:413 +0x118
arduino.cc/builder.(*GCCPreprocRunnerForDiscoveringIncludes).Run(0x124fbd60, 0x122a0000, 0x0, 0x0)
 /home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/gcc_preproc_runner.go:93 +0x23c
arduino.cc/builder.runCommand(0x122a0000, 0x5f39b0, 0x124fbd60, 0x0, 0x0)
 /home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/container_find_includes.go:183 +0x57
arduino.cc/builder.findIncludesUntilDone(0x122a0000, 0x124fbc40, 0x538ca0, 0x123bcfc0, 0x125d1d90, 0xd, 0x0, 0x0)
 /home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/container_find_includes.go:331 +0x1810
arduino.cc/builder.(*ContainerFindIncludes).Run(0x614ef0, 0x122a0000, 0x0, 0x0)
 /home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/container_find_includes.go:149 +0xdfd
arduino.cc/builder.runCommands(0x122a0000, 0x12557cc0, 0x22, 0x22, 0x1, 0x0, 0x0)
 /home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/builder.go:191 +0xe2
arduino.cc/builder.(*Builder).Run(0x12557de4, 0x122a0000, 0x0, 0x0)
 /home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/builder.go:124 +0x89f
arduino.cc/builder.RunBuilder(0x122a0000, 0x0, 0x0)
 /home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/builder.go:222 +0x35
main.main()
 /home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/arduino-builder/main.go:338 +0x1360
eax     0x0
ebx     0x332fd008
ecx     0x0
edx     0x332a0000
edi     0x2a1c
esi     0x332fd000
ebp     0xcf67c
esp     0xcf654
eip     0xf2712
eflags  0x10212
cs      0x23
fs      0x53
gs      0x2b
D:\THE BANK\arduino 1.8.2\arduino-builder returned 2
Error compiling for board Arduino/Genuino Mega or Mega 2560.

Hey Pert Did I lose ya? I still have same symptoms but I switched to another 2560 to check it same results.... Something in my System is not doing the job! I think I should sell this one and get a new one!

Hey I got another inkling just had a Java Error and the ide shutdown??? Anything on JAva??? SE failure??

If you get a failure from Sketch > Compile/Verify then the problem is not related to the 2560. It's a problem with the IDE. So a new 2560 will not help.

I notice the original error is not part of that output you just posted so actually the symptoms have changed.

Please try this:

  • Rename C:\Users\Owner\AppData\Local\Arduino15 to C:\Users\Owner\AppData\Local\Arduino15.bak
  • Restart the Arduino IDE
  • Sketch > Compile/verify
  • If there is an error then post it, following my previous instructions.

The C:\Users\Owner\AppData\Local\Arduino15 folder may be hidden. You can access it by clicking on the link following File > Preferences > More preferences can be edited directly in the file in the IDE.

Arduino: 1.8.2 (Windows 7), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

C:\Arduino1.8.2\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Arduino1.8.2\Arduino\hardware -tools C:\Arduino1.8.2\Arduino\tools-builder -tools C:\Arduino1.8.2\Arduino\hardware\tools\avr -built-in-libraries C:\Arduino1.8.2\Arduino\libraries -libraries C:\Users\Owner\Documents\Arduino\libraries -fqbn=arduino:avr:mega:cpu=atmega2560 -ide-version=10802 -build-path C:\Users\Owner\AppData\Local\Temp\arduino_build_508685 -warnings=none -build-cache C:\Users\Owner\AppData\Local\Temp\arduino_cache_503455 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arduinoOTA.path=C:\Arduino1.8.2\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude.path=C:\Arduino1.8.2\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc.path=C:\Arduino1.8.2\Arduino\hardware\tools\avr -verbose C:\Arduino1.8.2\Arduino\examples\01.Basics\Blink\Blink.ino
C:\Arduino1.8.2\Arduino\arduino-builder -compile -logger=machine -hardware C:\Arduino1.8.2\Arduino\hardware -tools C:\Arduino1.8.2\Arduino\tools-builder -tools C:\Arduino1.8.2\Arduino\hardware\tools\avr -built-in-libraries C:\Arduino1.8.2\Arduino\libraries -libraries C:\Users\Owner\Documents\Arduino\libraries -fqbn=arduino:avr:mega:cpu=atmega2560 -ide-version=10802 -build-path C:\Users\Owner\AppData\Local\Temp\arduino_build_508685 -warnings=none -build-cache C:\Users\Owner\AppData\Local\Temp\arduino_cache_503455 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arduinoOTA.path=C:\Arduino1.8.2\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude.path=C:\Arduino1.8.2\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc.path=C:\Arduino1.8.2\Arduino\hardware\tools\avr -verbose C:\Arduino1.8.2\Arduino\examples\01.Basics\Blink\Blink.ino
Using board 'mega' from platform in folder: C:\Arduino1.8.2\Arduino\hardware\arduino\avr
Using core 'arduino' from platform in folder: C:\Arduino1.8.2\Arduino\hardware\arduino\avr
Detecting libraries used...
"C:\Arduino1.8.2\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10802 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR   "-IC:\Arduino1.8.2\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Arduino1.8.2\Arduino\hardware\arduino\avr\variants\mega" "C:\Users\Owner\AppData\Local\Temp\arduino_build_508685\sketch\Blink.ino.cpp" -o "nul"
Exception 0xc0000090 0x0 0x0 0xf2712
PC=0xf2712

syscall.Syscall12(0x75b1103d, 0xa, 0x12643000, 0x1260a400, 0x0, 0x0, 0x1, 0x400, 0x12671200, 0x0, ...)
	/home/jenkins/go/src/runtime/syscall_windows.go:196 +0x4a
syscall.CreateProcess(0x12643000, 0x1260a400, 0x0, 0x0, 0x1, 0x400, 0x12671200, 0x0, 0x12351328, 0x123512d4, ...)
	/home/jenkins/go/src/syscall/zsyscall_windows.go:583 +0x112
syscall.StartProcess(0x1266c500, 0x3a, 0x12531b20, 0x1b, 0x1c, 0x123513e0, 0x0, 0x0, 0x0, 0x0)
	/home/jenkins/go/src/syscall/exec_windows.go:326 +0x722
os.startProcess(0x1266c500, 0x3a, 0x12531b20, 0x1b, 0x1c, 0x12351514, 0x1236f1e0, 0x0, 0x0)
	/home/jenkins/go/src/os/exec_posix.go:45 +0x293
os.StartProcess(0x1266c500, 0x3a, 0x12531b20, 0x1b, 0x1c, 0x12351514, 0x0, 0x0, 0x0)
	/home/jenkins/go/src/os/doc.go:28 +0x53
os/exec.(*Cmd).Start(0x12626630, 0x0, 0x0)
	/home/jenkins/go/src/os/exec/exec.go:358 +0x6fa
os/exec.(*Cmd).Run(0x12626630, 0x0, 0x0)
	/home/jenkins/go/src/os/exec/exec.go:276 +0x2b
arduino.cc/builder/builder_utils.ExecRecipeCollectStdErr(0x12631420, 0x56c313, 0x15, 0x101, 0x5f4880, 0x614ef0, 0x0, 0x0, 0x0, 0x0)
	/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/builder_utils/utils.go:413 +0x118
arduino.cc/builder.(*GCCPreprocRunnerForDiscoveringIncludes).Run(0x12631400, 0x12390000, 0x0, 0x0)
	/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/gcc_preproc_runner.go:93 +0x23c
arduino.cc/builder.runCommand(0x12390000, 0x5f39b0, 0x12631400, 0x0, 0x0)
	/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/container_find_includes.go:183 +0x57
arduino.cc/builder.findIncludesUntilDone(0x12390000, 0x12631360, 0x538ca0, 0x12615860, 0x12648470, 0xd, 0x0, 0x0)
	/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/container_find_includes.go:331 +0x1810
arduino.cc/builder.(*ContainerFindIncludes).Run(0x614ef0, 0x12390000, 0x0, 0x0)
	/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/container_find_includes.go:149 +0xdfd
arduino.cc/builder.runCommands(0x12390000, 0x12351cc0, 0x22, 0x22, 0x1, 0x0, 0x0)
	/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/builder.go:191 +0xe2
arduino.cc/builder.(*Builder).Run(0x12351de4, 0x12390000, 0x0, 0x0)
	/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/builder.go:124 +0x89f
arduino.cc/builder.RunBuilder(0x12390000, 0x0, 0x0)
	/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/builder.go:222 +0x35
main.main()
	/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/arduino-builder/main.go:338 +0x1360
eax     0x0
ebx     0x32f0d008
ecx     0x0
edx     0x32eb0000
edi     0x1f44
esi     0x32f0d000
ebp     0xcf67c
esp     0xcf654
eip     0xf2712
eflags  0x10212
cs      0x23
fs      0x53
gs      0x2b
C:\Arduino1.8.2\Arduino\arduino-builder returned 2
Error compiling for board Arduino/Genuino Mega or Mega 2560.

Sorry I went to bed but I did run the check for the hidden folder and it is a folder right? Changed the hidden attribute and re-ran compiler??? same results after I re-established the preferences .txt was the lever to pry on I changed it's name and re-ran & got this

Arduino: 1.8.2 (Windows 7), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

C:\Arduino1.8.2\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Arduino1.8.2\Arduino\hardware -tools C:\Arduino1.8.2\Arduino\tools-builder -tools C:\Arduino1.8.2\Arduino\hardware\tools\avr -built-in-libraries C:\Arduino1.8.2\Arduino\libraries -libraries C:\Users\Owner\Documents\Arduino\libraries -fqbn=arduino:avr:mega:cpu=atmega2560 -vid-pid=0X2341_0X0042 -ide-version=10802 -build-path C:\Users\Owner\AppData\Local\Temp\arduino_build_523365 -warnings=none -build-cache C:\Users\Owner\AppData\Local\Temp\arduino_cache_837672 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=C:\Arduino1.8.2\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=C:\Arduino1.8.2\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude.path=C:\Arduino1.8.2\Arduino\hardware\tools\avr -verbose C:\Arduino1.8.2\Arduino\examples\01.Basics\Blink\Blink.ino
C:\Arduino1.8.2\Arduino\arduino-builder -compile -logger=machine -hardware C:\Arduino1.8.2\Arduino\hardware -tools C:\Arduino1.8.2\Arduino\tools-builder -tools C:\Arduino1.8.2\Arduino\hardware\tools\avr -built-in-libraries C:\Arduino1.8.2\Arduino\libraries -libraries C:\Users\Owner\Documents\Arduino\libraries -fqbn=arduino:avr:mega:cpu=atmega2560 -vid-pid=0X2341_0X0042 -ide-version=10802 -build-path C:\Users\Owner\AppData\Local\Temp\arduino_build_523365 -warnings=none -build-cache C:\Users\Owner\AppData\Local\Temp\arduino_cache_837672 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=C:\Arduino1.8.2\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=C:\Arduino1.8.2\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude.path=C:\Arduino1.8.2\Arduino\hardware\tools\avr -verbose C:\Arduino1.8.2\Arduino\examples\01.Basics\Blink\Blink.ino
Using board 'mega' from platform in folder: C:\Arduino1.8.2\Arduino\hardware\arduino\avr
Using core 'arduino' from platform in folder: C:\Arduino1.8.2\Arduino\hardware\arduino\avr
Detecting libraries used...
"C:\Arduino1.8.2\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10802 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR   "-IC:\Arduino1.8.2\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Arduino1.8.2\Arduino\hardware\arduino\avr\variants\mega" "C:\Users\Owner\AppData\Local\Temp\arduino_build_523365\sketch\Blink.ino.cpp" -o "nul"
Exception 0xc0000090 0x0 0x0 0xf2712
PC=0xf2712

syscall.Syscall12(0x75b1103d, 0xa, 0x12315f00, 0x12358800, 0x0, 0x0, 0x1, 0x400, 0x12384800, 0x0, ...)
	/home/jenkins/go/src/runtime/syscall_windows.go:196 +0x4a
syscall.CreateProcess(0x12315f00, 0x12358800, 0x0, 0x0, 0x1, 0x400, 0x12384800, 0x0, 0x12311328, 0x123112d4, ...)
	/home/jenkins/go/src/syscall/zsyscall_windows.go:583 +0x112
syscall.StartProcess(0x125fa880, 0x3a, 0x12596460, 0x1b, 0x1c, 0x123113e0, 0x0, 0x0, 0x0, 0x0)
	/home/jenkins/go/src/syscall/exec_windows.go:326 +0x722
os.startProcess(0x125fa880, 0x3a, 0x12596460, 0x1b, 0x1c, 0x12311514, 0x12589040, 0x0, 0x0)
	/home/jenkins/go/src/os/exec_posix.go:45 +0x293
os.StartProcess(0x125fa880, 0x3a, 0x12596460, 0x1b, 0x1c, 0x12311514, 0x0, 0x0, 0x0)
	/home/jenkins/go/src/os/doc.go:28 +0x53
os/exec.(*Cmd).Start(0x125944d0, 0x0, 0x0)
	/home/jenkins/go/src/os/exec/exec.go:358 +0x6fa
os/exec.(*Cmd).Run(0x125944d0, 0x0, 0x0)
	/home/jenkins/go/src/os/exec/exec.go:276 +0x2b
arduino.cc/builder/builder_utils.ExecRecipeCollectStdErr(0x12637680, 0x56c313, 0x15, 0x101, 0x5f4880, 0x614ef0, 0x0, 0x0, 0x0, 0x0)
	/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/builder_utils/utils.go:413 +0x118
arduino.cc/builder.(*GCCPreprocRunnerForDiscoveringIncludes).Run(0x12637660, 0x12350000, 0x0, 0x0)
	/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/gcc_preproc_runner.go:93 +0x23c
arduino.cc/builder.runCommand(0x12350000, 0x5f39b0, 0x12637660, 0x0, 0x0)
	/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/container_find_includes.go:183 +0x57
arduino.cc/builder.findIncludesUntilDone(0x12350000, 0x126375c0, 0x538ca0, 0x125d5860, 0x12640e70, 0xd, 0x0, 0x0)
	/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/container_find_includes.go:331 +0x1810
arduino.cc/builder.(*ContainerFindIncludes).Run(0x614ef0, 0x12350000, 0x0, 0x0)
	/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/container_find_includes.go:149 +0xdfd
arduino.cc/builder.runCommands(0x12350000, 0x12311cc0, 0x22, 0x22, 0x1, 0x0, 0x0)
	/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/builder.go:191 +0xe2
arduino.cc/builder.(*Builder).Run(0x12311de4, 0x12350000, 0x0, 0x0)
	/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/builder.go:124 +0x89f
arduino.cc/builder.RunBuilder(0x12350000, 0x0, 0x0)
	/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/builder.go:222 +0x35
main.main()
	/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/arduino-builder/main.go:338 +0x1360
eax     0x0
ebx     0x331fd008
ecx     0x0
edx     0x331a0000
edi     0x890
esi     0x331fd000
ebp     0xcf67c
esp     0xcf654
eip     0xf2712
eflags  0x10212
cs      0x23
fs      0x53
gs      0x2b
C:\Arduino1.8.2\Arduino\arduino-builder returned 2
Error compiling for board Arduino/Genuino Mega or Mega 2560.

Got the blink to start to compile but it hangs and dumped three pages attached of crap I can’t cypher???

Arduino compiler error 5-31-17.doc (29 KB)

You have a rather exotic problem.

pert:
If you get a failure from Sketch > Compile/Verify then the problem is not related to the 2560. It's a problem with the IDE. So a new 2560 will not help.

I notice the original error is not part of that output you just posted so actually the symptoms have changed.

Please try this:

  • Rename C:\Users\Owner\AppData\Local\Arduino15 to C:\Users\Owner\AppData\Local\Arduino15.bak
  • Restart the Arduino IDE
  • Sketch > Compile/verify
  • If there is an error then post it, following my previous instructions.

The C:\Users\Owner\AppData\Local\Arduino15 folder may be hidden. You can access it by clicking on the link following File > Preferences > More preferences can be edited directly in the file in the IDE.

Did you do this? (note - appdata is a hidden folder - you don't need to make it unhidden or anything, but you won't see it if you try to navigate to it in explorer if you don't have show hidden files enabled)

The key part is renaming the Arduino15 folder to something other than Arduino15 - that way, when the IDE starts, it will not see the old Arduino15 folder, and will create a fresh one, hopefully without whatever contents are causing the problem. The IDE stores a lot of stuff in that location, and if bad stuff somehow ends up there, it can cause really weird compile problems (why does it use that weird location? Since Vista, windows security policy is such that that's one of the few locations the IDE can be assured of having permissions to write to)

Yeah, I was hoping the problem was caused by the Arduino IDE using the AVR-GCC in Arduino15 instead of the version included with the the IDE installation as the original error reported was from avr-g++. Unfortunately the latest error output shows that the problem is also happening when using AVR-GCC from the Arduino IDE installation.

I'm stumped but maybe someone else can help with this. It would be ideal to get the latest version of the IDE working but there are a couple workarounds you could try if all else fails:

  • Try older IDE versions: Arduino - OldSoftwareReleases, starting with 1.8.1. 1.6.5 is the newest version before arduino-builder (the program giving the error) was added.
  • Use the Arduino Web Editor: Arduino Cloud

I GOT IT! Weird but for some reason I had a thumb drive in the usb port with the usb cable from the board and for some reason it seems to preferr the closer AVR base files I noted on different errors that the file locations were scattered between three places the old Arduino files I had "stashed" and the thumb drive with a copied load of the ide and the loaded and running system!!! Man the file control is goofy on the IDE I was getting files from all three locations in one compilation! Of course when it went back to the next file instead of to the ones that had been edited it was lost and went into NaNA land!!! But it compiles and now I can make my card blink and it loaded the old file for my Jig and I am writing code for the new controller!!! Yeah! but why would the IDE pickup files that were not in the system when I loaded the exe????? I'm too stupid to figure this out I just know its operational as long as I don't plug in the thumb drive!!! There needs to be some work done on the arduino usb interface me thinks !! Hey thanks a bunch guys and I'll be back if it does something else screwy!!!

David

I don't Got it I am loading the older version of IDE now! Apparently I have something wrong with something important!

Loaded the 13 version and got the same response too many errors for me to ponder a resolve too I deleted the ...15 file after I stopped processes on the avrg++.exe seems that the avr is started every time you compile a set of code and I only know that it won't let you clean out Arduino files completely till you kill that process and the code isn't getting shut down properly!! Some one in management out there listening?????

HELP!!!

Well I have gone through the c Drive and removed anything that looked Arduino I suppose I have done irreprable harm to the system may be I need to refreash the windows??? Don’t see why I can get the compile to work on blink now but not the upload??? Something like a big hammer needed to fix this mess!!

dcan5:
Don't see why I can get the compile to work on blink now but not the upload????

It's probably a completely different problem. Please do this:

  • File > Preferences > Show verbose output during > upload (check) > OK
  • Sketch > Upload
  • When you encounter an error you'll see a button on the right side of the orange bar "Copy error messages". Click that button. Paste the error in a reply here using code tags.