Idle does not work with Timer0

Hey,
I am just trying to low the energy consumption of my arduino and so I installed the LowPower(.h) library.
I need to use the Timer0 because I wanna create some kind of a watch. And there comes the problem: if I use "LowPower.idle(SLEEP_1S, ADC_OFF, TIMER2_OFF, TIMER1_OFF, TIMER0_OFF, SPI_OFF, USART0_OFF, TWI_OFF); " everything is allright but if I set the TIMER0 ON (because of my watch application with time.h) the controller does not sleep for 1 second.
The simplest programm I could imagine to show my problem is a modified blink:

that works:
#include <LowPower.h>
/
int led = 13;

void setup() {
pinMode(led, OUTPUT);
}

void loop() {
digitalWrite(led, HIGH);
LowPower.idle(SLEEP_1S, ADC_OFF, TIMER2_OFF, TIMER1_OFF, TIMER0_OFF,
SPI_OFF, USART0_OFF, TWI_OFF);
digitalWrite(led, LOW);
LowPower.idle(SLEEP_1S, ADC_OFF, TIMER2_OFF, TIMER1_OFF, TIMER0_OFF,
SPI_OFF, USART0_OFF, TWI_OFF);
}

that not:

#include <LowPower.h>
/
int led = 13;

void setup() {
pinMode(led, OUTPUT);
}

void loop() {
digitalWrite(led, HIGH);
LowPower.idle(SLEEP_1S, ADC_OFF, TIMER2_OFF, TIMER1_OFF, TIMER0_ON,
SPI_OFF, USART0_OFF, TWI_OFF);
digitalWrite(led, LOW);
LowPower.idle(SLEEP_1S, ADC_OFF, TIMER2_OFF, TIMER1_OFF, TIMER0_ON,
SPI_OFF, USART0_OFF, TWI_OFF);
}

What can I do to let both run together? Is there a connection between sleep and timer0???

THX
Jonny

sry guys, is there no answer for me????

If you leave timer0 on it will interrupt every 1.024ms, which might be the issue?

Just to get you right: you think my timer gets an overflow and because of that the interupt awakes my idle?
but is there a oportunity to solve my problem?

EDIT: interrupts(); and noInterrupts(); before and after my idle task is not running :~

timer0 is configured to interrupt every 1.024ms, that's how millis(), micros() and delay() work.

okay, but how to handle that problem now?
I need timer0 because of my real time application with time.h

Is there a way to tell time.h to work with timer1?

You just need to switch off timer0 interrupts before sleeping and turn them on again
afterwards, perhaps?

  TIMSK0 = 0 ;   // timer 0 all interrupts disabled
  TIMSK0 = 0x1 ;   // timer 0 overflow interrupts enabled

I already tried this one too, but couldn’t fix it with TIMSK

I am that desperate, that I am thinking about using a real time clock which works even if the arduino is in powerdown mode (like that one from China: http://www.ebay.de/itm/DS1302-Real-Time-Clock-Module-mit-CR2032-3V-Batterie-fur-Arduino-NEU-/191136140796?pt=Wissenschaftliche_Geräte&hash=item2c809a0dfc) but i don’t know if this is the best alternative…

Is there a way to tell time.h to work with timer1?

No, because time.h doesn’t do anything directly with timers. It relies on millis() operating correctly.